New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iPhone Hardware and Accessories Discuss iPhone hardware

Solution: iPhone 3G Data Service Not Working


Post Reply New Thread Subscribe

 
Thread Tools
Jaygray

 
Jaygray's Avatar
 
Member Since: Mar 04, 2008
Posts: 1,115
Jaygray is a jewel in the roughJaygray is a jewel in the roughJaygray is a jewel in the rough
Mac Specs: Unibody MacBook Pro 2.26, 4gb RAM, 500gb HD

Jaygray is offline
After pulling my hair out for two days trying to get the data service on my iPhone back up and running, thought I'd post my fix. I found a few threads with similar problems, but no posted solutions.

My 3G internet service wasn't working. Voice service worked perfectly. Screen showed full 3G signal strength. Apps which required an online connection could not connect. Mail could not connect to mail servers. But when I connected via WiFi, everything worked perfectly.

Rebooted the phone. Reset Network Settings. Did a full restore via iTunes and reinstalled all my apps. All the usual troubleshooting steps. Fiddled with it for two days and still wouldn't work.

Here's what did: Settings > General > Network > Disable 3G. Went back to the home screen. Signal strength briefly drops and then reappears without the 3G symbol next to it. Settings > General > Network > Enable 3G. Went back to home screen again. 3G symbol reappears a moment later. Works great ever since.

Somehow turning the 3G switch on and off resets something that isn't reset by rebooting the phone or even a full system restore.

Hope this helps someone else with the same problem...
QUOTE Thanks
ZEEK

 
Member Since: Jul 08, 2009
Location: NY
Posts: 206
ZEEK has a little shameless behaviour in the past
Mac Specs: 13" MBP, 3GS & iPhone4 Factory Unlocked.

ZEEK is offline
Im not running my iphone on at&t but i would like to thank you for posting this solution, it might come handy for others here
QUOTE Thanks
james515

 
Member Since: Mar 28, 2008
Posts: 223
james515 is an unknown at this point

james515 is offline
Quote:
Originally Posted by ZEEK View Post
Im not running my iphone on at&t but i would like to thank you for posting this solution, it might come handy for others here
thats not a problem with the AT&T network, its a device fault.

if it was a network error, the 3G internet connection would have been reestablished once the phone was rebooted, however since reboots, and a system restore did not fix the problem, and it took turning 3g off and back on to fix the problem, this leaves only one thing, the iPhone itself
QUOTE Thanks
ellefruit

 
Member Since: Jan 26, 2011
Posts: 1
ellefruit is on a distinguished road

ellefruit is offline
I'm not on AT&T, nor do I reside in the US. Actually I'm on SoftBank in Japan, but I found this gem of advice via google and registered precisely to say THANK YOU!! I was panicking this morning when the data had stopped working.

You've saved me a LOT of hassle.
QUOTE Thanks
Jaygray

 
Jaygray's Avatar
 
Member Since: Mar 04, 2008
Posts: 1,115
Jaygray is a jewel in the roughJaygray is a jewel in the roughJaygray is a jewel in the rough
Mac Specs: Unibody MacBook Pro 2.26, 4gb RAM, 500gb HD

Jaygray is offline
Welcome to MF! Hope you come back and visit us again!

The funny thing is... I don't even remember posting this or even having this problem. If you asked me for help, I wouldn't have remembered the answer. Glad Google dug it up for you!
QUOTE Thanks
comovartia

 
Member Since: Sep 07, 2009
Posts: 14
comovartia is on a distinguished road
Mac Specs: 2007 mac mini core2duo, snow lepord, 1 gig mem

comovartia is offline
Even though you don't remember this problem thanks for the info. I've been going crazy for the last couple days trying to figure out why I had no 3G service. Problem Solved.
Thanks again
QUOTE Thanks

Post Reply New Thread Subscribe


« Iphone 4 screen protector | Erase all content on iphone while jailbroken »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 12:13 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?