Results 1 to 2 of 2
  1. #1

    Member Since
    Aug 04, 2008
    HELP : Ipad 2 not Restoring : tried updating firmware from 4.3 to 6.0 :(
    I can't find the correct sub forum to put this topic in, So i decided to put it under IPAD
    Mods, please correct me if I am wrong.

    Last evening i tried to do a firmware update to my ipad 2.
    It was running on 4.3.x and I decided to go for IOS 6. SO I downloaded the new Itunes (the ;latest one)

    It asked me to backup my 57 GB on the ipad.
    It downloaded the new IoS software and in event of updating I don't know what happened and finally an error occured saying that the device can't update.

    Now, I what i see is a black screen with Itunes and the USB cable showing to connect to it.

    Please help me...I don't know what to do to bring this back to life. I am certainly feeling a bit bad about the upgrade..

    thanks in advance.

  2. #2

    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Victoria, BC
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    Put the iPad into DFU mode:

    Tip: How to put your iPhone or iPad into DFU mode |

    Then restore from your previous backup.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Restoring software and firmware
    By user350044 in forum iPhone Hardware and Accessories
    Replies: 2
    Last Post: 05-02-2011, 07:40 PM
  2. Remotely updating TC firmware
    By CapeFlyer in forum Internet, Networking, and Wireless
    Replies: 7
    Last Post: 12-29-2010, 08:31 PM
  3. Question about restoring and firmware
    By HonestIllusion in forum iPhone Hardware and Accessories
    Replies: 4
    Last Post: 06-10-2010, 09:30 AM
  4. re updating firmware on a G3 B/W
    By Wabbit in forum Switcher Hangout
    Replies: 2
    Last Post: 12-04-2007, 07:13 AM
  5. Firmware Updating
    By GotMac? in forum OS X - Operating System
    Replies: 3
    Last Post: 02-16-2005, 03:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts