New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iOS and Apps All your questions and discussion of iOS or iOS Apps.

iPad browser problem with ios7


Post Reply New Thread Subscribe

 
Thread Tools
colinwg

 
Member Since: Jan 04, 2013
Posts: 4
colinwg is on a distinguished road

colinwg is offline
Now I've upgraded to ios7 on my iPad, all browsers (safari, Chrome, Mercury) have same problem in that they no longer return to the last place on previous page. So I might be reading a newspaper article summary half way down a page, then click on it to get more detail, which opens a new page, but on returning to first page it opens somewhere near the top. I've tried uninstalling and reinstalling Mercury as a test, but no difference. As the problem is with all browsers I'm wondering if it could possibly be an ios7 issue. Any suggestions for solving would be gratefully received.
QUOTE Thanks
TattooedMac

 
TattooedMac's Avatar
 
Member Since: May 19, 2009
Location: Waiting for a mate . . .
Posts: 7,882
TattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant future
Mac Specs: 21" iMac 2.9Ghz 10.9.4 13"MBP 2.9Ghz i7 Yosemite 10.10 ~ iPhone5 iOS 8 ~ iPad Mini iOS 8 ~ ATV3 6.1

TattooedMac is offline
Can i try and understand you more ?? Do you mean, if you touch on a link, and it loads that link in the same page, then you hit the back button and the page loads again, but near the top, is that whats happening ? If this is what you mean. I have done this just now in Safari, Chrome, Dolphin and Atomic, and i get taken back to the point of the page i was reading.
I would say you have had a corrupt upgrade.

and in this instant, its always backup first and then see if you can go here and download the iOS 7 .ispw then via iTunes hold down Option while you click Restore and navigate to the downloaded .ispw and restore from a clean iOS 7 then restore from backup.

A way around this is too, long hold the link, and open in a New Tab and read then close. ??

Dont forget to use the Reputation System if someone has helped you out !!!
Arguing with a zealot is only slightly easier than tunneling through a mountain with your forehead!!!!!
MoTM ☆☆☆
QUOTE Thanks
colinwg

 
Member Since: Jan 04, 2013
Posts: 4
colinwg is on a distinguished road

colinwg is offline
Many thanks for a quick reply TattooedMac, you've understood the problem correctly. I'll give your suggestion a try.
QUOTE Thanks
colinwg

 
Member Since: Jan 04, 2013
Posts: 4
colinwg is on a distinguished road

colinwg is offline
Problem persists even with fresh install of ios7. However, it seems to be particularly online newspapers that have this problem (example is Washington post or Daily Telegraph, but you have to scroll well down a page to test whether the browser is returning to the same point). Other sites I've now tried, such as Wikipedia and New Scientist magazine, work fine. I'm puzzled.
QUOTE Thanks
TattooedMac

 
TattooedMac's Avatar
 
Member Since: May 19, 2009
Location: Waiting for a mate . . .
Posts: 7,882
TattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant futureTattooedMac has a brilliant future
Mac Specs: 21" iMac 2.9Ghz 10.9.4 13"MBP 2.9Ghz i7 Yosemite 10.10 ~ iPhone5 iOS 8 ~ iPad Mini iOS 8 ~ ATV3 6.1

TattooedMac is offline
HMmm yea well im out of idea's and it could even be the way those papers have written their code for Mobile devices ?? Not 100% sure, BUT it is a possibility. If i was you, i would be doing a Long Hold on the Link then Open in a Different Tab then close that Tab down when done, which will bring you back to the page and place you left ?!?!? Its all i have lol

Dont forget to use the Reputation System if someone has helped you out !!!
Arguing with a zealot is only slightly easier than tunneling through a mountain with your forehead!!!!!
MoTM ☆☆☆
QUOTE Thanks
vansmith

 
vansmith's Avatar
 
Member Since: Oct 19, 2008
Location: Toronto
Posts: 18,352
vansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond reputevansmith has a reputation beyond repute
Mac Specs: 2012 13" MBP (2.5 i5, 8GB)

vansmith is offline
The problem happens across browsers because, underneath, they're all the same. Apple does not allow applications into the App Store that interpret code (effectively all a browser does when opening a webpage) so each browser actually uses Safari's WebKit component underneath. Thus, behaviours in one are likely to appear across all browsers.

Given that it happens on only a few pages, I'm willing to bet that it has something to do with how the page ie designed. How that's so is beyond me but this might be something that you have to deal with.

Important Links: Community Guidelines : Use the reputation system if you've been helped.
M-F Blog :: Write for the blog
Writing a Quality Post
QUOTE Thanks

Post Reply New Thread Subscribe


« iPad disappeared from iTunes during IOS7 update | Restoring a backup from old iPad to new iPad »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Weird iPad problem Boomer2012 iPad Hardware and Accessories 2 01-28-2012 01:27 PM
Problem Syncing iPad and iCal - Wired orbit79 iOS and Apps 1 08-06-2010 11:35 PM
iPad Activation Problems diand iPad Hardware and Accessories 5 08-03-2010 05:31 PM
The iPad: A Review/Story! MinaMACMan iPad Hardware and Accessories 13 06-06-2010 10:32 PM
Web Browsers novicew OS X - Apps and Games 80 04-10-2010 12:02 PM

All times are GMT -4. The time now is 07:28 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?