New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iOS and Apps All your questions and discussion of iOS or iOS Apps.

Why is my mobile number greyed out in iMessage?


Post Reply New Thread Subscribe

 
Thread Tools
Trolle

 
Member Since: Feb 11, 2009
Posts: 389
Trolle is on a distinguished road

Trolle is offline
I was experiencing difficulties in syncing iMessages across my MBP, iPad, and iPhone.

A friend sent me an iMessage which I did not receive on my MBP, so I followed the steps suggested in a previous thread:

Quote:
Log into your AppleID on the Apple site and ensure you have your iPhone telephone number recorded.

Then go into Messages on your iPad and make sure you can see the number in the send/receive messages list. You may need to toggle iMessage off and on to refresh.
on my iPhone under iMessage settings the setting:
You can be reached by iMessage at:
Which has my cell phone and 3 email addresses (gmail, iCloud and me) shows the cell phone number check marked but greyed out.

On my iPad the settings are the same but the phone number is not greyed out

Just curious why that is.

Plus, on another note: if I send an iMessage from my iPhone to someone but they are not online should the message not revert to an SMS (I have the Send as SMS when iMessage is unavailable...)? A friend sent me an iMessage but I did not receive until I was back within wifi coverage. Would have liked to have gotten that message as an SMS.

15" MBP, 2.4 GHz, 8 GB RAM, OSX 10.8.3
iPod Classic (7th generation)
iPad Mini, 64GB Cellular (1st generation), iOS 6.0.2
iPhone 5
QUOTE Thanks
mrplow

 
mrplow's Avatar
 
Member Since: Oct 01, 2007
Location: UK
Posts: 6,749
mrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond reputemrplow has a reputation beyond repute
Mac Specs: 27" iMac i7 (2011) 10.10, iPhone6, iPad Air, AppleTV2

mrplow is offline
The number on your iPhone should be greyed out because it's something you can't change. The iPad however, not being tied to a phone number doesn't display it this way.

To make sure that everything is in sync log into the apple website with your ID and ensure your telephone number is recorded in there.

Regarding your SMS query, that function will only work on an iPhone when sending. How your settings are regarding SMS are not relevant in this case. Whether you receive an SMS is down to how it was sent so it's down to how the sender has their settings and whether they sent the message from an SMS capable platform. I.e. if they sent you an iMessage from an iPad of Mac you will not get an SMS.

Another issue to consider is your data plan. If you have a data signal you should be able to send and receive iMessages, it's not dependant on wifi if you have 3g/4g.

External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

Please use the reputation system if you think you've been helped - top right of this post
QUOTE Thanks
rabbitjetta

 
rabbitjetta's Avatar
 
Member Since: Nov 08, 2010
Location: Indiana
Posts: 940
rabbitjetta is on a distinguished road
Mac Specs: 13" Retina Pro, iPhone 5, iPad 4, iPod touch 3-5, iMac 27

rabbitjetta is offline
Try turning off imessage on the iPhone and turning it back on after you restart the phone. Then do the same on the mac and any other device that you are using iMessage for.
QUOTE Thanks
drlikme

 
Member Since: Jun 03, 2013
Posts: 7
drlikme is on a distinguished road

drlikme is offline
I had similar issues, including not syncing iMessages across Mac und iOS devices, and nothing really helped. Then I removed all iMessage preference plists on the Mac and reset everything on iOS and set up a new password for the iCloud account. Now it finally seems to work! You might wanna give it a try!
QUOTE Thanks

Post Reply New Thread Subscribe


« Apple Configurator: Question about "Restore" | The calendar app on my iPad Mini only shows Google events since 2 months ago? »
Thread Tools

Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
First-ever Macworld Mobile to be held at 2011 Mobile World Congress the8thark Apple Rumors and Reports 0 09-07-2010 02:12 PM
thanks Windows Mobile. you're much better than the iPhone lpn iPhone Hardware and Accessories 5 06-09-2008 05:45 PM

All times are GMT -4. The time now is 05:01 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?