Ok, I've been fighting this for a while and thought I could fix it on my own but I don't know what else to do.

The problem is that whenever I sync my iPhone 4 or iPad (1st Gen) in iTunes (wireless or plugged in) I get as far as step 3 "Syncing Contacts" and it just hangs. I mean it goes forever! Nothing ever happens. This started sometime around January or February of this year. I don't know what changed. I've had my MBP since 2008 and my iPhone 4 since Nov, 2010. They have always worked fine together. Recently it became a big pain when I added a group in Address Book on my Mac that I wanted to sync with my phone because it's so much easier (for me) to type a bunch of #'s and addresses (copy/paste) with the Mac than with the iPhone. Anyways, when I open iTunes and it sees my iPhone, I click on the Info tab to see my contact groups. Well, the new one I created isn't there. It doesn't show up. I made sure to close Address Book after working in it. I tried closing iTunes and re-opening it. I restarted my phone and restarted my MBP.

I don't know if this is an Apple ID problem somehow, but I'm throwing this out there...
My Apple ID is older and is not an email address. When I set up Find My Phone back whenever that was a new feature, it required an Apple ID that is an email address. So I used my gmail email as an Apple ID. Well, technically that isn't the same Apple ID as what I use for iTunes, and my iOS devices. Could that make any difference? Did I somehow confuse the crap out of iTunes? I don't know. I'm just wondering why I'm having so much trouble. It also won't backup my iPhone or iPad anymore.