New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iOS and Apps All your questions and discussion of iOS or iOS Apps.

How to avoid iOS 5 duplicate entries on WeekCal and Calendar?


Post Reply New Thread Subscribe

 
Thread Tools
JonasThorbjoern

 
Member Since: Oct 14, 2011
Posts: 2
JonasThorbjoern is on a distinguished road

JonasThorbjoern is offline
Hi guys!

Just updated my iPhone 4 to iOS 5 and found that Week Cal (which Iīm using as my standard calendar app) has duplicated every entry.
I donīt sync via iTunes, since they already warn that that would create duplicates.

Have anyone experienced the same thing?
AND found a solution to this?

Best,
Jonas

(Hey, my first post on the MacForum!
QUOTE Thanks
Mac2Dream

 
Member Since: Oct 14, 2011
Posts: 2
Mac2Dream is on a distinguished road

Mac2Dream is offline
I, too, just updated to ios5 on iPhone and iPad. Getting duplicate entries in iCal and Reminders on both devices. Also, my calendar list is crazy. Calendars I didn't create have appeared (on the device as well as my desktop) and each calendar is duplicated.

I'm sure it's something right in front of me; but, I'm not seeing it. Help!

Thanks.
QUOTE Thanks
Mac2Dream

 
Member Since: Oct 14, 2011
Posts: 2
Mac2Dream is on a distinguished road

Mac2Dream is offline
First check the Calendar preferences/Accounts and make sure there aren't duplicates. If so, back up your data and then delete the duplicate.

Easier still.... I didn't find a duplicate account under iCal prefs. So I went to THE CLOUD, opened up my calendar and unchecked the duplicates. You can tell immediately if you're unchecking the right one because your events will disappear if you're wrong. Of course, if that happens, just check it again. Once you uncheck the RIGHT duplicate.... click on EDIT and delete. Same goes for Reminders.

Voila! Open up the iOS devices, and watch THE CLOUD push changes to them. No more duplicates.

I'm so pleased with myself. Hope it's all good for you too!

QUOTE Thanks
JonasThorbjoern

 
Member Since: Oct 14, 2011
Posts: 2
JonasThorbjoern is on a distinguished road

JonasThorbjoern is offline
So the only way to do this is to buy the latest version of Lion (since I donīt have it) and uncheck each (of the many!) duplicated entries from the calendar?
QUOTE Thanks
pendlewitch

 
Member Since: Sep 10, 2011
Location: Nelson,UK
Posts: 1,739
pendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of light
Mac Specs: iMac 27" Mid 2010, 3.2GHz Intel Core i3,4GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Mavericks 10.9.4

pendlewitch is offline
Quote:
Originally Posted by JonasThorbjoern View Post
So the only way to do this is to buy the latest version of Lion (since I donīt have it) and uncheck each (of the many!) duplicated entries from the calendar?
I would say that you most definitely do need the the latest version of Lion( it is in the minimum system requirements). After 4 days of confusing and illogical syncs and only half a job up and running on iOS5/iCloud I noticed what the specs say and upgraded last night. I had been holding off because I had been unsure about Lion and some negative reports but this is ultimately futile because you will not get the full experience otherwise.

My iPhone now syncs seamlessly with my iMac over iCloud and my system is benefitting from the enhancements that Lion brings.

With regards to the duplication problem that you have this is caused by having both "on my Mac" and "iCloud" calendars checked to sync on your iPhone whereas you need to uncheck the local calendars and just keep the iCloud calendar checked. This will then become the default and your problems will go away, but not fully until you go Lion.

iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
MOTM October 2012. These days normally happy with an occasional grumble.
QUOTE Thanks
ALR26

 
Member Since: Oct 21, 2011
Posts: 3
ALR26 is on a distinguished road

ALR26 is offline
I recently discovered that by default, iOS 5 shows ALL calendars associated with your Apple ID. For me, I have my iMac using iCal, iCloud, and my iPhone, so iOS 5 calendar shows all 3 calendar locations on my iPhone. All I had to do was open Calendar in iOS 5 go to Calenders at the top and uncheck "All from My Mac", and "All from my iPhone" and leave iCloud checked. Since all my devices sync with iCloud, thats the only calendar I need to see on my iPhone. I'm not sure if this is a glitch with iOS 5 and iCloud or is by design. Calendars on my iMac should be directly synced with iCloud and not have a local copy, but I'm still trying to figure it out myself.

As a note, the "All from my iPhone" only shows up if you have any calendar entries stored locally on an iOS device like the iPhone or iPod, and probably the iPad (but I don't have an iPad to confirm).

My contacts have not duplicated, and I've made sure not to create any local contacts on any device...they're all on iCloud.
QUOTE Thanks
ALR26

 
Member Since: Oct 21, 2011
Posts: 3
ALR26 is on a distinguished road

ALR26 is offline
I've also discovered that Notifications will also show duplicates due to iTunes having Calendars and Contacts checked to sync. According to discussions on Apple, the resolution here is to tell iTunes not to sync your contacts and calendars and to only sync the iOS 5 device to use iCloud for contacts and calendars.

I'll give this a try when I get home tonight from work.

Hope all this helps.

Al
QUOTE Thanks
pendlewitch

 
Member Since: Sep 10, 2011
Location: Nelson,UK
Posts: 1,739
pendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of lightpendlewitch is a glorious beacon of light
Mac Specs: iMac 27" Mid 2010, 3.2GHz Intel Core i3,4GB 1333 MHz DDR3, ATI Radeon HD5670 512MB, Mavericks 10.9.4

pendlewitch is offline
Quote:
Originally Posted by ALR26 View Post
I've also discovered that Notifications will also show duplicates due to iTunes having Calendars and Contacts checked to sync. According to discussions on Apple, the resolution here is to tell iTunes not to sync your contacts and calendars and to only sync the iOS 5 device to use iCloud for contacts and calendars.

I'll give this a try when I get home tonight from work.

Hope all this helps.

Al
That's good work

iMac 27-inch Mid 2010 (wow....that old...eeeks!), WD My Book 1TB Firewire,WD My Passport Air 500GB, Magic Mouse,Magic Trackpad,
iPhone 5C, iPod Nano 4GB 3rd Gen, ATV2.
MOTM October 2012. These days normally happy with an occasional grumble.
QUOTE Thanks
ALR26

 
Member Since: Oct 21, 2011
Posts: 3
ALR26 is on a distinguished road

ALR26 is offline
UPDATE:

I got home from work and opened iTunes. Now that I am syncing via WiFi, all I had to do was click on my iPhone under Devices and uncheck "Sync iCal Calendars" and then apply. It sync'd and my calendars and contacts and the pull-down notifications menu is all correct now. No duplicates anymore.

I suppose you want the option "Sync Address Book Contacts" uncheck also in iTunes to correct any duplicate contacts that might appear for some of you with that issue too.

Here's what I learned with OS X Lion 10.7.2, iPhone 4S with iOS 5, iCloud, iTunes 10.5 (141), iCal, Mail, and Notifications in iOS 5:

Syncing iTunes with the two options "Sync Address Book Contacts" and "Sync iCal Calendars" checked, will cause iTunes to create copies of your address book and iCal data to the iOS 5 device(s). This is unnecessary if you have iCloud and Lion simply because iCal and Calendar on Lion are most likely setup to use iCloud now. This was done automatically during the migration from MobileMe to iCloud as well as new iCloud users during setup (unless you didn't or haven't setup iCloud on Lion).

Basically, iTunes was putting copies of iCal and Calendar from Lion onto your iOS 5 device which already has it from iCloud.
QUOTE Thanks
joeg679

 
Member Since: Jun 08, 2011
Posts: 244
joeg679 is on a distinguished road
Mac Specs: MacBook Pro 6-2011, iPad 1, 2&3, iPhone 4s, ATV2

joeg679 is offline
I currently sync my contacts manually through itunes. If I turn tat off and the icloud on to sync the events, will my events get deleted somehow?
QUOTE Thanks
pathfinder10

 
Member Since: Sep 19, 2012
Posts: 1
pathfinder10 is on a distinguished road

pathfinder10 is offline
Hi, I followed the steps above to prevent duplicate tnries, i.e unticked sync for calenadars and contacts, but now some a[ppointments have dropped out of my desktop outlook.

OK I have removed duplicates but I have lost important dates!

Help.
QUOTE Thanks

Post Reply New Thread Subscribe


« iOS6 update question | Updated To iOS 6 and Now I Can't Access Wifi »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 09:26 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?