Results 1 to 10 of 10
  1. #1


    Member Since
    Oct 13, 2011
    Posts
    2
    Angry Is iMessage useless on a wifi only iPad 2?
    I downloaded ios5 and wanted to try to message my friend. He has an iphone4, I don't know if he has ios5 yet. It would not send a message at all. The apple website said when referring to iMessage:
    "*For iPad with 3G, normal carrier data rates may apply."

    Does that mean iMessage for wifi iPad 2 is just a useless app?

  2. #2

    Chuckoir's Avatar
    Member Since
    Sep 21, 2011
    Location
    London, Londonshire, England.
    Posts
    726
    Specs:
    13" Late 2011 MBP,iPad '3' 32gb,iPhone4 32gb
    This is from the Apple website, which I found by typing "iMessage" into google. :p

    Apple - iOS 5 - See new features included in iOS 5.

    "You can send unlimited messages via Wi-Fi or 3G from you iPad...."

  3. #3


    Member Since
    Oct 13, 2011
    Posts
    2
    So I guess I should ask everyone, is there anyone out there with a wifi only ipad2 that has iMessage up and working?

  4. #4

    yzfmik's Avatar
    Member Since
    Nov 27, 2009
    Posts
    197
    The person you're sending the message to has to have iOS 5. I've been texting all day on my wi-fi iPad2.
     MacBook Pro 13" 2.4GHz
     MacBook Pro 13" 2.26GHz
     iMac 21.5" 3.06GHz /  iPod 30GB /  iPhone 5 32GB
     iPad 2 64GB / 3rd Gen iPad 64 GB/ iPad Mini 32GB

  5. #5

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,963
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    It's working on my WiFi iPad I 16GB. People on the other end have to have IOS5.

  6. #6


    Member Since
    Oct 13, 2011
    Posts
    1
    Working here too.

    EDIT***
    Figured out the picture question, iPad only apparently. Sorry to thread-jack.

  7. #7


    Member Since
    Oct 10, 2011
    Posts
    29
    Quote Originally Posted by Billyw715 View Post
    So I guess I should ask everyone, is there anyone out there with a wifi only ipad2 that has iMessage up and working?
    Works for me, was using it last night.

  8. #8

    Feniks80's Avatar
    Member Since
    May 23, 2010
    Location
    La Habra, CA
    Posts
    111
    I tried this last night from my iPod Touch to my friends iPad with Wi-fi. Like the others stated, it's free, but only with other iOS 5 users.

  9. #9


    Member Since
    Oct 14, 2011
    Posts
    2
    Not working on iPad 1
    Hi, this thread is very interesting. I have an iPhone 4 and an iPad 1. Both now on IOS 5. iMessage on iPhone working fine exactly as described. My son has iPhone 4 with IOS 5 and we're texting to one another over wifi with no problem. My iPad will not send or receive a thing. Any ideas? Thanks

  10. #10


    Member Since
    Oct 14, 2011
    Posts
    2
    Sorry, should say the iPad is wifi only but iCloud all enabled etc.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Had to restore iPad, now can't iMessage non-iOS device
    By skybolt in forum iPad Hardware and Accessories
    Replies: 3
    Last Post: 08-02-2015, 11:05 PM
  2. Permanently delete imessage from iPhone, iPad, iCloud??
    By hel35 in forum iPhone Hardware and Accessories
    Replies: 10
    Last Post: 04-06-2015, 12:42 PM
  3. Apple Starts Changing iPad WiFi + 4G Name To WiFi + Cellular
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 0
    Last Post: 05-13-2012, 10:00 AM
  4. iPad contacts don't work for FaceTime and iMessage.
    By Amguitarman in forum iPad Hardware and Accessories
    Replies: 2
    Last Post: 10-29-2011, 08:03 AM
  5. Inside Apple's iOS 5: iMessage to bring proprietary chat to iPhone, iPad
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 0
    Last Post: 06-10-2011, 04:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •