Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   iOS and Apps (http://www.mac-forums.com/forums/ios-apps/)
-   -   RedSnow cannot reboot tethered 3GS 4.2.1 ipad BB (http://www.mac-forums.com/forums/ios-apps/249592-redsnow-cannot-reboot-tethered-3gs-4-2-1-ipad-bb.html)

cojobt 09-03-2011 02:39 PM

RedSnow cannot reboot tethered 3GS 4.2.1 ipad BB
 
Hi,

I have been going round in ever increasing circles for about three days now trying to unlock my 3GS on 4.2.1 with the dreaded 04.15.04 BB. After much trial and error I opted for the RedSnow option and updated the BB to the iPad 06.15.00 Baseband.

This worked - the phone worked after install with network coverage, the updated BB, but no working Cydia and Safari was unstable (crashed 2 seconds after opening every time). The Cydia logo was blank. When I tried to open it, the page/screen would flash open then crash immediately.

Forgive the lack of clarity here, but I think I first tried to run RedSnow again and 'Install Cydia only', but that didn't work, so I may have tried to run Green Poison at this point, but that didn't work either.

I have restarted the phone and of course it goes straight to the Activation/iTunes logo.

I cannot escape this.

RedSnow fails to reboot the iphone. It gets as far as the rebooting stage, the screen goes white, then RedSnow gives an error message.

I have tried restoring using a Pwnage Tool created Custom Firmware via iTunes with Tiny Umbrella running, but this does nothing. I have tried using TU to fix recovery, and recboot also, but they do nothing. I have attempted using GreenPoison again, and several other combinations of the above but nothing works.

In addition, I have two 'iPhones' appearing in my iTunes sidebar. iTunes informs me twice that I have an iPhone in restore mode.

Can anyone offer any advice on how to get out of this cycle?

I am on a Mac, using an iPhone 3GS, MC model, running 4.2.1, with SHSHs saved (also for 4.1 and a couple of others, including 3.1.3), have jailbroken using RedSnow 0.9.6rc16 installing 4.2.1 and 06.15.00 BB, and am about to have a nervous breakdown.

cojobt 09-03-2011 06:10 PM

As a follow up, I managed to get it sorted all by my little old self and feel jolly proud about it all too!

After much rummaging around the internet, I put the phone in DFU mode, opened iTunes, Restored to a Pwnage 4.2.1 Custom Firmware. Got 1601 error. Closed iTunes. Connected iphone to different USB port. Opened iTunes. Restored to the aforementioned Custom Firmware with Tiny Umbrella running.

It worked. iPhone finally restored to 4.2.1 with fully functioning Cydia too, and I believe it is untethered (the RedSn0w one was tethered).

However, there was no network. I found a suggestion about going into Settings/General/Network, turning off 3G and on again, but this did nothing.

I then read something about using Ultrasn0w.

I have since installed Ultrasn0w and have made a couple of calls on my new, non-official carrier, and I am very happy about it!

So, if anyone finds themselves in a similar pickle, try the following:

Download Custom Firmware.
Put iPhone in DFU mode.
Open iTunes.
Use Alt/Shift Restore to select Custom Firmware.
If you get a 1601, close iTunes, change USB port and go through the previous steps again.

No Network?
Go to Settings/General/Network.
Turn off 3G.
Turn on Data Roaming.
Turn on 3G again.
(This didn't work for me, but others report success).

If this does not work, try:
Open Cydia
Go to Manage
Sources
Edit
Add
Type 'repo666.ultrasn0w.com' - note: the '0' is the number 0, not the letter 'o'.
Confirm and install.

This unlocks your phone, and for some wonderful reason reactivates your connection.

cojobt 09-03-2011 06:19 PM

A further follow-up: the phone is stuck in Safe Mode which is not too much of a problem but I'd prefer if it weren't. I think this happened after installing SBsettings, which I can't access cos I'm stuck in Safe Mode.

Also, this is definitely an untethered jailbreak, which is massive bonus!

Finally, although I am on the 06.15.00 I seem to have no problems with GPS. The Compass is working as it should and Google Maps found me.


All times are GMT -4. The time now is 06:34 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.