Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   iOS and Apps (http://www.mac-forums.com/forums/ios-apps/)
-   -   Delete mail on iPhone (http://www.mac-forums.com/forums/ios-apps/241898-delete-mail-iphone.html)

neilf 06-20-2011 01:00 PM

Delete mail on iPhone
 
Hi all,
Can someone educate me on this.
It would appear that when I delete an email from my iPhone, it is immediately deleted from that account on the ISP server.
Is this the normal function?
If so, is it possible to delete mail from iPhone, but leave it on the server?
Any help appreciated.

Neil

dtravis7 06-20-2011 01:24 PM

Configure Apple iOS (iPad / iPhone / iPod Touch) Device

Talks about that setting toward the bottom of the page.

neilf 06-20-2011 04:07 PM

Thanks for the reply but.....
i know about that setting (delete from server) and I have it set to "never".
Yet my emails are being deleted.

chas_m 06-22-2011 08:15 AM

If you are using an IMAP server, then what you do on the iPhone (read, forwarded, deleted) is replicated on the server.

neilf 06-22-2011 02:39 PM

I am using POP3 not IMAP. So I'm still confused as to why my emails get deleted from my ISP server when I delete them on my iPhone4

chas_m 06-23-2011 06:46 AM

POP3 is designed for email to be handled by a single machine. Through preferences, you can set it to handle the concept of more than one machine, but that's not really what it was designed for.

So, in POP, one of the machines that is checking the email is the "primary machine," the one that after IT checks the email, the email is deleted off the server (remember -- POP is not designed to store email on the server, no matter what prefs you have set, and ISPs have different rules about whether they will store ANY of your email -- and for how long -- once your primary machine has accessed it).

It sounds like the root of the problem is that your iPhone 4 has become the primary machine.

I'm sure someone more familiar with the intricacies of POP3 manipulation can find a solution to the problem, but in the meantime just set your email account (via the webmail interface) to forward everything to a free GMail IMAP account, and set your machines to all check the IMAP account only. Problem solved permanently.


All times are GMT -4. The time now is 02:51 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.