I want to restore my iPhone 3GS after a jailbreak. The firmware version is 4.3.3. When ever I go to iTunes alt and click on restore and select the firmware (which I downloaded), then I confirm it, it does the restore and a little way into doing it, it comes up with error 1015.

Now, I have searched the internet for hours to find a fix for 1015. But, nothing seems to work. I have used tiny umbrella, then did the process by exit recovery mode - that didn't work, it just comes back up with the plug into itunes screen. I have also used the fix recovery within Tiny Umbrella, but that just puts some writing on iphone screen about greenposion.

I have also tried putting it into DFU mode and then select the restore file via iTunes, but that didn't work either.

I have also tried downloading a previous iPhone firmware (4.2.1 & 4.3), but when I select the ipsw shortly after it says that the iPhone isn't elegible for the requested build.

I have pretty much tried everything that I have found on the internet.

iTunes 10.3.1
iPhone 3GS (need 4.3.3 on it)
Originally Jailbroken with Redsn0w 0.9.6rc16
Used Tiny Umbrella v5