Dev-Team Blog

The 4.3.1 untether works on all devices that actually support 4.3.1 except for the iPad2:

iPhone4 (GSM)
iPod touch 3G
iPod touch 4G
AppleTV 2G (PwnageTool only for now)

WARNING WARNING — ultrasn0w users don’t update yet! We need to first release an update to ultrasn0w that fixes some incompatibilities when FW 4.3.1 is used on the older basebands supported by ultrasn0w. And remember once we do fix ultrasn0w for 4.3.1, you must only get there via a custom IPSW from PwnageTool, Sn0wbreeze or xpwn! Don’t ever try to restore or update to a stock IPSW, or you’ll lose the unlock!