New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
iOS and Apps All your questions and discussion of iOS or iOS Apps.

iPhone 3GS not switching to EDGE automatically


Post Reply New Thread Subscribe

 
Thread Tools
drum

 
Member Since: Nov 29, 2009
Posts: 3
drum is on a distinguished road

drum is offline
Hi all,

Having issues with my iPhone since I've received it less than a month ago. I have a data plan and when I'm at home and connected to Wifi, all's good. Once I leave the house, the phone won't automatically switch over to the Edge network if I try checking my mail or surf the net.

I've tried switching off the Wifi option, enabling the 3G option, but nothing works. The only way I can get it to function if I'm outside a Wifi coverage area is by rebooting the phone and then all's good... But that's starting to get a bit annoying.

Is there something I should be doing to make this process easier to use? Should I be switching off the Wifi function before leaving my house, or should the phone *automatically* switch over toe Edge on its own?

I was under the impression that once out of a Wifi zone, the phone (with a data plan) would just switch over to Edge without me having to do anything specific.

Any thoughts on whether the phone is defective?
QUOTE Thanks
drum

 
Member Since: Nov 29, 2009
Posts: 3
drum is on a distinguished road

drum is offline
I see this all the time with folx being unable to switch over to Wifi, or just generally having issues with Edge taking over the Wifi controls, but never with Edge being unable to connect...

Anyone?
QUOTE Thanks
Kash

 
Kash's Avatar
 
Member Since: Dec 03, 2006
Location: Irvine, CA
Posts: 9,385
Kash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant futureKash has a brilliant future
Mac Specs: Black Macbook C2D 2GHz 3GB RAM 250GB HD iPhone 4 iPad 3G

Kash is offline
Is your iPhone jailbroken? I noticed that I have trouble accessing the Internet on my phone on 3G/EDGE ever since I jailbroke my phone. It works perfectly fine on Wi-Fi. If you are jailbroken, then I think the only solution is to restore back to factory settings.


June 2007
July 2009
QUOTE Thanks
drum

 
Member Since: Nov 29, 2009
Posts: 3
drum is on a distinguished road

drum is offline
No, it's not jailbroken.

Thanks for replying though. I'll try resetting it and if it persists, I guess I'll give my service provider a ring and see if the phone is defective. I can't see why else it would be constantly struggling to access 3G/EDGE network...
QUOTE Thanks
james515

 
Member Since: Mar 28, 2008
Posts: 223
james515 is an unknown at this point

james515 is offline
have you tried to reset the network settings on the phone?

Tap Settings
Tap General
Tap Reset
Tap Reset Network Settings
This will cause your iPhone to restart, and will delete any stored Wi-Fi passwords as well as DNS settings and more. It may, however, restore your ability to join a stubborn wireless network, let you access stalled Web pages, or eliminate issues with EDGE data access that can occur for various reasons.
QUOTE Thanks
pabrognara

 
Member Since: Nov 02, 2011
Posts: 2
pabrognara is on a distinguished road

pabrognara is offline
Hi

Im also facing a similar issue on my Iphone:

Whenever I leave a WiFi network, I need to restart my iPhone in order for it to successfully start using the Edge network again. Five bars and the little E show that I am connected to Edge, however, without the restart, the iPhone simply doesn't connect to anything (Mail, Safari, Contacts/ActiveSync Directory search). The little circle spins and spins, the phone heats up, and the battery drains quickly as it continually attempts to negotiate network access.

Once I restart it, Edge is back to normal (meaning painfully slow, but working). I jump on Wifi several times a day, so I am restarting my iPhone several times a day.

My device is the Iphone 4 and IOS 5. If someone has the solution, pls let me know. Tried many things (also resetting the network connection) except restoring but any success.
QUOTE Thanks

Post Reply New Thread Subscribe


« Picture Quality | Photo texting seems slow with ios5? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

All times are GMT -4. The time now is 07:38 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?