Results 1 to 6 of 6
  1. #1


    Member Since
    Jun 08, 2009
    Posts
    2
    How do I upgrade from iTunes 4 to 7.7.1?
    OK....I am new to all of this, so bear with me! I have a Power Mac G4, running 10.3.9. I would like to use an iPod shuffle, but understand that I need to upgrade my iTunes (4). But whatever I upgrade to has to work on my old 10.3.9! Ugh! I don't want to upgrade my OS now. What can I do and where can I find it? I have searched a bit on line and have become very frustrated!

  2. #2

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,494
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    google search for "download itunes 7.7" reveals this as the 2nd link
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  3. #3


    Member Since
    Jun 08, 2009
    Posts
    2
    I went there. After I installed it, it said that iTunes x could not be installed on this computer. What's that all about?

  4. #4

    Eric559's Avatar
    Member Since
    Jul 18, 2007
    Location
    Central California
    Posts
    3,185
    Specs:
    2.16GHz C2D MacBook w/ 2GB RAM & 120GB HD. HTC Droid Incredible.
    Your operating system is out of date. It's too old to use with your iPod shuffle.
    Member Of The Month for December '08.
    It's only the internet!

  5. #5

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,494
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    iTunes 7.7 requirements call for:

    - 500MHz G3 processor or better;
    - QuickTime 7.4.5 or later;
    - 256MB RAM;
    - 10.3.9

    Eric is correct if you have the new shuffle, here are the minimum requirements.

    - USB 2.0 port
    - Mac OS X v10.4.11 or later
    - iTunes 8.1 or later
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  6. #6

    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,782
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    Quote Originally Posted by tammccagg View Post
    But whatever I upgrade to has to work on my old 10.3.9! Ugh! I don't want to upgrade my OS now.
    While I do understand the frustration of upgrading or the lack of necessity, you will be three iterations of OS X behind in 3 months when Snow Leopard gets released. My guess is that when SL gets released, even less software will work with Panther. You are going to eventually have to bite the bullet and upgrade to at least Tiger.
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do you have to upgrade to itunes 10?
    By spugnug in forum OS X - Apps and Games
    Replies: 9
    Last Post: 12-16-2011, 07:13 AM
  2. itunes bad upgrade
    By davidgreer99 in forum OS X - Apps and Games
    Replies: 3
    Last Post: 03-28-2009, 12:15 PM
  3. I have: itouch 1.1.5, itunes 8.0.1 I need 2.0 upgrade
    By coldplays in forum iOS and Apps
    Replies: 0
    Last Post: 11-04-2008, 08:30 PM
  4. iTunes upgrade
    By BinaryPunk in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 07-06-2007, 10:34 PM
  5. iTunes 4.9 upgrade...
    By pharme in forum OS X - Apps and Games
    Replies: 1
    Last Post: 07-19-2005, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •