Results 1 to 7 of 7
  1. #1

    Member Since
    Mar 28, 2009
    Iphone 3G updating apps are 'stuck'

    firstly, Iíve got an iPhone 3G, and donít currently have a home computer that i can 'synch' my phone to.. i DO however have a friend who also has an iPhone and who lets me update my phone etc from her PC when I need to.

    basically it hasnít been a problem not to have a PC to use with my iPhone as i just download songs & apps direct from iTunes onto my phone, which until now i havenít had any problems with.

    however...last night i went into app's and had about 6 updates that appeared. i didnít want to update all the others listed as i was planning on deleting some of them, however 2 that i DID want to update were a weather application and the other one was facebook.

    so i started the update for the weather app, and then i went back to apps and started the facebook app update.

    thatís where my problems started. basically both app updates seemed to get 'stuck'. they appear on the screen as kind of 'see thru', with 'loading...' written underneath and the little progress bar is just empty...AND...nothing happens.... they stayed like this for ages. so i tried turning my phone on and off multiple times. Each time iTunes would ask me for my iTunes password as though it was about to complete the download. but then nothing.

    over nite i turned my phone off and left it charging. this morning when i turned it back on i was asked for my iTunes password again....and after entering it i lightly 'tapped' the weather app (not sure why i did this??? and amazingly it loaded up!!!

    however, i still cant get the facebook app to load up, have turned the phone on /off/on/off heaps of times etc. and annoyingly i cant even just delete the app (and then id just reload it later), bcos it wont let you delete it (i.e. no little X to delete).

    im getting frustrated and so have been fiddling about with the phone and went back into the apps and had 2 more updates for other apps i (perhaps stupidly?!?) hit 'update all'........and now i have facebook plus 2 other apps sitting trying to load...AND...nothing happening!

    So.... now i donít know what to do?? Iím guessing that if i went and used my friends PC i could perhaps fix it somehow? but getting to my friends place is a bit of a bother and might take a week or so. if i have to then thatís what Iíll do. but i have read about doing a 'hard reset' where you press and hold the home and on/off buttons for 10secs (or something like that) and wonder if this would help at all? Iím just not sure if the problem is with my phone or with iTunes maybe?? if its iTunes then i doubt a hard reset would help?

    anyway, if i do a hard reset can anyone tell me what exactly this will do?? what does it actually reset? will it mean losing any info in my phone? contact info? my songs? my apps? i donít really care about the apps, but losing songs and other contacts info etc would be a problem.

    sorry this is SOOO long. if anyone can offer advise id appreciate it.


  2. #2

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    27" iMac i7 (2011) 10.10, iPhone6, iPad Air 2, AppleTV2
    First things I'd try is a full reset as mentioned - hold the lock and home button until you see the silver apple logo in the centre of the screen.

    If that doesn't work why not delete the app and then restart, then download it 'afresh'. To delete an app. Touch and hold any icon until they wobble and then hit the X on the apps you want to delete. All you info etc on your facebook app is held on your web based Facebook account so once you re-install and login you won't have lost anything.

    External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

    Please use the reputation system if you think you've been helped - top right of this post

  3. #3

    Member Since
    Mar 28, 2009

    thanks for replying.

    do you know if i try the full reset, does that wipe stuff from the iphone? like contacts etc?

    as i mentioned in the original post- there is no ability to delete the apps using the little X. that would have been the first thing id have done.

    the apps that are 'stuck' in download start wiggling, but the X does not appear- so i cant delete them. maybe i could if i could connect to a PC but thats not an option at the moment.

    ive done some investigating on the net, reading about others with the same problem. and i think my prob has started from an app i tried to download a few days ago using McDonalds free gave me a msg saying it could not be downloaded but the icon is still on my phone saying 'waiting'........and since then i have had this prob trying to update other apps.

  4. #4

    MacJenny's Avatar
    Member Since
    Jan 30, 2009
    DC Metro
    15" Aluminum unibody MBP, Intel core duo 2.4GHz proc, 4MB DDR3 RAM,
    A full reset will not wipe your phone to my knowledge. I think it's similar to a battery pull.

    I had the app update problem on 2 apps as well, can't remember which ones. The only way I was able to resolve it was to update via iTunes on the computer and re-sync everything. Maybe you could do that on your friend's PC?
    Good luck.
    15" aluminum unibody MacBook Pro, 32gb White iPhone 3GS, 160gb iPod

  5. #5

    ńyla's Avatar
    Member Since
    May 10, 2009
    Los Angeles CA
    Overpowered PC kthx. Just have an iPhone <3
    The same EXACT thing is happening to me at the moment. I hit the update all option (stupidly...) and I had 13 ::sigh:: apps that needed to upgrade. This has been three days now. I wasn't sure if it was that I was also downloading a new and large game (MYST).
    Just like you said Jules... I was frustrated and clicked on a random "loading" app which started to download to my disbelief.
    I ended up turning off my wireless and then back on. But the loading icon that looks like an asterisk wasn't displaying so I opened the app store. For some reason or another this seemed to trigger a couple more to actually finish but I am still stuck with two that will not download. I can pause one but not the other. Not that it seems to matter...
    Adding insult to injury, all of the phone functions are slowed dramatically as it's in a constant state of loading.

    Anyone have any ideas that don't include a master reset or deleting the apps?

  6. #6

    Member Since
    Jun 17, 2009
    The full reset worked for me. Thanks!

  7. #7

    Member Since
    Nov 17, 2011
    Smile Guess my 17 yr old daughter is a genius :D
    Hello guys
    Stumbled on this forum while searching for solution to the same annoying problem. Nothing helped, shared it with my daughter, she turned off both wifi and cellular data on my 3gs and lo the waiting apps icons were gone in an instant. Joined this forum thinking to help you guys with another option to get rid of the problem I had been experiencing since two days. Good luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Apps not updating
    By joshjrg in forum OS X - Apps and Games
    Replies: 7
    Last Post: 07-01-2015, 12:21 PM
  2. Updating Apps on iPhone
    By myracarr in forum iOS and Apps
    Replies: 3
    Last Post: 12-08-2013, 05:27 AM
  3. updating apps.
    By jtpie in forum OS X - Apps and Games
    Replies: 1
    Last Post: 10-21-2012, 07:45 PM
  4. iPhoto is stuck in the middle of updating a facebook album
    By KirklanAMoss in forum OS X - Apps and Games
    Replies: 1
    Last Post: 12-05-2009, 05:11 AM
  5. Trouble updating apps from iPhone
    By leerobert in forum iOS and Apps
    Replies: 1
    Last Post: 09-09-2008, 11:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts