Results 1 to 9 of 9
  1. #1

    Member Since
    Feb 28, 2008
    Airport Extreme Printing
    I recently purchased the Airport extreme and I am using it as my wireless router connected to my PC. I connected my printer to the Airport Extreme and I have [somehow] managed for my printer's name (Epson Stylus CX6400) to pop up in the list of printers when I go to print. However, whenever I print it tells me that there was a problem printing.. does any body have any ideas on what I should do ? Your help would be greatly appreciated !

  2. #2

    Kash's Avatar
    Member Since
    Dec 03, 2006
    Irvine, CA
    Black Macbook C2D 2GHz 3GB RAM 250GB HD iPhone 4 iPad 3G
    Here is an unofficial list of compatible USB printers

    Glancing through it, it seems as though the CX6400 is not supported, which could possibly be the reason why you're getting that error.

    June 2007
    July 2009

  3. #3

    Member Since
    Jan 11, 2008
    Dallas, TX
    Too many to specify! :)
    Is there an updated list anywhere? I'm having a similar issue printing to my Canon MP500 through XP. It prints just fine via OS X (why wouldnt it!? ).

  4. #4

    Member Since
    Apr 01, 2008
    imac 20in screen 1gb ram
    Epson RX 595 works fine when connected directly to computer, will not work via airport extreme.
    Will Epson and Apple correct this problem? I had a 6600 recently until it died and it worked okay via airport.
    Are there other drivers that will make this work?


  5. #5

    Member Since
    Apr 03, 2008
    Quote Originally Posted by mapmaker View Post
    Epson RX 595 works fine when connected directly to computer, will not work via airport extreme.
    Will Epson and Apple correct this problem? I had a 6600 recently until it died and it worked okay via airport.
    Are there other drivers that will make this work?


    Download and install the latest driver from the Epson website. Afterwards "reset the printing systems" and re-add the printer on the print and fax menu under system preferences...

    Hope it works!!

  6. #6

    Member Since
    Jul 17, 2008
    I got a 500 Time Machine...lovely ... all works fine EXCEPT the wireless printing thing ... I can still hardwire my HP6210 into the macbook and it works fine but the wireless thing doesn't work... the printer status says printer ready/ thinks about it for about 8 seconds. and then the status switches from printing to stopped.

    have tried turning off the printer and the computer (in an attempt to reset everything...) .. what is weird is that I was jacking with it yesterday ... trying all kinds of combinations and it DID work *one* time.. don't know what ii did to make that work.. but I did get it to work for one sheet.

    but not now...

    any thoughts..

  7. #7

    Member Since
    Feb 10, 2009
    This is my first post here, so I hope to start with the right foot!

    This problem seems to be caused by incomplete device addresses in Zeroconf (aka Bonjour) created queues in Mac OS Leopard. It's not a driver issue, so it's no use trying different driver versions.

    Since all printers in Mac OS X are managed under the hood by a piece of software called CUPS, I thought maybe I could use CUPS to try and fix printers connected to my Airport base stations...

    Here is how I fixed my problems with both an Epson Stylus D120 and an Epson Stylus Office T33 (both of these are essentially the same printer as the Epson Stylus C120 sold in the US or the C110 sold elsewhere).


    1) Connect the printer to one of your Mac's local USB ports.
    2) Open System Preferences/Print and Fax to make sure the printer is recognized.
    3) Print a test page to make sure the printer is addressable.
    4) Open CUPS printers page at http://localhost:631/printers
    5) Notice that the Device URI: line ends up in something like "serial=hexadecimal number", where hexadecimal number is the needed information for the following steps to work. This number is unique for each printer that has an USB port. It's generated with the printer's serial number by EPSON's initialization program, which is ran at the factory. In my case it was "serial=4B4D544B3030323597"
    6) Carefully take note of all hexadecimal digits after the equal sign.
    7) Connect your printer to your Airport base station.
    8) In System Preferences/Print and Fax, add the printer again in case you deleted the non-working queue out of frustration.
    9) Refresh CUPS printer page in Safari in order to show the new (airport connected) queue.
    10) Notice the Device URI: line ends up with a period. For example, Zeroconf created my queue to read as ---> mdns://EPSON%20Stylus%20Office%20T33._riousbprint._tcp.lo cal. <--- THIS IS INCORRECT SYNTAX because such addresses never end in periods. That's how I found something was wrong.
    11) Click Modify Printer.
    12) Click Continue button. Take note of the printer's Description as it will be needed ahead.
    13) Press the Continue button until you reach the Device URI page.
    13) Complete the device URI with the correct syntax. In the above mentioned example, I changed it to read : ---> mdns://EPSON%20Stylus%20Office%20T33._riousbprint._tcp.lo cal./EPSON%20Stylus%20Office%20T33%204B4D544B3030323597
    14) Click Continue two more times.
    15) Finally click Modify Printer to save the changes.

    Note that in the above example there are a lot of %20's. This is how you add spaces in web pages. Just use %20 whenever a space is needed, as you would probably find spaces in the printer's description.

    Also note that you need to add a forward slash to the end of the Device URI generated by Zeroconf, just after the period. Follow that by the printer's Description you noted in step 12, followed by a space (%20) and finally by the device hexadecimal serial number you noted in step 6.

    I hope this helps with other people's problems with Airport connected printers. Unfortunately, I do not know if it works with all EPSON printers, nor printer's from other manufacturers. It just worked with two different EPSON printers I have that would not print if connected to either my Time Capsule, nor my Airport Express with 802.11n, when trying to print from either my iMac or my Macbook.

    What are you waiting for? go fix your Airport connected printer!

  8. #8

    Member Since
    Feb 10, 2009
    In the above mdns:// lines, please note that all {...}_tcp.lo cal{...} lines should be {...}_tcp.local{...}. That is, no spaces in the word local.

  9. #9

    Member Since
    Nov 10, 2010
    heyhow you!
    your discription is exactly the same like my prolem, the cups uri is the same as mine. but when i try to change this uri, i can t get to the place where to change it. from step 13 on its not the same. after i copied the printer discrition and clicked continue once i get this page:

    i can t find the uri anywhere ...
    thx 4 your help,

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Printing with Airport Extreme
    By rockitdoc in forum Running Windows (or anything else) on your Mac
    Replies: 0
    Last Post: 01-24-2010, 11:07 AM
  2. airport extreme printing
    By mpp0117 in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 10-07-2009, 08:30 AM
  3. Wireless printing with Airport extreme!
    By SLC Flyfishing in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 09-05-2007, 03:28 PM
  4. Printing from an Airport Extreme
    By amardilo in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 08-29-2007, 04:20 PM
  5. Alternative to Airport extreme for printing
    By mig.gentry in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 04-20-2005, 03:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts