Results 1 to 13 of 13
  1. #1

    Member Since
    Dec 04, 2007
    Sharing my laptop internet connection to iPhone

    I can't always find a hotspot but I can always connected via the 3G USB modem in my laptop and there are certain things I'd like to do with my iPhone from the internet.

    I've tried to share the internet connection from my MacBook Pro with my iPhone (System Preferences - Sharing) via Airport, however the sharing doesn't seem to work. The iPhone can "see" the wifi signal but it can't connect.

    Is there anything that I missed here? Please advice.

  2. #2

    Member Since
    Apr 28, 2006
    iMac Core Duo 20", iBook G4, iPhone 8GB :)
    Did you enable internet sharing in "System preferences > Sharing"? If the wifi icon in your menubar shows a little computer, then it's a computer network. If it shows the radio waves icon with an arrow, then it's internet sharing.

  3. #3

    Member Since
    Dec 04, 2007
    Thanks goobi,

    Yes, I've enabled the internet sharing and my airport icon on the menubar shows an up arrow. The screenshot for my sharing preferences is here:

    But somehow as I wrote before, iPhone still can't connect to the net although it does "see" the wifi.

    What else could be wrong? :-(

  4. #4

    Member Since
    Jul 27, 2009
    I too have done this correctly and actually see the wifi icon displayed on my iPhone 3G[S] as if it is connected, but when i try to view any web pages it just times out like its not connected.

    Could someone please provide a solution to this

  5. #5

    Member Since
    Sep 14, 2009
    Hi, I have this problem too! I wonder if it's disabled by Apple to ensure 3G use...

  6. #6

    Member Since
    Jun 21, 2010
    Smile MBP firewall change fixed this for me!
    This has been annoying me for weeks now.

    After reading a few other of the topics on this site, I decided to try changing the MBP firewall settings - AND IT WORKED.

    As others have said I could see the wireless on my iPhone, but the internet wasn't working. It started working straight away as soon as I did the following:

    Go To system Preferences - security - firewall

    Then go to Advanced, and uncheck "Block all incoming connections"

    I left the other settings as they were (i.e. stealth mode on) and I'm afraid I don't know the security implications of what I did, but it works!

  7. #7

    roeiboot's Avatar
    Member Since
    Apr 18, 2010
    MB061LL/B & iPhone4
    when i want to go on-line via my home or work internet connection i just jump on WiFi.. no need to go through the laptop. am i missing something ?
    iPhone 4 /16GB MacBook3,1 iPad my blog

  8. #8

    Member Since
    Sep 27, 2008
    Thanks for this post and instructions. I was able to share my laptop's wired connection with my iphone.

    To answer the question as to when this would be useful - I am in a hotel overseas and paying for wired access in my hotel room. Since I don't want to pay for my iPhone access and I want to download files bigger than the 3G limit (let alone avoid data roaming charges), the sharing allows me to do this. You are right, at home, the iPhone just uses my wifi connection directly.


  9. #9

    Member Since
    Jan 28, 2011
    Sharing Your Internet Connection via Wi-Fi
    Sharing your internet connection is easy on the Mac.
    Mac has a built in feature that does just that.

    Article found at:

  10. #10

    Member Since
    Feb 17, 2011
    I still can not browse on my ipad even though i turn of the firewall setting at:

    Setting > System preferences > Security > firewall

    anymore help? thank you

  11. #11

    Member Since
    Feb 24, 2011
    iPod connect to wireless but..
    My ipod connect to My network airport connection but when I want use internet for example open one page on safari or check mail, say you are not connect to internet
    everybody know what's problem?


  12. #12

    Member Since
    Mar 09, 2011
    When I was on travel to the Caribbean working but not with some hiccups. Now I'm in Guam and it doesn't work at all. I get the arrow up icon on the airport and even get a IP on my phone but no connectivity. Uhgg...

  13. #13

    Member Since
    Aug 14, 2012
    I made it work on windows
    IT wasn't working for me on windows (running on a mac though). Same issue, shared the created WEP connection - was visible to iPhone but wasn't really transmitting any internet data on request.

    got an idea from this post and tried this - Had AVG installed, temporarily disabled the AVG protection completely from advanced settings - the internet started working. now enabled AVG back. stlil internet was working.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sharing an Internet connection from a PC
    By burrough in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 01-17-2011, 01:41 PM
  2. Wireless Bridging Tiger to Leopard; Wimax Internet Connection; Internet Sharing
    By papayajelly in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 05-27-2009, 03:37 AM
  3. Sharing Internet Connection
    By Scientia in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 02-23-2009, 09:18 AM
  4. Sharing an Internet Connection
    By adamburgess in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 01-28-2007, 08:44 PM
  5. Sharing Internet Connection
    By JimmyHat in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 02-09-2006, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts