New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Internet, Networking, and Wireless Discussion of networking, internet, and wireless including Apple's Airport products.

Internet slow (FIOS) on Imac with both Safari and Firefox


Post Reply New Thread Subscribe

 
Thread Tools
murfman89

 
Member Since: Jul 08, 2005
Posts: 26
murfman89 is on a distinguished road

murfman89 is offline
Fairly new imac 20", ver 10.4.10. From time to time, my internet on this mac runs very slow or not at all. No errors, just have pages loading or just stalls. I check the pc next to me and fires right, same pages. Try releasing my ip and reseting the dlink router (I am wired) and still long pause or nothing comes up? I've cleared safari cache and it still pauses....way too long for a super fast pc and fios internet. any ideas?
QUOTE Thanks
Fireplug

 
Member Since: Dec 01, 2007
Posts: 18
Fireplug is on a distinguished road

Fireplug is offline
I just stumbled upon this and it worked great for me, I have an imac 20" 2.4 OS 10.5 Leopard. My internet was slow as molasses, now it screams.

Go to system preferences, select Network, select Ethernet and click "Assist Me". Click on Diagnostics, under "Network Diagnostics" select "yes" and continue. You may have to select a different "Location" (I did, my wife did not), choose continue, select Ethernet and click continue the "Quit" You may also be able to do this with the Airport, I don't know.
Let us know if it works for you. I am new to Mac and figuring this out was an accident.
QUOTE Thanks
tom0147

 
Member Since: Sep 22, 2008
Posts: 5
tom0147 is on a distinguished road

tom0147 is offline
I have the exact same issues with my new fios 3 bundle. I had the 2 bundle and things were fine. Now I have 20/20 and certain times things are fine and other times (especially at night) pages load very slowly. I went to my pc and things are fine. My email is tomsuzuki1@verizon.net. Please let me know if you figure it out and/or if you send your address I'll do the same. BTW. I'm not quite sure what the other post was talking about.
QUOTE Thanks
tom0147

 
Member Since: Sep 22, 2008
Posts: 5
tom0147 is on a distinguished road

tom0147 is offline
Quick update... It seems to be a router problem. I've read a few post on other sites and that seems to be the consensus. Try this. When you have a site that's taking forever loading, stop the load (the x button) swap the network cable on the back of the router from its present port to another open port and try reloading the same page or site. It should scream loading up. Unfortunately the next page or at best a few pages down will be slow again. My immediate suggestion is to get a new router from Verizon but who knows if that one will be any good. Stay tuned.
QUOTE Thanks
tom0147

 
Member Since: Sep 22, 2008
Posts: 5
tom0147 is on a distinguished road

tom0147 is offline
There seems that there may be a firmware issue with the Actiontec routers. No confirmation but it makes sense that PCs work and not Macs.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,050
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Hi Guys:

To you folks who are using Verizon FIOS - I had the same slowdown issues as has been described. It's not the router or firmware it's the way Verizon derives its DNS settings for FIOS.

If you go into the router setup menu, you'll probably see all zeros for the primary DNS and secondary DNS settings (under WAN\LAN menu). Normally this is OK because the system will generate a DNS setting on the fly. While this works great for Windows PCs, it does not always work correctly for Mac airport or Mac ethernet.

Here's how to resolve the problem: First go into System Preferences and open Network. If you're Airport Connected, it'll show up that way by being highlighted. Now click on the Advanced button. Click on DNS.

Add these settings in for Primary DNS and Secondary DNS:

Primary = 208.67.222.222
Second = 208.67.220.220

Click OK and go back one step. Now choose ethernet and put in the same settings for DNS Server. Close the dialog.

Now go into your router and do the same thing for primary and secondary DNS settings. Reboot the router.

Those settings for primary and secondary are for OpenDNS. Standard DNS servers which are separate from Verizon or any other ISP. They're fast and work well. I finally found someone at Verizon FIOS support who understands Mac machines and OS X and he agreed with me.

Give it a try but before you do, make sure you write down all your old settings so you can go back in case things don't work out.

Regards.
QUOTE Thanks
djbethell

 
Member Since: Sep 26, 2008
Posts: 2
djbethell is on a distinguished road

djbethell is offline
OK, I have no idea what the last post was about but then again I am kinda stoopid when it comes to computers. Surely there is a simpler way os dealing with this. Both my Safari and Firefox are sooooo slooow. They were fine two weeks ago, and I mean really fast. It's a new MAc (only two months old) I've checked the router, I've checked my download speed with Talktalk and everything their end is fine so it's definitely my Firefox and Safari (or Mac). Someone mentioned clearing my browser cache or something. Again not sure as I don'y know hoe to do this. Any new suggestions? Anyone spoken to Apple about this?
If you have any ideas it would much be appreciated if you can explain it to me as if I were three years old and not a computer literate genius, because I am defintiely not one of those
Much thanks,
David x
QUOTE Thanks
MikeandDeni

 
Member Since: Sep 27, 2008
Posts: 3
MikeandDeni is on a distinguished road

MikeandDeni is offline
Quote:
Originally Posted by Fireplug View Post
I just stumbled upon this and it worked great for me, I have an imac 20" 2.4 OS 10.5 Leopard. My internet was slow as molasses, now it screams.

Go to system preferences, select Network, select Ethernet and click "Assist Me". Click on Diagnostics, under "Network Diagnostics" select "yes" and continue. You may have to select a different "Location" (I did, my wife did not), choose continue, select Ethernet and click continue the "Quit" You may also be able to do this with the Airport, I don't know.
Let us know if it works for you. I am new to Mac and figuring this out was an accident.
I followed your suggestion - for location I selected Automatic instead of Westell - HUGE difference.
BIG Thank you
QUOTE Thanks
djbethell

 
Member Since: Sep 26, 2008
Posts: 2
djbethell is on a distinguished road

djbethell is offline
Also followed the above advice and it did absolutely nothing for me. In fact, if possible, is slower than ever. My internet download speed is brilliant but so slow on this NEW mac. Does Safari of Firefox have any suggestions?
QUOTE Thanks
tenp

 
Member Since: Jan 01, 2008
Posts: 36
tenp is on a distinguished road

tenp is offline
2 chscag
It really works! Now I've got a very stable internet connection via ethernet cable.

Macbook Pro 2.5GHZ/250HD/4GB RAM/Logitech G3/SteelPad
QUOTE Thanks
musicyardmalibu

 
Member Since: Oct 09, 2008
Posts: 3
musicyardmalibu is on a distinguished road

musicyardmalibu is offline
I too have been having a problem with my Verizon connection. I swapped from Charter for the fast connection but immediately I lost my ability to use Ichat / video - with my family overseas. I contacted Verizon and set the ports etc on the admin page but that did not work. My internet speed is fast if I sit next to the modem with a hard connection via ethernet, but I still have no video chat
I have the Wifi modem (action tech) and even with a full signal I get sluggish pages loading etc. in fact sometimes they even freeze.
The Verizon tech came out to trouble shoot the problem and with his old school PC laptop (a quarter of the power of my 3 macs) his internet was blazing fast.

Verizon and action tech say they cannot do anything to help me in regards to troubleshooting the mac. not much help.

Also I tried using Skype with my family and I managed a audio connection on both ends - my mother can see me on video but i cannot see her ? more voodoo!

Does anyone know if there is a fix for all this or would I have been better sticking with Charter?
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,050
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
To musicyardmalibu:

Are you on Verizon FIOS or regular Verizon DSL? Post back and let me know.
If you like, post to me via Private forum mail.

You're correct about the techs at Verizon. If you can find one that understands OS X and Macs, better write down his\her name for future reference. I too dropped Charter because of their poor service and went with Verizon. The techs at Charter are likewise not knowledgeable about Macs.

Regards.
QUOTE Thanks
tom0147

 
Member Since: Sep 22, 2008
Posts: 5
tom0147 is on a distinguished road

tom0147 is offline
Finally got things working. Very simple solution. Why nobody knows this, i don't know. Go to System preferences > Network > Built in ethernet and in the DNS Server field enter 4.2.2.5. Apply and close and restart. This worked for me after days of searching for an answer and on the phone with Verizon. Try it out and see if it works for you. Good Luck.
QUOTE Thanks
chscag

 
chscag's Avatar
 
Member Since: Jan 23, 2008
Location: Fort Worth, Texas
Posts: 40,050
chscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond reputechscag has a reputation beyond repute
Mac Specs: 27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, 3 iPods, OS X Mavericks

chscag is offline
Tom:

Interesting. Where did you come up with that fix? And does it work for an airport connection?

Regards.
QUOTE Thanks
tom0147

 
Member Since: Sep 22, 2008
Posts: 5
tom0147 is on a distinguished road

tom0147 is offline
In theory it should but we are talking about a godzillion other factors when we start getting into wireless. With me it was a problem loading pages via ethernet. My speeds were fine when tested through speakeasy but the pages just didn't want to load up. Setting a static DNS server address fixed the problem. Try it with wireless.
QUOTE Thanks

Post Reply New Thread Subscribe


« netflix / silverlight issues | Connecting to a PC server from an iMac »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Safari labeled as Firefox scoutfinch OS X - Apps and Games 3 08-04-2007 02:45 PM
Firefox or Safari dennis495 OS X - Apps and Games 6 06-04-2007 04:56 AM
Safari AND Firefox running slow 5litreLX OS X - Apps and Games 18 10-18-2006 09:29 AM
Safari running EXTREMELY slower than Firefox??? lewistyler Switcher Hangout 1 09-01-2006 01:25 AM
Slow typing in firefox in Intel Imac Back2MacinNYC OS X - Apps and Games 3 07-12-2006 03:24 PM

All times are GMT -4. The time now is 03:09 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?