New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Internet, Networking, and Wireless Discussion of networking, internet, and wireless including Apple's Airport products.

Old problem I guess


Post Reply New Thread Subscribe

 
Thread Tools
andrebnu

 
andrebnu's Avatar
 
Member Since: Mar 18, 2007
Location: Blumenau, Brazil
Posts: 280
andrebnu will become famous soon enough
Mac Specs: MacBook Pro 2,33GHz C2D 2GB RAM 256MB video + LCD Samsung 20" 206BW + Maxtor OneTouch III 500GB

andrebnu is offline
Guys, I'm really sorry, but I looked around for a while and, althoug I've seen many posts talking about the same problem, I did not find the answer.

Today is my first day with a MacBook Pro. I'm flirting with it for 4 hours now, but I'm still stuck with an airport issue.

I have a wireless router at home, connected to my PC (soon will be gone lol).

This network is protected with WEP security, 64 bits, hexadecimal.

I've never had any problem connecting notebooks here, I just had to insert the password.

With the macbook, since the first time, I keep getting this message:

"THERE WAS AN ERROR JOINING THE AIRPORT NETWORK".

I just don't know what to do.

Now, I set my router for none security (open), and I finally got to connect with my MBP.

So, any ideas? No chances I'll be letting this thing open.

Thanks in advance!
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
You need to enter the entire 26-character WEP key and not the "passphrase" generated by your router. The passphrase is proprietary to your router and the paired (same brand) network card you're using on your PC. Since the Airport card in your MacBook Pro is not the same brand, it is not able to make the translation between your passphrase and the WEP key.

When you enter your passphrase on your router, it should generate a 26-character, hexadecimal key. That's the key you need to enter on your MacBook.

This can be alleviated by switching over to WPA (or better yet WPA2 if your router supports it), that always uses a standard, easy to key/remember password.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
andrebnu

 
andrebnu's Avatar
 
Member Since: Mar 18, 2007
Location: Blumenau, Brazil
Posts: 280
andrebnu will become famous soon enough
Mac Specs: MacBook Pro 2,33GHz C2D 2GB RAM 256MB video + LCD Samsung 20" 206BW + Maxtor OneTouch III 500GB

andrebnu is offline
Well, as I was using 64 bits encryption, the passphrase is just 10 characters, right? That's what I had set up, and tried to type when Airport asked for my Wep password.

Any other ideas?
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by andrebnu View Post
Well, as I was using 64 bits encryption, the passphrase is just 10 characters, right? That's what I had set up, and tried to type when Airport asked for my Wep password.

Any other ideas?
You're right - if you're using 64 bits, it will be 10 characters. Does your router not support WPA? WEP is easily hackable with readily available tools and offers little to no security, especially if you're not using MAC filtering (if you're filtering by MAC in tandem with WEP, make sure you enter your MacBook's MAC address in the filtering table). WPA is the newer standard and is far less prone to being hacked. If you have a relatively new router, it should support WPA. When you use WPA, you simply specify a password and that's always what you'll use to get on initially (on both your PC and Mac). It's a lot safer and easier to use, so I highly recommend you consider it if you can.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
andrebnu

 
andrebnu's Avatar
 
Member Since: Mar 18, 2007
Location: Blumenau, Brazil
Posts: 280
andrebnu will become famous soon enough
Mac Specs: MacBook Pro 2,33GHz C2D 2GB RAM 256MB video + LCD Samsung 20" 206BW + Maxtor OneTouch III 500GB

andrebnu is offline
yes, my routers supports WPA, but I don't know how to configure.

It has 3 options:

* 802.1x

this option will ask me to fill in with server IP addres, Port and Secret.

* PSK Hex

I'm assuming it`s the pre-shared key. I tryied to choose this option, but it's no saving....don't know if there's something else I should do..

* PSK String

Don't know what's this about...
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by andrebnu View Post
yes, my routers supports WPA, but I don't know how to configure.

It has 3 options:

* 802.1x

this option will ask me to fill in with server IP addres, Port and Secret.

* PSK Hex

I'm assuming it`s the pre-shared key. I tryied to choose this option, but it's no saving....don't know if there's something else I should do..

* PSK String

Don't know what's this about...
PSK Hex is probably a hexadecimal key (I've never seen this before). It's probably not saving because the password you're trying has characters that fall outside of Hexadecimal (0-9, A-F). PSK String, is just a regular, text password. That would be the option I'd choose.

What kind of router are you working with?

EDIT: I really have to head off to bed (it's 11pm here, and I have to go to work tomorrow), so I'll catch up with you later if you have more questions.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
andrebnu

 
andrebnu's Avatar
 
Member Since: Mar 18, 2007
Location: Blumenau, Brazil
Posts: 280
andrebnu will become famous soon enough
Mac Specs: MacBook Pro 2,33GHz C2D 2GB RAM 256MB video + LCD Samsung 20" 206BW + Maxtor OneTouch III 500GB

andrebnu is offline
answering your question, my router is a D-LINK model DSL-G604T

tks for the help so far
QUOTE Thanks
hagios1972

 
hagios1972's Avatar
 
Member Since: Jan 24, 2007
Location: Hamilton, New Zealand
Posts: 343
hagios1972 will become famous soon enough
Mac Specs: MacBook black, Intel C2D 2GHz, 2GB RAM, 320GB WD Scorpio HD

hagios1972 is offline
WE have the same modem router. You have to go to the D-Link router website http://10.1.1.1 and configure it from there. You can choose WPA PSK and use an ordinary password.
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by andrebnu View Post
answering your question, my router is a D-LINK model DSL-G604T

tks for the help so far
Excellent. Keep in mind that D-Link does offer Mac support, so if we can't get it working, you can always give them a call.

Let us know how you make out.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
andrebnu

 
andrebnu's Avatar
 
Member Since: Mar 18, 2007
Location: Blumenau, Brazil
Posts: 280
andrebnu will become famous soon enough
Mac Specs: MacBook Pro 2,33GHz C2D 2GB RAM 256MB video + LCD Samsung 20" 206BW + Maxtor OneTouch III 500GB

andrebnu is offline
Hey guys,

Thank you for your valuable help!

I got it working now. I changed the encryptation on my router for WPA, instead of WEP, and it worked like a charm.

Tks again!
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by andrebnu View Post
Hey guys,

Thank you for your valuable help!

I got it working now. I changed the encryptation on my router for WPA, instead of WEP, and it worked like a charm.

Tks again!
Great, and you'll be much better protected too.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
Yukon4

 
Member Since: Apr 13, 2007
Posts: 7
Yukon4 is on a distinguished road

Yukon4 is offline
Hi there - I am getting that same message: "there was an error joining the network" -- BUT -- this is happening on an iMac that had been connecting to our Linksys router fine for several months. We have 2 other Macs and a Windows XP on this same network, all connecting fine.

Why would the iMac suddenly STOP connecting and start generating this message? In my case, would I still make the changes from WEP to WPA etc since WEP was and still works fine for the other 3 computers?

What makes it more strange is if I bring the iMac closer to the router - then it connects OK. It does NOT ask for password nor does it give the "error" message. The signal is good in the location where it would not connect though.(iStumbler shows 54%+) And an older iBook is able to connect where the iMac suddenly will not. So I'm not sure modifying any of the security settings would help in this case.

Any ideas for this? Help! Thanks!
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by Yukon4 View Post
Hi there - I am getting that same message: "there was an error joining the network" -- BUT -- this is happening on an iMac that had been connecting to our Linksys router fine for several months. We have 2 other Macs and a Windows XP on this same network, all connecting fine.

Why would the iMac suddenly STOP connecting and start generating this message? In my case, would I still make the changes from WEP to WPA etc since WEP was and still works fine for the other 3 computers?
Recently, Apple rolled out a security update for the AirPort wireless card inside your Mac. In my experience, shortly after doing the update, I had problems with joining my Linksys router's wireless network. Switching from WPA to WPA2 corrected those issues for me. WEP is basically useless, especially if you're not using it in tandem with MAC filtering. It can be hacked in a matter of minutes by anyone with a modicum of savvy as it relates to wireless security.

Quote:
What makes it more strange is if I bring the iMac closer to the router - then it connects OK. It does NOT ask for password nor does it give the "error" message. The signal is good in the location where it would not connect though.(iStumbler shows 54%+) And an older iBook is able to connect where the iMac suddenly will not. So I'm not sure modifying any of the security settings would help in this case.

Any ideas for this? Help! Thanks!
My problem was very similar - in areas of very good signal, I didn't have an issue. When I was on the fringe of my network was when I started having issues. I think it had to do with the fact that I was closer to a neighbor that had a stronger signal in the areas I was having trouble with. Changing channels helped somewhat, as did changing the SSID to be broadcast (I had it not broadcasting at one point), but ultimately, switching to WPA2 corrected all of my problems.

So, if you haven't already done it, upgrade your router's firmware to the most recent version. Make sure SSID broadcast it turned on and switch to WPA2 if available. Also, you may want to try a tool like AirPort Radar to see what channels your neighbors are using and switch to a different channel.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks
Yukon4

 
Member Since: Apr 13, 2007
Posts: 7
Yukon4 is on a distinguished road

Yukon4 is offline
You know, now that you mention it, I think I may have downloaded that security update, maybe.

I'll try WPA2 and see what happens. Just nervous about re-doing all the configurations and winding up with NO computers working!!

Thanks again!
QUOTE Thanks
cwa107

 
cwa107's Avatar
 
Member Since: Dec 20, 2006
Location: Middletown, Pennsylvania
Posts: 26,494
cwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond reputecwa107 has a reputation beyond repute
Mac Specs: 15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD

cwa107 is offline
Quote:
Originally Posted by Yukon4 View Post
You know, now that you mention it, I think I may have downloaded that security update, maybe.

I'll try WPA2 and see what happens. Just nervous about re-doing all the configurations and winding up with NO computers working!!

Thanks again!
If you've updated to 10.4.9, you probably have it - I believe that was rolled up into that update.

WPA has been around for some time now, the only reason that manufacturers continue to support WEP is that some older wi-fi cards are simply not capable of adhering to the newer standard. So, it allows for some backward compatibility and compliance with the older 802.11 standards.

Worst case scenario is that you can just reset your router to defaults and configure it again with WEP, although I think you'll find the performance and security to easily outweigh any configuration headaches.

Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!
QUOTE Thanks

Post Reply New Thread Subscribe


« Server without a Server? | Couple networking bugs »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Problem With Keyboard...... mmcltd OS X - Operating System 4 02-02-2010 06:47 PM
Microsoft Messenger Problem millenium_spike OS X - Apps and Games 4 09-16-2008 01:11 AM
Colour Problem On One Account stewart OS X - Operating System 0 08-25-2006 07:42 PM
Display problem (not the usual) missyvortex Apple Notebooks 7 10-11-2004 07:15 PM
Startup problem OS 10.2 and G4 450 AGP lvinay OS X - Operating System 2 09-30-2003 11:21 AM

All times are GMT -4. The time now is 01:56 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?