Mac Forums

Mac Forums (
-   Internet, Networking, and Wireless (
-   -   macbook core 2 duo and belkin wireless g router (

r0bbb 01-10-2007 07:57 AM

macbook core 2 duo and belkin wireless g router

I recently bought a new macbook core 2 duo, but cant get the airport card to connect to my belking wireless g router. Ive turned off wep security, so i know its nothing to do with that. i can connect to it using the ethernet cable. Ive read lots of posts about problems with core 2 duo machines connecting to belkin routers, but none of them come to any conclusion. can some one pleaseeee help me!



Osiris22x 01-10-2007 09:58 AM

I've had similar troubles connecting to Belkin router's when working with client's computers. Thus far I haven't found a good solution, short of switching to a different brand of router.

Even once I did get it working now and then, it would turn around and die again a day or two later.

cvx5832 01-10-2007 11:12 AM

Same experiences here. Not much luck with the Belkins.

r0bbb 01-11-2007 05:24 AM

Just Spoke to belkin support who provided me with instructions on resolving the issue. Im at work now so i cant try it out, but if anyone manages it successfully please let us all know. Here they are:

1. Go to the applications folder on your hard drive and find the Internet Connect application.

2. Double-click on it to start.

3. Select AirPort from the Configuration dropdown menu, if Airport Power is On click on Turn Airport Off

4. If you would like the AirPort status to show in your menu bar place a check in the box Show AirPort status in menu bar. When you click on the AirPort symbol in the menu bar the AirPort window will open. You can also turn airport off by clicking Turn Airport Off here.

5. After turning it off, click on it to turn it on. You should see your Belkin wireless network in the network instead on “wahoo”

6. If Belkin not listed, please highlight the network and then you will be associated with Belkin wireless network.

7. Click on Other…. A new window would open up.

8. Type in the SSID of the router (belkin54g/WLAN) under “Name”

9. Click on Airport Symbol on Menu bar and now the Belkin wireless network should be displayed there. Highlight the network and then you will be associated with Belkin wireless network.

10. Open System Preferences

11. Select Network.

12. From the Show field select Active Network Ports.

13. You can set the default active port by dragging the desired port to the top of the list.

14. Click on Apply Now.

15. Select AirPort under “Show”. The AirPort network panel will open. Select SSID related to Belkin in the Preferred Network field. If the “Apply Now” button is active, click on it.

This will fix the issue.

r0bbb 01-11-2007 03:41 PM

Well that didnt work! But updating my belkin firmware did! all working now, even with security enabled. amazing.

Thought id share that with everyone as there are so many similar belkin/macbook threads and none seem to come to any kind of conclusion.



rpmgatech 01-11-2007 04:09 PM

I have a Belkin and a Intel Core 2 Duo. It worked for me. I connected it to my old PC and then connected with no problem wirelessly. The one thing that I had to do was restart the PC. But that's a given with those un-people-friendly IBM Compatibles.

The only other thing that you may want to check is if the host computer can connect to the internet. If it can't, then it is something with the way the IP is set up (Static, Dynamic, etc. etc.). If your host can access the internet, then it is something with airport. Can you see the network or is it just not working? If you cannot see it, you may have to go into the Other..., enter the information in each of the fields and you should be golden. I have a problem with seeing certain networks sometimes and doing that usually works.

All times are GMT -4. The time now is 04:52 PM.

Powered by vBulletin
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.