New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Internet, Networking, and Wireless Discussion of networking, internet, and wireless including Apple's Airport products.

Wep encryption problem


Post Reply New Thread Subscribe

 
Thread Tools
Kevriano

 
Kevriano's Avatar
 
Member Since: Jul 02, 2006
Location: Crawley, England
Posts: 4,561
Kevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to all
Mac Specs: 20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.

Kevriano is offline
Hi guys. Can anyone help solve a small problem with encryption for me. I have just set up a wireless system using a D-Link Dsl-624T Router and DWL G122 Usb adaptor.
The connection works fine if I use no encryption at all, but as soon as I try a wep encryption it doesn't work. I have made sure I put in exactly the same combination of numbers and letters, but it just doesn't work. D-links' advice line said that Macs work differently and need a figure or letter put in front of the wep key to make it work. I looked on Apples' web site and tried the 2 solutions it suggested, a dollar sign or 0x, but still no luck, it just says that I have put in too many digits.
The same applies to the PSP, which connects fine unencrypted, but will not do so otherwise.
Any solution would be helpful, even if you know more about WPA instead,which I could use. ( don't worry about the PSP thing). It may just be me not fully understanding encryption, but I would like to know to stop people nabbing free service from me ( even if it's free to me from Talk Talk!).
Thanks in advance. Kev.
QUOTE Thanks
cazabam

 
cazabam's Avatar
 
Member Since: Jun 06, 2006
Posts: 1,153
cazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of light
Mac Specs: MacBook 2.0GHz White, 512MB RAM, 60GB HDD

cazabam is offline
Sounds like you need to select 64-bit or 128-bit WEP (Depending on which you have configured on the router). There are a variety of posts already covering this topic, if you have a quick search.
QUOTE Thanks
Kevriano

 
Kevriano's Avatar
 
Member Since: Jul 02, 2006
Location: Crawley, England
Posts: 4,561
Kevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to all
Mac Specs: 20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.

Kevriano is offline
Quote:
Originally Posted by cazabam
Sounds like you need to select 64-bit or 128-bit WEP (Depending on which you have configured on the router). There are a variety of posts already covering this topic, if you have a quick search.
Thanks for replying, but I made sure both devices were set up as 64 bit encryption and just used a 10 digit hexadecimal key, but it still didn't work.
As it happens, the usb adaptor isn't allowing me to connect the Mac wirelessly at the moment, despite having a 100% strength connection signal! D link are getting back to me!
Any further advice gratefully received. Thanks.
QUOTE Thanks
Daddy Elmis

 
Daddy Elmis's Avatar
 
Member Since: Mar 28, 2006
Posts: 390
Daddy Elmis has a spectacular aura about

Daddy Elmis is offline
This is going to sound weird, and I don't know why this is, but I noticed on my old Linksys "b" system (I've since upgraded to an Extreme) the Mac (not me) seemed to put a "$" (without the quotes) in front of my WEP key. If I deleted the "$" I'd lose my connection between computers. You might give that a whirl.
QUOTE Thanks
Kevriano

 
Kevriano's Avatar
 
Member Since: Jul 02, 2006
Location: Crawley, England
Posts: 4,561
Kevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to allKevriano is a name known to all
Mac Specs: 20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.

Kevriano is offline
Quote:
Originally Posted by Daddy Elmis
This is going to sound weird, and I don't know why this is, but I noticed on my old Linksys "b" system (I've since upgraded to an Extreme) the Mac (not me) seemed to put a "$" (without the quotes) in front of my WEP key. If I deleted the "$" I'd lose my connection between computers. You might give that a whirl.
Thanks, I did try that, as suggested on Apples' site but it didn't seem to work. I think I may just not be using the right sort of code. Could anyone maybe give me an example of a wep key. Much appreciated. Kev.
QUOTE Thanks
cazabam

 
cazabam's Avatar
 
Member Since: Jun 06, 2006
Posts: 1,153
cazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of lightcazabam is a glorious beacon of light
Mac Specs: MacBook 2.0GHz White, 512MB RAM, 60GB HDD

cazabam is offline
I just had a look in my airport preferences (I wasn't at my mac last time I responded). Your WEP key is a series of 10 or 32 hexadecimal digits (0-9 or a-f). My airport network connection dialog lets me choose between:

* WEP password
* WEP 40/128-bit hex
* WEP 40/128-bit ASCII

Rather than putting special characters (0x, $, s or whatever) you should select the correct one. The default appears to be WEP password for some networks, so make sure it's set to WEP hex if you use hex digits.
QUOTE Thanks

Post Reply New Thread Subscribe


« Which PCI card can I use? | WEP Keys »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Problem connecting to Airport with Windows - What's a WEP? Aaron Mayfield Internet, Networking, and Wireless 3 07-14-2006 09:26 PM
Wireless Internet WEP key hexadecimal Problem oragano Internet, Networking, and Wireless 16 04-15-2005 04:58 AM
How do I make airport auto connect to a WAN with WEP? edokid Internet, Networking, and Wireless 10 03-02-2005 12:35 PM
Enable WEP encryption on Airport - OS 10.2.5 (Jaguar) newuser Internet, Networking, and Wireless 1 05-09-2004 03:53 PM
G5 Video problem WilliS Apple Desktops 3 05-05-2004 10:16 AM

All times are GMT -4. The time now is 06:11 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?