Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Internet, Networking, and Wireless (http://www.mac-forums.com/forums/internet-networking-wireless/)
-   -   Wep encryption problem (http://www.mac-forums.com/forums/internet-networking-wireless/37976-wep-encryption-problem.html)

Kevriano 07-14-2006 10:39 AM

Wep encryption problem
 
Hi guys. Can anyone help solve a small problem with encryption for me. I have just set up a wireless system using a D-Link Dsl-624T Router and DWL G122 Usb adaptor.
The connection works fine if I use no encryption at all, but as soon as I try a wep encryption it doesn't work. I have made sure I put in exactly the same combination of numbers and letters, but it just doesn't work. D-links' advice line said that Macs work differently and need a figure or letter put in front of the wep key to make it work. I looked on Apples' web site and tried the 2 solutions it suggested, a dollar sign or 0x, but still no luck, it just says that I have put in too many digits.
The same applies to the PSP, which connects fine unencrypted, but will not do so otherwise.
Any solution would be helpful, even if you know more about WPA instead,which I could use. ( don't worry about the PSP thing). It may just be me not fully understanding encryption, but I would like to know to stop people nabbing free service from me ( even if it's free to me from Talk Talk!).
Thanks in advance. Kev. :(

cazabam 07-14-2006 11:17 AM

Sounds like you need to select 64-bit or 128-bit WEP (Depending on which you have configured on the router). There are a variety of posts already covering this topic, if you have a quick search.

Kevriano 07-14-2006 03:39 PM

Still a problem!
 
Quote:

Originally Posted by cazabam
Sounds like you need to select 64-bit or 128-bit WEP (Depending on which you have configured on the router). There are a variety of posts already covering this topic, if you have a quick search.

Thanks for replying, but I made sure both devices were set up as 64 bit encryption and just used a 10 digit hexadecimal key, but it still didn't work.
As it happens, the usb adaptor isn't allowing me to connect the Mac wirelessly at the moment, despite having a 100% strength connection signal! D link are getting back to me!
Any further advice gratefully received. Thanks.

Daddy Elmis 07-14-2006 09:29 PM

This is going to sound weird, and I don't know why this is, but I noticed on my old Linksys "b" system (I've since upgraded to an Extreme) the Mac (not me) seemed to put a "$" (without the quotes) in front of my WEP key. If I deleted the "$" I'd lose my connection between computers. You might give that a whirl.

Kevriano 07-15-2006 05:10 AM

Quote:

Originally Posted by Daddy Elmis
This is going to sound weird, and I don't know why this is, but I noticed on my old Linksys "b" system (I've since upgraded to an Extreme) the Mac (not me) seemed to put a "$" (without the quotes) in front of my WEP key. If I deleted the "$" I'd lose my connection between computers. You might give that a whirl.

Thanks, I did try that, as suggested on Apples' site but it didn't seem to work. I think I may just not be using the right sort of code. Could anyone maybe give me an example of a wep key. Much appreciated. Kev.

cazabam 07-15-2006 08:09 PM

I just had a look in my airport preferences (I wasn't at my mac last time I responded). Your WEP key is a series of 10 or 32 hexadecimal digits (0-9 or a-f). My airport network connection dialog lets me choose between:

* WEP password
* WEP 40/128-bit hex
* WEP 40/128-bit ASCII

Rather than putting special characters (0x, $, s or whatever) you should select the correct one. The default appears to be WEP password for some networks, so make sure it's set to WEP hex if you use hex digits.


All times are GMT -4. The time now is 07:45 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.