Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1


    Member Since
    Aug 01, 2012
    Posts
    15
    iMac slow internet, makes others slow too.
    Imac slow on internet and makes others slow too.

    Hi folks, my broadband has become very slow but the machine seems to work fine with everything else. Also the other computers in the house run just fine on the broadband, until I connect mine Ė then all of them become slow.

    We have 3 computers on our broadband, my imac running OS X 10.6.8, my wifeís newer imac running 10.9.1 and my sonís PC.

    Iím wondering if Iíve got some malware thatís taking up all the bandwidth, or if thereís some conflict between the router and the mac. We have BT broadband.

    Itís a really strange situation, does anyone have any idea what the problem might be?

  2. #2

    MacInWin's Avatar
    Member Since
    Jul 07, 2008
    Location
    Winchester, VA
    Posts
    6,060
    Specs:
    2015 rMBP, 2008 iMac, iPhone 6, iPad mini, 13" MBP, AppleTV and two MacMinis
    Probably not malware, but you might have a network conflict in IP addresses. Can you check on your router to see what IPs are assigned and who is who? All of them should be using DHCP and you turn on DHCP on the router and it sorts them all out for you automagically.

  3. #3

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,485
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    What iMac do you have? And how are you connecting to the router - via wifi or ethernet?

    Some of the early Intel Macs did not have 'n' wireless capability - they maxed out at 'g' speeds.
    Some of them (my first Mac) had the capability of 'n' speeds, but, it was not enabled until you paid $1 for the firmware update to enable it.
    If yours is one of those, then every time you connect via wifi, it is going to slow the entire wifi network down to 'g' speeds.

    I still have 1 'g' device left here. Hence, I run 2 wifi networks - one that is 'n' only and one that is a combo network to avoid just this issue.

    edit:
    If you are using wifi - hold the option key and click on the wifi icon on the menu bar - that will provide you with more detailed info about your connection - in this case you would be looking for the 'Transmit Rate'.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  4. #4


    Member Since
    Aug 01, 2012
    Posts
    15
    Thanks. I clicked the THANK button for MacInWin but can't see how to do the same for bobtomay???

    I'm connected by wifi. My imac isn't that old, about 2.5 years old, imac11,2 running at 3.06 GHz so doubt if that would be running at G?

    Anyway transmit rate is 117, what can I infer from that?

    Thanks for the help I really appreciate it. R

  5. #5

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,935
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    Interesting. When things are bogging down, Open Activity Monitor from Applications/Utilities and click on the Network Tab. Do you see anything constantly using bandwidth there?

  6. #6

    RadDave's Avatar
    Member Since
    Jan 20, 2012
    Location
    North Carolina
    Posts
    3,347
    Specs:
    MBP 13" (2013); 8 GB RAM; SSD 256 GB; OS 10.11.5
    Quote Originally Posted by Rich Greenland View Post
    Thanks. I clicked the THANK button for MacInWin but can't see how to do the same for bobtomay???

    I'm connected by wifi. My imac isn't that old, about 2.5 years old, imac11,2 running at 3.06 GHz so doubt if that would be running at G?

    Anyway transmit rate is 117, what can I infer from that?
    Hi Rich - you already have some of the 'seasoned pros' here responding, but maybe a little more information would help: 1) What ISP are you using for your broadband?; 2) What is the brand/model/age of your router? and 3) What router protocols are being used, i.e. 802.11 'g/n' (or even 'ac')? Have you 'power recycled' your modem & router (may be one device) - pulled the plugs and waited a while and re-powered, modem first, then router?

    Have you checked your DL/UL speeds on the 3 computers, first w/ yours not on Wi-Fi and then w/ all 3 using wireless? (Speedtest Net is a good choice) - just wondering how your speeds change when your iMac is connecting, especially the download numbers? Dave

    P.S. I'm assuming that the 3.06 GHz quoted above is the speed on your CPU; 'g' is the Wi-Fi protocol, specifically 802.11 g which runs at the 2.4 GHz band at 'ideal' speeds up to 54 Mbps, if that helps.

  7. #7

    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,485
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
    Quote Originally Posted by Rich Greenland View Post
    ...

    I'm connected by wifi. My imac isn't that old, about 2.5 years old, imac11,2 running at 3.06 GHz so doubt if that would be running at G?

    Anyway transmit rate is 117, what can I infer from that?

    ...
    You're running at 'n', but, on a single channel instead of dual channels which would give you 300. Here's a quick tidibit on channel bonding.

    I'd probably grab iStumbler - that version requires OS X 10.8 or later - check the channels being used by your neighbors surrounding networks and change the channel of your network.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  8. #8

    MacInWin's Avatar
    Member Since
    Jul 07, 2008
    Location
    Winchester, VA
    Posts
    6,060
    Specs:
    2015 rMBP, 2008 iMac, iPhone 6, iPad mini, 13" MBP, AppleTV and two MacMinis
    +1 for what bobtomay suggested. I just helped a friend who was unable to do anything wirelessly until I moved her off of channel 6 on the 2.4ghz band where a neighbor was camped (that is the default setting for most routers). Now it's humming. Another way to avoid the jam on 2.4Ghz band is to move to the 5ghz band. There are more channels up there so there is room for more networks in a confined space. When I set up my WiFI router, I set up with different names for the 2.4 and 5 ghz channels. That way I've been able to tell all my computers and devices to connect to the 5 side, leaving 2.4 for visitors and guests in my home.

  9. #9

    RadDave's Avatar
    Member Since
    Jan 20, 2012
    Location
    North Carolina
    Posts
    3,347
    Specs:
    MBP 13" (2013); 8 GB RAM; SSD 256 GB; OS 10.11.5
    Quote Originally Posted by MacInWin View Post
    ......... When I set up my WiFI router, I set up with different names for the 2.4 and 5 ghz channels. That way I've been able to tell all my computers and devices to connect to the 5 side, leaving 2.4 for visitors and guests in my home.
    Hi Jake - thanks for the information - attached is a screen capture from an app called WiFi Explorer showing my 4 networks on an AirPort Extreme (plus my neighbors) - this was from my laptop in another room, so the lower signal strengths - the laptop is currently on the 5 GHz band, channel 149 (highlighted in blue - crossed out my name).

    Now being new to a dual band router last spring, I did not give each band a different name, but the laptop seems to automatically go to the 5 GHz one - from your experience will my MBPro (spring 2013 model) always seek this higher band? I'm also wondering about my other devices, such as the Rokus - will need to check? Thanks for any comments. Dave

    .
    Attached Images Attached Images

  10. #10

    MacInWin's Avatar
    Member Since
    Jul 07, 2008
    Location
    Winchester, VA
    Posts
    6,060
    Specs:
    2015 rMBP, 2008 iMac, iPhone 6, iPad mini, 13" MBP, AppleTV and two MacMinis
    RadDave, open System Preferences/Network and then select your WiFi network in the left window. In the right window, click Advanced. Under the WiFi tab you will see a window with all the WiFi Networks the system has seen, in the priority order it uses to connect. As the window says, you can drag the networks into the order you prefer. If you want to remove any networks, select them and click the "-" button.

  11. #11

    RadDave's Avatar
    Member Since
    Jan 20, 2012
    Location
    North Carolina
    Posts
    3,347
    Specs:
    MBP 13" (2013); 8 GB RAM; SSD 256 GB; OS 10.11.5
    Quote Originally Posted by MacInWin View Post
    RadDave, open System Preferences/Network and then select your WiFi network in the left window. In the right window, click Advanced. Under the WiFi tab you will see a window with all the WiFi Networks the system has seen, in the priority order it uses to connect. As the window says, you can drag the networks into the order you prefer. If you want to remove any networks, select them and click the "-" button.
    Hi Jake - thanks for your prompt response - I followed your instructions, but the listing combines my 2.4 & 5 GHz networks (since each has the same name), so I cannot put them in an order - guess that I'd have to go into the Airport Utility and rename (to split out the two frequencies)? I'll periodically use the app mentioned in my other post to see which network my laptop is connected to and check my Roku devices - Dave

  12. #12

    MacInWin's Avatar
    Member Since
    Jul 07, 2008
    Location
    Winchester, VA
    Posts
    6,060
    Specs:
    2015 rMBP, 2008 iMac, iPhone 6, iPad mini, 13" MBP, AppleTV and two MacMinis
    Yes, the default for Airport is that the two channels have the same name. You can change that, then tell each machine which of the two is to be preferred. Normally, devices connect to whichever was last, if it's available, or the strongest it can detect, if the last is not available. The preferences change that behavior to look for networks in that order and only if it cannot find any of them to look for the strongest it CAN see.

  13. #13


    Member Since
    Aug 01, 2012
    Posts
    15
    Reply I attempted to post yesterday but failed because internet is tanked:


    Thanks Dennis, if I open Activity Monitor I presume you mean clicking on the Network button? TBH it doesn’t show much except levels of data sent and received. Data sent seems consistently much higher than data received and there seems to be a lot of data being sent even when I’m not using the internet but have windows open. Is that normal?

    Thanks Dave, the ISP is BT Broadband – I’m in the UK. The router is a BT Homehub, type A, less than 6 months old. Don’t know about the protocols, I’d have to ask the provider. Yes I have powered down the router a number of times, if I turn it off and on again, the speed improves for a while then gets slow again. I will do the speed test later when all family members are present. Yes 3.06GHz is the speed of the CPU.

    Cheers Bob and Jake I did phone the provider and he said he’d reset our router to automatically change channels if it was receiving interference from neighbours. I’m not even sure how to change channels myself.

    All the best, Rich G

  14. #14

    MacInWin's Avatar
    Member Since
    Jul 07, 2008
    Location
    Winchester, VA
    Posts
    6,060
    Specs:
    2015 rMBP, 2008 iMac, iPhone 6, iPad mini, 13" MBP, AppleTV and two MacMinis
    In activity monitor in the upper window when you have selected Network, click on either Sent Bytes or Rcvd Bytes to sort them so that the big users are at the top. That will tell you what applications are using the bandwidth the most.

  15. #15

    RadDave's Avatar
    Member Since
    Jan 20, 2012
    Location
    North Carolina
    Posts
    3,347
    Specs:
    MBP 13" (2013); 8 GB RAM; SSD 256 GB; OS 10.11.5
    Quote Originally Posted by Rich Greenland View Post
    Thanks Dave, the ISP is BT Broadband Ė Iím in the UK. The router is a BT Homehub, type A, less than 6 months old. Donít know about the protocols, Iíd have to ask the provider. Yes I have powered down the router a number of times, if I turn it off and on again, the speed improves for a while then gets slow again. I will do the speed test later when all family members are present. Yes 3.06GHz is the speed of the CPU.
    Hi Rich - as to the portion of your post above - you can obtain a LOT of Wi-Fi information by opening 'System Information' (plenty of ways but a quick one is to type that into Spotlight) - below is a screen capture from my laptop which shows that I'm using an AirPort Extreme supporting 802.11 a/b/g/n (blue arrow); also, I've blocked out my main network of 4 w/ this router, but my MBPro is connected via 802.11 n on channel 149 (other useful information is also provided) - hope this helps. Dave

    .
    Attached Images Attached Images

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slow internet on iMac
    By steveohim in forum OS X - Operating System
    Replies: 2
    Last Post: 08-01-2014, 06:04 PM
  2. Macbook Internet Fast, iMac Internet Slow
    By otnpabka in forum OS X - Operating System
    Replies: 14
    Last Post: 09-10-2012, 03:43 AM
  3. Slow Internet speed on new iMac
    By iPJC in forum Internet, Networking, and Wireless
    Replies: 7
    Last Post: 11-26-2011, 07:30 PM
  4. slow youtube, ichat disconnecting, now slow internet
    By anyaderosa in forum Switcher Hangout
    Replies: 4
    Last Post: 02-01-2010, 01:33 AM
  5. G3 iMac 700 se Internet slow!!
    By geofcoulson in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 05-01-2008, 01:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •