Hi everyone,

I'm Uli and I'm new to this forum, I am very desperate and don't know what else to do anymore. So I hope to find help here.

I bought a wifi repeater last month to get internet in my room on the other side of the apartment. Which worked fine until 3 days ago. Now my MacBook doesn't connect to it anymore. It keeps saying, that the network doesn't has an ip address, or when it has that it still can't connect to the internet.

I did everything I could find on the internet. I reseted the repeater. I set it up completely new.
I deleted and add a new network on my mac, renewed DHCP Lease, added new location, updated repeater, mac and router and it's still not working. Oh, and I did all of it multiple times.
The weird thing about it is that my ipad and my iphone are connecting without any problems to the repeater and keep the connection. Only my mac doesn't like the network.

It would be awesome if someone of you has an idea what else I can do.

Here is some background:

Mac Book Pro, 15-inch Early 2008, Version: 10.7.3
Processor 2.4 GHz Intel Core 2 Duo
Memory 4 GB 667 MHz DDR2 SDRAM

Wifi Repeater
Wireless wifi repeater Blurex R501 -N 300Mbps, latest version 2.0

Comcast, Cisco router (right now I don't have any more information about our network because it's in the room of one my roommates, but I can post them later on.)

But as I said, it worked fine until 3 days ago. The placement of repeater or modem/router hasn't changed.

Thank you so much