Results 1 to 2 of 2
  1. #1

    Member Since
    Mar 24, 2012
    Unhappy Airport Internet stops working when I plug in ethernet cable
    I've been a mac user for going on 20 years now, and I've never experienced anything like this. What makes it even more weird is this process use to work FINE, but now I have no clue why it no longer works.

    I use a Mac Pro (no internet) for all my business work, and a macbook for my emailing & uploading/transfer files on the internet. When needed I will transfer files from my Mac Pro to Macbook via ethernet and proceed to upload them to the internet, or vice versa (download files from the internet to my macbook and transfer them via ethernet to my Mac Pro). In the past this was seamless, as I would just leave the ethernet plugged in, have the Mac Pro open in my sharing, and drag and drop files as needed. However recently, for some reason unknown to me, whenever I plug in an ethernet cable into my macbook, my internet no longer works! For example, I can have ichat open and in a video conference on my Macbook, and if I plug an ethernet cable into the macbook, the video conference will immediately stop and I'll be disconnected from ichat. I don't even need to connect to the mac pro, just the simple act of plugging in the ethernet cable causes the internet to stop working!

    In my network preferences, both ethernet and airport say their connected (green light) and local file transfers over airport with ethernet plugged in still work, but the internet for some reason stops working (websites, ichat, etc all no longer load). As soon as I unplug the ethernet, all internet activities start working again. Like I mentioned before, this process use to work fine, and I was able to be on the internet and file share via ethernet at the same time. Something has happened though and this no longer works.

    Any advice would be greatly appreciated, as I have no clue what to do to fix this! Thank you.

    Macbook 1.83 Intel Core 2 Duo, OS 10.6.8

  2. #2

    Member Since
    Mar 24, 2012
    I figured it out. Reordering my services in network preferences solved it.

    Here's how to do it if you're having the same problem in 10.6.8:

    Go to your network preferences.
    On the lower left hand side you will see a disclosure triangle next to the plus/minus buttons
    Click on "Set Service Order"
    And make it so your airport is above ethernet in the list of priorities.

    I currently have my ethernet cable plugged in while typing this, so it worked for me! Hope this helps someone else in the future.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No Internet with Ethernet Cable--WTH!!
    By gatrapper in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 07-27-2014, 12:45 AM
  2. Unable to connect to internet via ethernet cable
    By ernestha3001 in forum OS X - Operating System
    Replies: 4
    Last Post: 10-13-2012, 06:03 PM
  3. Cannot connect to Internet using ethernet cable
    By himalay in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 01-20-2011, 04:24 PM
  4. Internet stops working
    By jwpdad in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 11-30-2009, 05:04 PM
  5. airport saying 'Ethernet unplugged' and when plugged in the phone line stops!?
    By jackusmacus in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 03-30-2009, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts