Mac Forums

Mac Forums (
-   Internet, Networking, and Wireless (
-   -   WiFi Connection to DIR-615 Router with Macbook Pro (

ferrel 12-27-2011 10:32 AM

WiFi Connection to DIR-615 Router with Macbook Pro
My system:
Desktop computer, windows xp (router connected to this via ethernet cable)
Arris Cable Modem TM402 (from Comcast; my ISP is Earthlink)
+ several wireless devices I want to connect

What I did:
Power cycled everything, ran the Wizards for the router.

Desktop computer works fine with it.
Samsung Epic 4G works fine with the wireless router.
Nook Color: Connects to the router, but no internet.
Macbook Pro: either "connection timed out", or "connection failed"

I need help to get my Macbook Pro connected. Any help
greatly appreciated.

Below are the router settings after I ran the Wizards.

D-615 Wireless Router Setup info
Hardwave Version: E1
Firmware Version: 5.00NA

Internet Connection:
Internet Connection Type: Dynamic IP (DHCP)
Enable Advanced DNS Service: Yes
Host Name: DIR-615
Use Unicasting: Yes
Primary DNS Address: (greyed)
Secondary DVS Address: (greyed)
MTU: 1500
MAC Address: 00:40:ca:98:15:3e

Wireless Connection Setup:
Wi-Fi Protected Setup
Enable: No
Current Pin: 00000000
Wi-Fi Protected Status: Disabled/Configured

Wireless Network Settings
Enable Wireless: Yes Always
Wireless Network Name: Zorkon
802:11 Mode: Mixed 80211n, 802.11g, and 802.11b
Enable Auto Channel Scan: Yes
Wireless Channel: 2.437GHz - Ch 6 (Greyed)
Channel Width: Auto 20/40 MHz
Visibility Status: Visible

Wireless Security Mode
Security Mode: WPA-Personal

WPA Mode: WPA Only
Cipher Type: TKIP and AES
Group Key Update Interval: 3600 (seconds)

Network Settings
Router IP Address:
Subnet Mask:
Device Name: dlinkrouter
Enable DNS Relay: Yes (greyed)

DHCP Server Settings
Enable DHCP Server: Yes
DHCP IP Address Range: to
DHCP Lease Time: 10080 minutes
NetBios Announcement: No
Learn NetBios from WAN: no
NetBios Scope: Blank
NetBios node type: Yes Broadcast Only (greyed)

ADD/EDIT DHCP Reservation
Enable: No

HARDWARE Address Assigned IP Hostname
b4:07:f9:c0:b9:8d UNKNOWN (my Samsung Epic 4G)
00:40:ca:98:15:3e YOUR-34EFF17BD0a (my Desktop computer)
58:67:1a:1c:7e:67 android_43264e50 (my Nook Color)

cwa107 12-27-2011 10:37 AM

Make sure that SSID broadcast is enabled. Also, make sure that MAC filtering is *not* enabled (or if it is enabled, add your MBP's MAC address to the table).

Also, be sure you're running the latest firmware on the router.

ferrel 12-27-2011 10:58 AM

The SSID is "visible", is that what you mean?

I don't see anything about "MAC Filtering" anywhere.
What table? Do you mean to set up a DHCP reservation?

Thanks for your reply.

cwa107 12-27-2011 11:38 AM


Originally Posted by ferrel (Post 1345684)
The SSID is "visible", is that what you mean?



I don't see anything about "MAC Filtering" anywhere.
What table? Do you mean to set up a DHCP reservation?
If you've never configured MAC Filtering, then you probably do not have it enabled. It's different from a DHCP reservation (which should almost never be necessary).

Did you check for a firmware update from D-Link?

ferrel 12-27-2011 02:29 PM

The firmware is up to date.

All times are GMT -4. The time now is 11:22 PM.

Powered by vBulletin
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.