Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Internet, Networking, and Wireless (http://www.mac-forums.com/forums/internet-networking-wireless/)
-   -   iMac (airport) has hard time connecting to wireless (http://www.mac-forums.com/forums/internet-networking-wireless/258035-imac-airport-has-hard-time-connecting-wireless.html)

iMacSnow 11-21-2011 09:23 PM

iMac (airport) has hard time connecting to wireless
 
I'm new to the Mac world and so far so good EXCEPT for the wireless connection issue. These are the messages I get when I try to connect to a wireless signal using airport:

"AirPort does not have an IP address and cannot connect to the Internet."

"AirPort has the self-assigned IP address xxxxxxxxxxxxx and will not be able to connect to the Internet."


It usually connects after a 15-20 minute wait or sometimes I can click on "Renew DHCP Lease" and that will work but not always.

Notes:
- I'm running Snow Leopard v10.6.8.
- I have no problem connecting w/ my ipad or pc

Any suggestions?

pendlewitch 11-22-2011 02:10 PM

Hi,
Have you used the diagnostics in Network Preferences at all ?

iMacSnow 11-23-2011 06:39 PM

Quote:

Originally Posted by pendlewitch (Post 1329840)
Hi,
Have you used the diagnostics in Network Preferences at all ?

I ran diagnostics once after it failed to connect but didn't help much.

Anyone else have any suggestions?

pendlewitch 11-24-2011 04:45 AM

The message seems very specific. When you booted up your iMac for the first time it should have asked you if you wanted to connect to the wireless connection it found. Unless you configured it later manually?

In System Preferences/Network/Wireless do you have Location 'Automatic checked and Wi-Fi turned on ?

iMacSnow 11-24-2011 01:44 PM

Quote:

Originally Posted by pendlewitch (Post 1330702)
In System Preferences/Network/Wireless do you have Location 'Automatic checked and Wi-Fi turned on ?

In System Preferences/Network, I do not see "Wireless" and only see "Airport", "Ethernet", and "Firewire".

This morning the airport had no issues connecting to the wireless. I'm wondering if it had anything to do w/ clicking "Turn AirPort Off" last night.

Also, I noticed when I restart the computer, it would connect with no issues. It's only when I put the imac to sleep w/o turning airport off that this issue seems to be happening.

osxx 11-24-2011 02:13 PM

System Preferences > Network >Left Column at the top should be Wi-Fi with a green dot
showing connected and on the left column status connected should show your network if not click on advanced Wi-Fi > Preferred network drag yours to the top and edit the rest if any others are listed.

iMacSnow 11-24-2011 02:34 PM

Quote:

Originally Posted by osxx (Post 1330933)
System Preferences > Network >Left Column at the top should be Wi-Fi with a green dot
showing connected and on the left column status connected should show your network if not click on advanced Wi-Fi > Preferred network drag yours to the top and edit the rest if any others are listed.

hmm I don't see Wi-Fi anywhere, even when I click Advanced. I only see:
AirPort | TCP/IP | DNS | WINS | 802.1X | Proxies | Ethernet

chscag 11-24-2011 02:52 PM

Quote:

Originally Posted by iMacSnow (Post 1330942)
hmm I don't see Wi-Fi anywhere, even when I click Advanced. I only see:
AirPort | TCP/IP | DNS | WINS | 802.1X | Proxies | Ethernet

Are you actually connected to WiFi when opening System Preferences, Network? If not, WiFi will not show up on the list. Make sure you're connected and locked on to the signal, then open System Preferences, Network, and do what member osxx said.

harryb2448 11-24-2011 03:44 PM

Did wifi only appear with Lion? From memory when running Snow Leopard did state Airport. Seeing Airport under Advanced confirms this. Location is Automatic and the network name appears in the window pane?

Have you tried re-setting the modem/router and if no joy follow the manual to go into the browser address and set up a new network. And when you go into Advanced > DNS do two sets of IP addresses appear there? If not ask your ISP for the addresses. One is primary and the second one, secondary of course.

pendlewitch 11-24-2011 04:06 PM

1 Attachment(s)
Quote:

Originally Posted by chscag (Post 1330954)
Are you actually connected to WiFi when opening System Preferences, Network? If not, WiFi will not show up on the list. Make sure you're connected and locked on to the signal, then open System Preferences, Network, and do what member osxx said.

Mine looks like this, and yes I recall it used to be called 'Airport'.

The router address is what you should paste into your Safari address bar to access the router's utility as harryb2448 was explaining.

iMacSnow 11-24-2011 09:21 PM

Thanks for all the help guys.

looks like clicking "Turn Airport Off" whenever I'm done using the computer, then turning it on again does the trick.

harryb2448 11-24-2011 09:29 PM

Well always personally turn it on in System preferences and turn off in Menu Bar, if you have show status in menu Bar selected.

iMacSnow 12-05-2011 10:02 PM

So after a week of successfully connecting to the airport using the "turn airport on/off" method, I'm having the same issues again!!

Seems like when the airport self assigns an IP address, it starts w/ 169 and doesn't connect. When it finally chooses to connect, the IP address starts w/ a 192.

I just don't get it. Do you guys think it's a faulty airport card?


All times are GMT -4. The time now is 11:12 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.