Results 1 to 4 of 4
  1. #1

    Member Since
    Nov 03, 2011
    What files are involved with routing in Lion?
    To start from the beginning...

    I came home one day from work with my somewhat new macbook to discover that Lion was no longer able to connect to the internet. After many hours of troubleshooting I was left with the following...

    I can connect to my wireless router okay. My router is connected to the internet just fine (I can ping any domain from my router's console). Lion's browsers and terminal cannot ping or connect to any domain or IP. I run Parallels inside of Lion and my Windows 7 virtual machine can connect to the internet just fine (this is how I'm writing this). When I take my macbook to work the wireless and wired (usb adapter) internet works flawlessly. I've checked to make sure my router hasn't blocked my mac or ip address and reset the router many times. I've confirmed with my internet provider that they do not have any kind(s) of blocks on my account (should be obvious as any other OS on any hardware can connect perfectly fine). I have the most recent versions and updates of all software installed in Lion and Windows.

    When I ping an IP I get the following...
    request timeout for ICMP_seq(n)
    no route to host

    When I try to get any information from netstat, it just spins and spins and tries and tries for ages and doesn't give me anything, all while Activity Monitor is showing tons of traffic coming in and going out through the network (from Windows).

    It started around the time I installed CentrifyDC, because Lion refused any attempt to bind to my work domain. I use this is my work computer and I need to be able to access network resources. I've talked with my fellow geeks in IT at work about it and they have no idea as they all only know Windows.

    So I'm left with this being a routing problem, caused by some file that was created, modified, or deleted during the CentrifyDC installation. (Yes, I uninstalled CentrifyDC).

    A further issue is that I have bootcamp installed and therefore Lion will not reinstall because of that. I have a TimeMachine backup, but it is currently on a disk that only my Windows machine can read. Lion refuses to acknowledge the HFS+ partition that Windows can read and write to (I have paragon installed).

    I feel like my only real option is to completely format the entire drive, go buy another external hard drive, pray I can get my backups back up, and reinstall everything. I'd really rather not have to go through all that trouble if I could fix this with one line in Terminal...

    I haven't felt this helpless in a long time. Can someone please at least point me in the right direction? Please?

  2. #2

    mrplow's Avatar
    Member Since
    Oct 01, 2007
    27" iMac i7 (2011) 10.10, iPhone6, iPad Air 2, AppleTV2
    You may have already tried it but make sure your network settings are set to automatic.

    You can also reset your network settings:
    - disconnect from all networks (wifi or cabled)
    - in Finder go to /Library/Preferences/SystemConfiguration
    - Rename preferences.plist to preferences.plist.old (in case you need to go back to the current configuration)
    - restart your Mac and try to connect to your router
    - test internet connection etc

    Post back with how it goes.
    External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

    Please use the reputation system if you think you've been helped - top right of this post

  3. #3

    Member Since
    Nov 03, 2011
    The solution was, as I expected, that my default gateway was not actually what Lion was reporting and had been changed to my work's default gateway as a static route placed in my routing table by some process that was installed or modified by CentrifyDC.

    I went to terminal and did "netstat -rn" and found that indeed my gateway was set to my work's Domain Controller. I did "sudo route flush" to get rid of it, and did "sudo route add default" to fix the route. That lets me get to the internet.

    But something does keep changing it back, and whenever I want to use the internet I have to do those same commands. So some process keeps changing my default route.

    Does anyone know how I can monitor what process is changing my routing table so I can stop it from happening in the future?

  4. #4

    Member Since
    Nov 03, 2011
    I just checked my preferences.plist and discovered the route was in there, so I did as you said and renamed the preferences.plist file, went back into system preferences > Network, setup a new location, and everything was good.

    Would it have fixed it if I had just changed my "location" in the preferences earlier?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how involved is it to transfer files?
    By dwhygienist in forum Switcher Hangout
    Replies: 7
    Last Post: 12-03-2012, 10:26 PM
  2. VPN Routing?
    By jasonjustice in forum OS X - Operating System
    Replies: 0
    Last Post: 02-04-2010, 10:43 PM
  3. Audio Routing Software
    By jmarkbangerter in forum OS X - Apps and Games
    Replies: 1
    Last Post: 01-25-2010, 07:55 AM
  4. Audio Output Routing
    By jmarkbangerter in forum Music, Audio, and Podcasting
    Replies: 0
    Last Post: 01-23-2010, 02:25 AM
  5. pre-N routing
    By jdgti in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 10-16-2006, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts