Results 1 to 10 of 10
  1. #1


    Member Since
    May 25, 2009
    Posts
    7
    Unhappy Help!? No IP/Self-assigned address.
    Hey there all...
    any one having this "self-assigned IP" problem? (still ?)
    For me it started a week ago, one day i was surfin' the net at home on my mac book [ OS X 10.6.8 ] (thru a wifi connection), it was all normal.. all the bars were lit up on the airport icon at the top, then the pages didn't load and i saw a " ! " on the airport icon
    in network settings under AirPort it says ether:

    1.AirPort does not have an IP address and cannot connect to the Internet.
    2.AirPort has the self-assigned IP address 169.254.200.59 and will not be able to connect to the Internet.
    or just plain simple..
    3.Self-Assigned IP

    So after that, i google this thing and i read a couple of forums and tried these things out, witch did didly-squat.(nothing)

    1. In Network>Advance>Airport>Preferred Networks-
    I had there a couple of networks i used before (at friends, family houses or any free wifi spots) i deleted all the other networks besides the one i want to use at home.

    2. I also tried to "renew DHCP Lease" under Network>Advance>TCP/IP

    3. in the network settings i also tried this: delete the Airport. Apply and closes the system preferences, then open it back up and create a new Airport

    4.Disconnect the telephone line from the modem (but let the modem still be connected to power) for 30 min. I read that it was going to reset it self and after 30 min pass and i connect the cable back it would send a new IP to my mac, buuuuut it didn't

    By the way, i use this ( http://www.tp.pl/b/binaries/PL/35802..._366613532.pdf ) to connect to the internet thru wifi. Sorry its all in polish, yes I am Polish and currently living in Poland
    To this modem i have connected one widows PC, a Mac book (10.6.8), an iMac (10.4.11), and a ipod touch.
    On my iMac i never had this problem with the airport, it works fine. Just with the Macbook now.

    5. this other thing i tired witch i thought of myself:
    under, Network>Advance>TCP/IP
    i switched the ConfigureIPv4 from "Using DHCP" to " Using DHCP with manual address" and looking at the network settings that i have on my iMac i just typed in everything in the macbook that was on the imac network settings, applied and.. for a second there i thought i was a computer genius (witch obesely i am definitely not. lol) because after i applied the airport icon on the top flashed full fore bars or.. tree bars and a dot, depends on how you look at it but then after like 5 seconds the "!" came back on...

    Right now i'm on my macbook connected thru the ethernet cable from my modem as you can probably tell by now, i am noooot that good with computers. The thing is.. when i plugged the ethernet cable in to my macbook the airport icon showed and is still showing all bars but in system preferences it still says " Self-Assigned IP " ( WHY????? lol)
    When i unplug the ethernet cable the " ! " comes back on the airport and no internet ..

    Now my settings under: Network>Advance>TCP/IP
    are..
    Configure IPv4: Using DHCP.
    under there it also shows an "IPv4 Address"
    and a "Subnet Mask"
    the Router spot is empty tho.. nothing there

    under "Configure IPv6" i have it set to Automatically.
    and there are
    tree more spots witch are empty:
    1.Router
    2.IPv6 Address
    3.Prefix Length

    I dont know if thats all good or not, and i have no idea what els should i try the forums i found about this topic had posts from like .. 2006 - 2009 and a few from 2010 and even fewer from 2011 ..
    the posts from 10-11 were mostly like " Hey keep this topic going i have th same problem and i need help"
    but most of those threads are dead..

    PLEASE, if any one could help or give any kind of advice, that would be awesome!
    this no IP thing is so freeken' annoying.

    ..and just off to the side, do you think this is an apple bug/thing or is it just the wifi it self.. oooorr is it my internet service provider?

    I hope to hear from some one soon..
    you can also email me at: 1cookiemonsta@gmail.com

    OH! one more thing, i'm downloading some system updates right now, maaaybe the update will help me ... i sure hope so..

  2. #2


    Member Since
    May 25, 2009
    Posts
    7
    Well, the update didn't help :/

  3. #3

    Dysfunction's Avatar
    Member Since
    Mar 17, 2008
    Location
    Tucson, AZ
    Posts
    6,881
    Specs:
    Way... way too many specs to list.
    try deleting your network preferences and rebooting.
    mike
    This machine kills fascists
    Got # ? phear the command line!

  4. #4

    osxx's Avatar
    Member Since
    Jan 19, 2008
    Location
    houston texas
    Posts
    4,695
    Specs:
    09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
    Quote Originally Posted by Cookiee View Post
    Hey there all...
    any one having this "self-assigned IP" problem? (still ?)
    For me it started a week ago, one day i was surfin' the net at home on my mac book [ OS X 10.6.8 ] (thru a wifi connection), it was all normal.. all the bars were lit up on the airport icon at the top, then the pages didn't load and i saw a " ! " on the airport icon
    in network settings under AirPort it says ether:

    1.AirPort does not have an IP address and cannot connect to the Internet.
    2.AirPort has the self-assigned IP address 169.254.200.59 and will not be able to connect to the Internet.
    or just plain simple..
    3.Self-Assigned IP

    So after that, i google this thing and i read a couple of forums and tried these things out, witch did didly-squat.(nothing)

    1. In Network>Advance>Airport>Preferred Networks-
    I had there a couple of networks i used before (at friends, family houses or any free wifi spots) i deleted all the other networks besides the one i want to use at home.

    2. I also tried to "renew DHCP Lease" under Network>Advance>TCP/IP

    3. in the network settings i also tried this: delete the Airport. Apply and closes the system preferences, then open it back up and create a new Airport

    4.Disconnect the telephone line from the modem (but let the modem still be connected to power) for 30 min. I read that it was going to reset it self and after 30 min pass and i connect the cable back it would send a new IP to my mac, buuuuut it didn't

    By the way, i use this ( http://www.tp.pl/b/binaries/PL/35802..._366613532.pdf ) to connect to the internet thru wifi. Sorry its all in polish, yes I am Polish and currently living in Poland
    To this modem i have connected one widows PC, a Mac book (10.6.8), an iMac (10.4.11), and a ipod touch.
    On my iMac i never had this problem with the airport, it works fine. Just with the Macbook now.

    5. this other thing i tired witch i thought of myself:
    under, Network>Advance>TCP/IP
    i switched the ConfigureIPv4 from "Using DHCP" to " Using DHCP with manual address" and looking at the network settings that i have on my iMac i just typed in everything in the macbook that was on the imac network settings, applied and.. for a second there i thought i was a computer genius (witch obesely i am definitely not. lol) because after i applied the airport icon on the top flashed full fore bars or.. tree bars and a dot, depends on how you look at it but then after like 5 seconds the "!" came back on...

    Right now i'm on my macbook connected thru the ethernet cable from my modem as you can probably tell by now, i am noooot that good with computers. The thing is.. when i plugged the ethernet cable in to my macbook the airport icon showed and is still showing all bars but in system preferences it still says " Self-Assigned IP " ( WHY????? lol)
    When i unplug the ethernet cable the " ! " comes back on the airport and no internet ..

    Now my settings under: Network>Advance>TCP/IP
    are..
    Configure IPv4: Using DHCP.
    under there it also shows an "IPv4 Address"
    and a "Subnet Mask"
    the Router spot is empty tho.. nothing there

    under "Configure IPv6" i have it set to Automatically.
    and there are
    tree more spots witch are empty:
    1.Router
    2.IPv6 Address
    3.Prefix Length

    I dont know if thats all good or not, and i have no idea what els should i try the forums i found about this topic had posts from like .. 2006 - 2009 and a few from 2010 and even fewer from 2011 ..
    the posts from 10-11 were mostly like " Hey keep this topic going i have th same problem and i need help"
    but most of those threads are dead..

    PLEASE, if any one could help or give any kind of advice, that would be awesome!
    this no IP thing is so freeken' annoying.

    ..and just off to the side, do you think this is an apple bug/thing or is it just the wifi it self.. oooorr is it my internet service provider?

    I hope to hear from some one soon..
    you can also email me at: 1cookiemonsta@gmail.com

    OH! one more thing, i'm downloading some system updates right now, maaaybe the update will help me ... i sure hope so..
    Under router you need an IP for example if you are using 2Wire from Uverse
    it would be 192.168.1.254 if you get one that starts 169.xxx.x.xxx this is a default when the IP can not be established.
    As was mentioned re-boot both the router/modem and the Mac.
    What brand and model router is it?

  5. #5


    Member Since
    May 25, 2009
    Posts
    7
    Thanks for responding so fast
    umm.. i tried to reboot the router and the mac,
    also tried deleting the network preference and then rebooting the mac and router...
    still nothing, still the same ... :/

    oh and the router is "Livebox 1.1" [ Orange Livebox - Wikipedia, the free encyclopedia ]

  6. #6


    Member Since
    May 25, 2009
    Posts
    7
    i just tried this (it KIND OF worked lol ... >_>)
    under Airport>Network>advanced>TCP/IP
    i changed the "Configure IPv4" from "using DHCP" to "using DHCP with manual address"
    and entered the IPv4 Address from "Ethernet>networks>Advanced>TCP/IP"
    the airport icon in the network pref. turned green and it said "connected" it even says "AirPort is connected to neostrada_6787 and has the IP address 192.168.1.11. " the airport icon on top is showing all the bars.
    Seems awesome right?, i got really happy that this thing is fixed, until i opened safari and the page did not load.
    after that i tried rebooting the mac and the router and its still the same, the bars light up and it says its connected but the pages wont load. :/
    I also tried two other browsers Firefox and Chrome, but none of them can load any pages..

  7. #7


    Member Since
    May 25, 2009
    Posts
    7
    Please help !!... im still haveing this problem ..
    anyone?

  8. #8

    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,938
    Specs:
    iMac 2010 27" QuadI7 OSX10.11, iMac 2008 OSX10.11, MBP Late2011OSX10.11 , iPad Air, iPhone 3GS
    You have other computers connected to that router and they are getting an IP and working on the net?

    I tried to read as much of your posting as I could.

  9. #9


    Member Since
    May 25, 2009
    Posts
    7
    Quote Originally Posted by dtravis7 View Post
    You have other computers connected to that router and they are getting an IP and working on the net?

    I tried to read as much of your posting as I could.
    every computer/ipod/phone that was connected trhu wifi to the router was geting an IP and was working fine.. except my macbook osx10.6

  10. #10


    Member Since
    May 25, 2009
    Posts
    7
    Cool
    YES YES YES !!!!
    i found a fix !!!
    Haha, so happy finally.. after a good month of fighting with this thing .. trying pretty much EVERY thing i can.. that i found in this and a couple of other forums.

    Today searching for a fix for this self assigned problem, i stumbled upon this thread (Airport problem: self assigned IP address? - Page 7 - The macosxhints Forums)
    in there i found a post from "colin6272" a fix that helped me, i changed my router from a WAP password to a WPA one. and it worked.
    Here is how i did it.

    I went in to my configuration of the router by typing in the routers numbers in the web browser witch i found in "System preferences>Network>Ethernet>Advanced>TCP/IP " (while connected thru a ethernet cable to the router) in there thare are a couple of things that show up like your IPv4 adress, subnet mask, .. theres a couple of other things but look for "Router:" copy that number .. the "192.xxx.x.x" and paste it in to your browser adress bar, hit enter/return.
    A page will load up and it will probably ask you for a user name and a password, most likely both are gonna be "admin" unless you changed it to something els ..

    Now for this part..i cant tell you exactly step by step because you probably have a different router and the config. probably looks a little different, but you have to look around for something like a "wireless tab" or .. somethin' like that and when you do find it, it will show you your MAC address, your SSID, your channel and a couple of other things but look for the section where it says "security" or somethin' like that and change it from WAP to WPA when you change it and apply the changes a password will show, copy that save it somewhere or just remember it cuz you'll need it later.

    Now, after applying the changes in your router go to "System preferences>Network>Airpot>Advanced>AirPort" in the "preferred Networks" click on the network you just configured and click the edit button change the Security from "WAP Password" to "WPA Personal" enter the password you got before, save, click ok and apply.

    Now it should work.
    It did for me and i'm EXTREMELY happy !
    Because i been so frustrated with this thing and fighting this thing for a month .. ughh..
    but now its fixed

    if this didn't help i probably would of tried changing to a new router.
    I really hope this helped someone too, because i know how frustrating this self assigned ip thing can be.
    Oh and thanks to "colin6272" from http://hintsforums.macworld.com/showthread.php?p=640247 for posting this .. cuz i pretty much reposted this

    if you got any questions, just ask.. maybe i can help you

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Self-assigned IP address/no IP address, internet connection issue
    By leechalmers in forum Internet, Networking, and Wireless
    Replies: 7
    Last Post: 06-07-2013, 11:33 PM
  2. Self-Assigned IP Address
    By Cormag001 in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 12-30-2011, 02:02 AM
  3. Self assigned ip address
    By hollymaya in forum Internet, Networking, and Wireless
    Replies: 11
    Last Post: 05-24-2011, 04:03 PM
  4. Self-Assigned IP address
    By raechul in forum Internet, Networking, and Wireless
    Replies: 10
    Last Post: 04-05-2011, 11:49 AM
  5. Self Assigned IP Address
    By BGvlm620 in forum Internet, Networking, and Wireless
    Replies: 7
    Last Post: 06-19-2010, 11:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •