Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Internet, Networking, and Wireless (http://www.mac-forums.com/forums/internet-networking-wireless/)
-   -   Strange problems sharing internet to iPod Touch (http://www.mac-forums.com/forums/internet-networking-wireless/253317-strange-problems-sharing-internet-ipod-touch.html)

EliotKami 10-13-2011 03:34 AM

Strange problems sharing internet to iPod Touch
 
Hello all,
having a lot of trouble getting online here in China and would greatly appreciate some help.
The place I'm staying has Ethernet, which I can only access by manually entering an IP, Subnet Mask, Router and a single DNS server. I'm getting online without a problem using this, but when I try to share my connection over AirPort things go funny.
My Internet Sharing network (which I hilariously titled 'SkyNet', not realising it would have the same malignancy towards humanity as its namesake) only appears sporadically on my iPod Touch. When I go into WLAN networks other networks appear each time, but SkyNet comes and goes. I often have to wait a minute or two for it to appear, and then when I try to connect I get an 'Unable to join the network "SkyNet"' message.
I have set up my MacBook Pro and iPod Touch's networks according to the instructions in this article [ How to Set Up Internet Sharing on Mac OS X — Light Year Software ], but it still doesn't work. Airport however, shows as being connected to SkyNet and having the static IP which I have assigned it. Also, I have successfully shared my MacBook's ethernet connection with my iPod Touch in other places (without using static IPs, etc) with no problem.
Again, this is very frustrating and I would dearly appreciate any help. My network settings are below.


MacBook Pro Ethernet
IP: 192.168.x.x
Subnet Mask: 255.255.255.0
Router: 192.168.x.x
DNS: 192.168.x.x

MacBook Pro Airport
IP: 10.0.2.x
Subnet Mask: 255.0.0.0
Router: (same as above)

iPod Touch
IP: 10.0.2.(x+1)
Subnet Mask: 255.0.0.0
Router: (same as AirPort IP)

I've also tried giving the AirPort and iPod Touch 192.168.x.x addresses, to no avail

EliotKami 10-13-2011 11:13 AM

On the advice of a friend I installed and ran a program on my MacBook called 'IPSecuritas'. This has stopped my wireless network from appearing and disappearing, but I still can't connect. Would really appreciate some help with this.


All times are GMT -4. The time now is 10:14 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.