New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus • Advice and insight from world-class Apple enthusiasts • Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Internet, Networking, and Wireless Discussion of networking, internet, and wireless including Apple's Airport products.

File Sharing - "Snow Leopard" and Win 7


Post Reply New Thread Subscribe

 
Thread Tools
Tomel

 
Member Since: Apr 19, 2011
Location: Virginia
Posts: 35
Tomel is on a distinguished road
Mac Specs: Early 2011 MBP i5 2.3GHz 13" 8Gb Ram 120Gb SSD

Tomel is offline
I'm an experienced Windows user, but new to the Mac OS. I just spent a lot of time setting up file and folder sharing between my Win 7 Desktop and my new MacBook Pro. Seems there's a lot of research and advice out there on how to accomplish this, but I could not find any post that covered the topic thoroughly enough for someone with no prior knowledge of one of the two OS environments. Accordingly, I put together a step-by-step outline on how to accomplish Win 7 and Snow Leopard File sharing. Hope it helps someone out there.

How to set up file sharing between a Mac OS “Snow Leopard” Computer and a Windows 7 Computer

Notes:

1. These instructions assume that your Mac and your Windows Computers are both password protected
2. At certain points you may be asked to enter your Administrator’s account password in order to continue

Mac Preparation

1. Go to System Preferences/Sharing and put a check mark in left panel box for File Sharing
a. Only public folder is shared by default
b. To add additional folders to share, click the “+” sign in the Shared Folder box and choose additional folders to be shared
c. Once folders to be shared have been selected, click on each folder to be shared and set permissions, e.g. “Read Only”, “Read & Write”, etc.
2. After choosing folders to be shared and setting permissions, click the “Options” button in the Sharing window
a. Check the box “share files and folders using SMB
b. Click “Done”
3. Click “Show All” and then click the “Network” icon
a. Click “Advanced”
b. Click the “Wins” tab
c. Enter WORKGROUP on the Workgroup line
d. No other entries are necessary in this window, so click OK.

Windows Computer Preparation

1. Click Start Button, right click on Computer and select “Properties”
2. Click “Advanced System Settings” in left panel
3. Click “Computer Name” tab
4. If the Workgroup line does not read WORKGROUP, click the change button
5. At the bottom of the window, click the Workgroup button and enter WORKGROUP
6. Click OK and then OK again
7. Click on Start Button, then Control Panel and select Network and Sharing
a. Click on Home network under “view your active networks”
b. Select “Work network”
8. Exit all open windows

Logging On To Access Shared Folders

Windows

1. Make sure both your Windows and Mac are turned on and you are logged into your user accounts on each system
2. Open Explorer
3. Double click on Network in the left panel. You should see WORKGROUP listed. Single click WORKGROUP.
4. Enter your Windows Administrator account name and your Windows Administrator account password.
5. Click OK. You should now be able to view your shared Mac files

Mac

1. Open Finder
2. Click “Go” in the Finder menu
3. Click “Connect to Server . . .”
4. In the “Server Access” box, type smb:// followed by your Windows Computer Name (Example: smb://MyWindowsComputer)
5. Click “Connect”
6. On the next window that appears, enter the user name of your Windows computer and the password for that Windows user account.
7. On the next window, select the volumes you want to mount (in other words, the folders you want to share)
8. Click OK. You should now be able to view your shared Windows files.

Limiting Windows Folders and Files to be Shared

When you check the shared Windows Folders and Files on your Mac, you may discover that all of your Windows folders have been shared. If this is true and you want to limit what Windows files are shared with your Mac, follow the following procedure on your Windows system.

1. Open Explorer
2. Click Local Disk in the left panel
3. Right Click the “Users” Folder
4. Select “Properties” and then select the “Sharing” Tab
5. Click “Advanced Sharing”
6. Uncheck “Share this Folder”
7. Click “Apply”, then Click “OK” or “Close”
8. Navigate to each folder or file that you DO wish to share and follow the procedure outlined below for each folder or file (navigate using Explorer/Local Disk/Users, NOT using your Documents Library Folder).
a. Right Click on the File or Folder you wish to share
b. Select “Properties” and then select the “Sharing” Tab
c. Click “Advanced Sharing”
d. Check “Share this Folder”
e. Click “Permissions”
f. Set the Permissions you wish to allow for persons sharing this file or folder
g. Click “Apply”, Click “Apply”, Click “Apply” or “Close”
h. This file or folder will now be shared. Continue this procedure for other files or folders you wish to share.
i. After you’ve finished, go to your Mac and verify that the correct folders are now shared. Note that you may have to “Eject” the shared folders and then use the “Go” and “Connect to Server” routine in Finder to see the corrected Shared Folders and Files.

A Final Note

At various times during the setup process and when you are using shared folders and files, you will be asked to enter a login user name and a password. Sometimes it’s not clear whether you should enter the Windows or the Mac information or the Administrator or Standard User information . There must be a pattern and logic to what’s requested, but I haven’t been using the systems long enough to discover that pattern. Just do what I do – experiment until something works and make note of it for future reference.
QUOTE Thanks
Aptmunich

 
Aptmunich's Avatar
 
Member Since: Mar 09, 2004
Location: Munich
Posts: 9,075
Aptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant futureAptmunich has a brilliant future
Mac Specs: Aluminium Macbook 2.4 Ghz 4GB RAM, SSD 24" Samsung Display, iPhone 4, iPad 2

Aptmunich is offline
Wow, very detailed post - nice job!
QUOTE Thanks
IvanLasston

 
IvanLasston's Avatar
 
Member Since: Feb 26, 2010
Location: Rocky Mountain High, Colorado
Posts: 2,116
IvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to behold
Mac Specs: 1.8 GHz i7 MBA 11" OSX 10.8.2

IvanLasston is offline
Good writeup.

I just reinstalled my Mac and am getting everything back together. Something new happened for me - In step 2a on the Mac. I setup share using SMB and clicked OK - but when I tried getting to my Mac from windows using \\ipaddress - it never accepted my password. I believe others have had similar problems. I went back to the dialog just to see if I had SMB enabled and now there is a selection box -> On Account - so you have to pick which accounts are allowed to share on SMB. I checked the box and typed in my password and now the Windows machine can access the mac through Explorer.

I am not sure when that check box showed up - I know when I originally setup the MBP when I first got it I never had to do that. I don't remember seeing it when I reinstalled and did my SMB setup. There is a warning about enabling SMB for users that is above that dialog box. Maybe they did that to tell users that the passwords exchange isn't as secure.
QUOTE Thanks
Tomel

 
Member Since: Apr 19, 2011
Location: Virginia
Posts: 35
Tomel is on a distinguished road
Mac Specs: Early 2011 MBP i5 2.3GHz 13" 8Gb Ram 120Gb SSD

Tomel is offline
IvanLasston . . .

Strange. I just went back and checked and in the smb "On Account" section it does show both of my Mac User accounts, but both are unchecked. I just went over to my Windows System, clicked on WORKGROUP, entered my WINDOWS Administrator Account Name and WINDOWS Administrator Account Password and it immediately connected and showed the shared folders on my Mac. I highlighted that I had to enter my WINDOWS name and password above since logic would say that you should have to enter the Mac information. However, entering the Mac information doesn't work - at least for me.
QUOTE Thanks
IvanLasston

 
IvanLasston's Avatar
 
Member Since: Feb 26, 2010
Location: Rocky Mountain High, Colorado
Posts: 2,116
IvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to beholdIvanLasston is a splendid one to behold
Mac Specs: 1.8 GHz i7 MBA 11" OSX 10.8.2

IvanLasston is offline
Hmm - I didn't go through workgroup. My username/password is the same on both machines. Honestly your write up is what I did when I first got my Mac. After I did a clean re-install I couldn't get through to the Mac shared folders. Both times I use the \\ipaddress way of accessing the shared folders. Well selecting that has gotten it to work again.

Thanks again for the write up
QUOTE Thanks
Chris H.

 
Chris H.'s Avatar
 
Member Since: Oct 03, 2009
Location: Rio Rancho, NM
Posts: 2,603
Chris H. is a jewel in the roughChris H. is a jewel in the rough
Mac Specs: late 2009 MacBook - 10.9

Chris H. is offline
Sorry for the thread hijack, but I didn't want to start a new thread (just yet).

I have three Windows 7 PC's and three Mac computers in the house connected to the same network under the same work group. However, my Mac computers cannot see the Windows computers, and for some reason, all the Windows computers can *see my MacBook's admin folder (admin being the name I chose for the Home folder). I don't want the Windows computers to have access to the Home folder, and I've checked and double and triple checked the Sharing preference pane and it says that under File Sharing, only my Public Folder is visible. What's going on?


*All the Windows computers can also see all the Mac computers.


I don't want the Windows computers to prompt me for a password whenever I need to connect to the Macs:

Mac Mini, Mac OS X 10.6.7 (Snow Leopard)
MacBook, Mac OS X 10.6.7 (Snow Leopard)
PowerMac G4, Mac OS X 10.4.11 (Tiger)

I went through the Sharing pref pane and noticed that Tiger's is completely different from Snow Leopards, among countless other things in relation to network file sharing. I'm so confused.

 iPad mini 1st gen - iOS 8.0
 iPod touch 5th gen - iOS 8.0
 Mac mini Server M10 - OS X 10.9.4
 MacBook Uni L09 - OS X 10.10 PB3
QUOTE Thanks
Tomel

 
Member Since: Apr 19, 2011
Location: Virginia
Posts: 35
Tomel is on a distinguished road
Mac Specs: Early 2011 MBP i5 2.3GHz 13" 8Gb Ram 120Gb SSD

Tomel is offline
Regarding your Macs not seeing your Win 7 computers, have you gone through the procedure under the "Limiting Windows Folders and Files to be Shared" in my original post for each Windows system? Make sure the folders or files you want the Macs to see have the "Share this Folder" item checked off.

Regarding your Win 7 systems seeing more than the Public Folders on your Macs, sounds like you did the right thing. I got mine to work correctly and just show the Public folders using the procedure I outlined in my post. Since I'm new to the Mac world, I'll have to defer on this issue to someone more experienced.
QUOTE Thanks
Matt Price

 
Member Since: Jul 02, 2011
Posts: 3
Matt Price is on a distinguished road

Matt Price is offline
Thanks for a very thorough reply. I will give it a try when I get home.

Cheers

Matt
QUOTE Thanks
CDimock

 
Member Since: Sep 19, 2011
Posts: 2
CDimock is on a distinguished road

CDimock is offline
Hi,

I just recently bought a MacBook Air with OSX 10.7.1. I am trying to connect to my home Windows 7 workgroup. I have searched the web for about 5 days, trying all of the suggested tricks, but I still cannot get my Windows 7 desktop and MacBook Air to see each other.

I have disabled the firewalls on both boxes, set up sharing according to the instructions above, added the workgroup "WORKGROUP" on my Windows 7 computer and added it to my Mac. When I try to "Connect to Server" I just get an error that the device may not exist. I have checked the syntax several times!

My Windows computers can see each other just fine, and all of the computers, including the Mac can get out to the Internet. I have a Cisco access point as my wireless network device (it hangs off of a Linux box that serves as my gateway to the Internet).

I would greatly appreciate any thoughts or suggestions on where I might go next.

Thanks!
QUOTE Thanks
Tomel

 
Member Since: Apr 19, 2011
Location: Virginia
Posts: 35
Tomel is on a distinguished road
Mac Specs: Early 2011 MBP i5 2.3GHz 13" 8Gb Ram 120Gb SSD

Tomel is offline
My original post worked for Snow Leopard, but since I've upgraded to the Lion OS I've been unable to get my Win 7 system to see my Mac System (although the Mac DOES see the Win 7 system). Assuming you're on the Lion OS you may want to see the following web site for some suggestions.

File Sharing Mac OS X Lion and PC Windows 7 | Mac OS X
QUOTE Thanks
CDimock

 
Member Since: Sep 19, 2011
Posts: 2
CDimock is on a distinguished road

CDimock is offline
Quote:
Originally Posted by Tomel View Post
My original post worked for Snow Leopard, but since I've upgraded to the Lion OS I've been unable to get my Win 7 system to see my Mac System (although the Mac DOES see the Win 7 system). Assuming you're on the Lion OS you may want to see the following web site for some suggestions.

File Sharing Mac OS X Lion and PC Windows 7 | Mac OS X
Hi,

Thanks for the pointer. The instructions are very clear, but despite having worked through them twice in detail, I still cannot get either computer to see the other. From either computer it looks like the other just doesn't exist. I cannot traceroute from one to the other, and the error messages consistently indicate that the IP address of the other computer is unreachable.

I read somewhere that file sharing was accomplished using IPv6. If that is true, I noticed that IPv6 is disabled on my wireless access point, and that is most likely the cause of my problem. I thought it strange that this would be the case as on both systems, I am using an IPv4 address to try to get to the other machine. Does sharing use IPv6?

Any help is greatly appreciated!

Thanks!
QUOTE Thanks

Post Reply New Thread Subscribe


« The internet doesn't use my full speed...? | Facebook hacked (can't open); otherwise internet fine »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
OSx Leopard network file sharing harsha.w@ OS X - Operating System 1 07-08-2008 08:58 AM
Mac Book Pro and Win xp network, can't see windows sharing in Mac sdelsack Switcher Hangout 2 06-29-2008 05:10 PM
Sharing libraries between Mac and Win iTunes? richarnd iPod Hardware and Accessories 0 07-28-2007 06:47 PM
Connecting to a Win 2000 File Server zunacai OS X - Operating System 0 09-13-2006 09:11 AM
Can't sell ALL shares on Win 2003 File Server jsbaker OS X - Operating System 1 06-10-2005 07:22 AM

All times are GMT -4. The time now is 04:54 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?