Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Internet, Networking, and Wireless (http://www.mac-forums.com/forums/internet-networking-wireless/)
-   -   Sharing Win7 Canon Multifunction Printer with new MacPro (http://www.mac-forums.com/forums/internet-networking-wireless/235986-sharing-win7-canon-multifunction-printer-new-macpro.html)

Tomel 04-19-2011 05:45 PM

Sharing Win7 Canon Multifunction Printer with new MacPro
 
I give up! That’s not easy to say for a Windows guru who can solve almost any PC problem, but is new to the Mac world (other than this problem, I love the Mac and the Mac OS so far).

The Problem: I can’t print from my MacBook Pro to the Windows-connected Canon multifunction printer.

The Facts – PC Side
- Running Windows 7 Home Premium fully updated (including SP1)
- Multifunction printer is Canon MF4370dn
- Printer is connected to Windows desktop via USB
- Windows desktop is connected via Ethernet cable to Verizon Actiontec Router
- Router wireless security is WPA2 and MacPro connected easily once appropriate passphrase was supplied.
- All available firmware updates have been applied to printer
- All printer functions work perfectly (print, scan, fax, etc.)

The Facts – MacPro Side
- New MacPro Notebook with i5 Sandy Bridge Processor
- Snow Leopard OS fully updated
- Was able to get file-sharing to work with Win7 desktop (after some trials and tribulations)

Steps that I’ve Taken So Far

Note that the steps shown below are based on having done an extensive web search. I did not find a single post that covered all of the steps shown below, but rather the steps shown were culled from many posts that were not complete (at least not complete from the standpoint of a Mac neophyte).

Windows Desktop Preparation

- User Account Name: MyUser, password protected
- Workgroup: WORKGROUP
- Computer Name: MyComputer
- Computer IP Address (from ipconfig): 192.168.1
- Made sure Windows Firewall was set to allow printer sharing
- Using Windows Programs and Features, turned on LPD Print Service (did not turn on LPR Port Monitor, since this was not mentioned in any of my web research)
- Control Panel/Devices and Printers
o Printer Icon on this page is named “Canon MF4360-4390”
o Selected Printer, Clicked File/Printer Properties
Selected Sharing Tab, checked “share this printer”, entered share name of “CanonMF4370dn”
Under Security Tab, clicked “Everyone” – verified that it showed printing is allowed
- From Control Panel/Network and Internet/Network and Sharing Center/Change advanced sharing settings, set the following settings for Home Network
Turned on network discover
Turned on file and printer sharing
Turned on sharing so anyone with network access can read and write files in the Public folders
Selected Use 128-bit encryption
Turned on password protected sharing
- Verified that all printer functions still worked

MacBook Pro Preparation

- Computer Name: MyMacPro
- User Name: MyMacUser
- Updated OS
- Downloaded and installed MAC drivers for MF4370dn from Canon site since driver for this printer did not appear on pre-installed printer driver list. After installation the MF printer drivers now appear on the driver list.
- Clicked System/Sharing and checked off Printer Sharing in left hand panel
- No Printers or Users appear in the Printers and User Panels
- Clicked “Open Print Preferences” – nothing appears on this page
- Clicked + sign to add printer
- Clicked IP Tab, Protocol shows as Line Prnter Daemon-LPD (only other choice was HP Jetdirect-Socket)
- Added Advaced icon to menu and clicked
- Under Type, selected “LPD/LPR Host or Printer”
- Under URL typed “lpd://192.168.1/CanonMF4370dn”
- Under Print Using, Clicked Printer Software and chose “Canon MF4360-4390 UFRII LT (US)” – Note that this was one of the drivers that were downloaded from the Canon site.
- Clicked Add
- Clicked continue when “Installable Options” window appeared
- Now in the left panel of the “Print & Fax” window, the following appears:
192.168.1.3
Idle, Last Used

- Closed “Print & Fax” Window
- Loaded Word Processor and created a Print Test Document
- When I hit “Print: a window appears asking for # of copies, etc. Printer is listed as 192.168.1.3
- When I hit print, the following message appears with a title of “Canon UFR II Printer Driver” and a message that says “Cannot communicate with the printer, or the printer is not supported”
- A printer queue window also appears showing that the Printer was Paused.
That’s it. I’ve been playing around for days now and am lost as to what to try next. Can one of you Mac guru’s help this Windows guru?

Tomel 04-20-2011 08:55 AM

No suggestions?
 
So far, 46 views with no replies. Is this because others are also looking for answers or because I've actually done everything I should have done?

If any of you Mac experts out there think I've covered the bases and have nothing further to recommend, please let me know? In which case, I'll stop trying to get the printer to work and just forward documents to my Windows desktop for printing. Certainly less convenient, but doable.

Thanks.

bthomlinson 01-03-2012 10:06 AM

Did you ever solve this problem?
 
It's almost 9 months after your original post and I am very sorry to see that you have not had any responses to your problem. I bought my fist Mac (MacBook Air) for Christmas and am having almost the same problem.

I can help with one issue in your described configuration but then run into the next wall.

You are trying to use LPD printer connections when I believe that is intended for printers that are directly connected to the network and have their own IP address. I have two Canon printers connected to Windows 7 machines and got one printer (the iP4700 photo printer) working the first try. My Canon MF4350D printer did not work out as well and seems to be related to known problems with the Canon UFR II printer drivers.

The step you missed was that you need to select "Windows" as the location of your printer and not LPD/LPR. I am running Mac OSX 10.7.2 and the descriptions of the items I see in System Preferences / Print & Scan / ... may be different.

I clicked "+" to add a new printer,
Selected "Windows" as the source,
Selected the name of my computer from the list,
Selected the name of the shared printer,
and opened the "Print Using" drop down to select the printer driver.

I did the same steps for botht eh Canon iP4700 and the MF4350D and the iP4700 worked perfectly. On the MF4350D I get an "Error - 50" when I try to print. No descriptions and no clues as to what is wrong.

An internet search shows that this problem seems to be happening a lot with the Canon UFR II printer drivers, even if the printer is attached to the Mac. The iP4700 printer has it's own separate driver and doesn't have this problem.

I am still looking for a solution.


All times are GMT -4. The time now is 12:46 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.