Results 1 to 3 of 3
  1. #1

    Member Since
    Jan 03, 2011
    Macbook airport does not communicate with router anymore
    Hello everyone

    After last doing a software update (about 10 Jan), my airport on my aluminium macbook stopped communicating with my wireless router. It used to be on DHCP but it doesnt seem to be able to retrieve a working IP anymore. Instead, it receives a an IP starting with 169 which doesnt work, and no router IP appears in the box. I can, however, see the wireless network. When I try to connect to it, I am only able to get a self-assigned IP.

    I have an identical Macbook in the same house which works just fine. After my other one stopped connecting I avoided installing the OS updates which I suspect caused the problem.

    I tried:

    1. turning the airport on and off;

    2. removing it from the list with types of connections and re-adding it (which was supposed to reset the drivers)

    3. removing the network from the network list and re-adding it.

    4. going into the router (from the other MBas I cannot get into it via the laptop that s not connecting anymore) and changing the name of the network.

    5. going into the router (again, from the other MB) and chaning the type of security from WPA2 to WEP and to no security.

    5. connecting via ethernet.

    NONE of the above worked/ changed anything. I still get a self-assigned IP.

    Any ideas would be MUCH appreciated...

  2. #2

    Member Since
    Jan 10, 2011
    I have the same problem
    Hmm, sounds as if it could be the same problem I have. I've noticed a lot of people with similar issues but reworded, so I think the solution may be to contact Apple as well.

  3. #3

    Member Since
    Jan 03, 2011
    problem solved
    Hey everyone

    I managed to solve my wireless connection issues and thought I'd share.

    I went into network preferences and removed all etherned connections as well as the airport one from the network list by clicking "-" (this resetting the drivers - from what I understand).

    I then restarted the mac and then plugged the ethernet cable in. I re-added the etherned connection to the list (by clicking "+"). It immediately retrieved the correct IP and started working. I then re-added the airport connection then switched to wireless. and voila...

    I hope this work for some of you, just make sure you try ethernet first and then switch to wirelss.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MacBook not connecting to wifi router - no airport card?.
    By MoiMac in forum OS X - Operating System
    Replies: 2
    Last Post: 12-27-2012, 10:28 AM
  2. Have new MacBook and older PC - what router to handle Airport Express?
    By fluxnet in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 07-27-2009, 06:41 PM
  3. Need some help--Macbook, D-Link Router, DLS--can't connect via airport
    By addismac in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 09-20-2008, 01:57 PM
  4. Is there ANY ROUTER that doesnt cuase macbook Airport problems...
    By pollofrito81 in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 08-14-2008, 10:56 PM
  5. macbook pro + router + airport express: recommendations?
    By PoutineEh in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 07-05-2006, 07:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts