Results 1 to 2 of 2
  1. #1

    Member Since
    Aug 26, 2010
    Airport shows full connection, but can't connect to internet
    I just moved to a new shared house and for the first three weeks the internet worked without a problem. Suddenly on Wednesday afternoon when I started up my mac I couldn't connect to the internet using any application, except for Skype. Skype works fine for some reason. My airport shows that I have a full wireless connection, but firefox, mail, spotify, none of those can connect to the internet. All of my housemates' laptops (2 others have macs) can connect just fine. Only my computer seems to be affected.

    I have a Power Book G4 and run OSX. I've tried resetting the router, tried switching airport on and off and reconnecting to the network multiple times. Network preferences says that I have a full connection. But I have no idea what to look for or how to diagnose the problem beyond that. Some advice would be much appreciated. Thanks in advance

  2. #2

    Member Since
    Sep 02, 2010
    Same exact problem
    I have the same exact problem. I thought it might be the home link, but it does not work in the office as well. I can connect using internet explorer via Microsoft in vmware fusion. I tried uninstalling Safari and reloaded it, but that did not work. I am still searching for a solution. Luckily I can use my iPad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airport connected (full bars) but no internet connection. Driving me crazy!
    By siavash in forum Internet, Networking, and Wireless
    Replies: 29
    Last Post: 03-20-2013, 07:28 AM
  2. Help Please! Airport showing full signal but no internet connection.
    By Louise McSharry in forum Internet, Networking, and Wireless
    Replies: 17
    Last Post: 03-03-2012, 02:57 PM
  3. AirPort shows all bars, but can't connect the internet!
    By michaelpenson in forum Internet, Networking, and Wireless
    Replies: 4
    Last Post: 06-19-2011, 11:20 PM
  4. Wireless Shows Full Connection But Internet Is Slow, How Come???
    By GrandDesign in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 07-01-2010, 01:11 PM
  5. Network Problem; Internet Connect says full signal but no connection
    By shotdsherrif in forum Internet, Networking, and Wireless
    Replies: 5
    Last Post: 10-24-2008, 11:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts