Results 1 to 12 of 12
  1. #1

    Powermac's Avatar
    Member Since
    May 19, 2009
    Posts
    40
    Specs:
    powermac g4 80gb HD 768mb ram superdrive os x 10.4.11 iPod touch 2nd Gen
    Exclamation Powermac g4 airport not working
    Hi, I just bought an airport card for my powermac g4 and it is not working, I put it in and it says that it is working but it's not finding any connection points. I have many other devices that work perfectly fine in the same room on the same connectino point. I was just wondering what I did wrong or if it my router or something else, Thanks

  2. #2

    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    22,229
    Specs:
    Imac 27" Retina 5K, 512GB flash memory, 3.3GHz, 16GB memory, macOS Sierra beta.
    What does Apple System Profiler have to say and did you install the software from the CD?

  3. #3

    Powermac's Avatar
    Member Since
    May 19, 2009
    Posts
    40
    Specs:
    powermac g4 80gb HD 768mb ram superdrive os x 10.4.11 iPod touch 2nd Gen
    That might be it becasue it didn't come with any software.
    Do you know where I can get the software?
    Also do I need and airport base station to have it work becasue i just have a belkin wireless router.

  4. #4

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,298
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    Did u connect aerial lead - As Harry says does it show in Sys Profiler? Download and install this, then run Software Update to make sure you have all the latest. Then see if you see any Networks.

  5. #5

    Powermac's Avatar
    Member Since
    May 19, 2009
    Posts
    40
    Specs:
    powermac g4 80gb HD 768mb ram superdrive os x 10.4.11 iPod touch 2nd Gen
    It does show up in the system profiler and I all ready have 10.4.11 so is there something different in that update? Thanks

  6. #6

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,298
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    Combo update can sort kinks left behind by incremental updates so can be a good troubleshooting step. After that running Software Update brings up any additions since Combo was put out and sometimes it can take 2 or 3 runs of Software Update to get all the changes. Recent session of 10.3 i did, one of the last to show up was an update for the Airport.

  7. #7

    Powermac's Avatar
    Member Since
    May 19, 2009
    Posts
    40
    Specs:
    powermac g4 80gb HD 768mb ram superdrive os x 10.4.11 iPod touch 2nd Gen
    Thanks I'll try that and give an update as soon as it's done.

  8. #8

    Powermac's Avatar
    Member Since
    May 19, 2009
    Posts
    40
    Specs:
    powermac g4 80gb HD 768mb ram superdrive os x 10.4.11 iPod touch 2nd Gen
    Ok so I tried it but it still doesn't seem to be working but after I downloaded it their weren't any other update, I don't know if that means something or not.
    Do you need to have some sort of special software on the router or something like that. Thanks

  9. #9

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,298
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    When u put the airport card in did u connect the aerial lead?

  10. #10

    Powermac's Avatar
    Member Since
    May 19, 2009
    Posts
    40
    Specs:
    powermac g4 80gb HD 768mb ram superdrive os x 10.4.11 iPod touch 2nd Gen
    what does it look like?

  11. #11

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,298
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    This is where the lead plugs in;


    Click for full size

  12. #12

    Powermac's Avatar
    Member Since
    May 19, 2009
    Posts
    40
    Specs:
    powermac g4 80gb HD 768mb ram superdrive os x 10.4.11 iPod touch 2nd Gen
    Thanks a bunch, I didn't know there was another cable to plug in, because the cable was tucked underneath the motherboard by the previous owner, It works perfectly now, The picture really helped. Thanks again to all

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airport express wireless extending airport Extreme not working out.. help?
    By Hann in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 09-21-2013, 12:25 PM
  2. Airport Extreme -> Airport Express via Cat6 not working?
    By ltdrebin in forum Internet, Networking, and Wireless
    Replies: 14
    Last Post: 08-24-2011, 03:43 AM
  3. keyboard not working on powermac G5
    By nickda in forum Apple Desktops
    Replies: 3
    Last Post: 07-06-2010, 08:40 AM
  4. Airport Wireless Internet Not Working on iBook G4 - Airport
    By Kimiko in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 10-05-2008, 08:50 PM
  5. OSX.4 on Powermac G4 not working ..
    By onehawksfan in forum OS X - Operating System
    Replies: 2
    Last Post: 04-27-2007, 06:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •