Results 1 to 3 of 3
  1. #1

    Member Since
    Feb 12, 2010
    Help can acces only certain websites

    Two days ago I tried to do a search on Google and the "Firefox can't establish a connection to the server at" page came up. I thought google was down but it still doesn't work. I did some random prodding and found that there are a lot of sites I can't visit but many that I still can. Here is a random list.

    Browser (firefox, safari, and chrome) won't connect to these sites. (though the yahoo search bar works in my browser)

    Sites I visit often and still can visit.

    Here are some things I have done to try and fix it.

    I did a virus scan with ClamXav and found 3 infected emails. Deleted them.

    I deleted all browser history and cache as well as the dns cache.

    I can "ping" all of the sites from terminal.

    I haven't changed any network settings.

    I have tried on different wifi networks as well as tested the sites on my phone with the same wifi network. My phone can access those sites but my puter won't on any network.

    Also, my mac mail is unable to pull in my POP gmail accounts but it pulls in the email from my website server.

    I have heard of some redirecting viruses out there but these sites simply don't connect.

    I can use the website, "" to access all of the above inaccessible sites.

    I can't think of anything else, but if anyone has any pointers out there, it would be greatly appreciated.

    Santa Rosa 15" MBP model, if it matters.


  2. #2

    VegasGeorge's Avatar
    Member Since
    Sep 23, 2006
    Las Vegas, NV USA
    iMac, and Macbook Pro
    Well, as long as you can still visit, you should be good to go!

    Seriously, you may have those websites unintentionally redirected in your hosts file. The hosts file is in the /etc folder. To access this file in Finder select Go > Go To Folder, and type in /etc. Double click the Hosts file to open it. See if your inaccessible websites are listed there. If they are, edit them out. Do not change anything else in the Hosts file. Let us know if that solves your problem.

  3. #3

    Member Since
    Feb 12, 2010
    I looked for the host file inside of the /etc file and it appears to be missing. Here is a screen shot so you can see.

    Twitpic - Share photos on Twitter


    I typed in /etc/hosts to see if it would open the file and a pop up said "The folder “hosts” can’t be opened because you don’t have permission to see its contents."

    Did I deny myself admin permission somehow?

    Edit #2:

    I'm an idiot. I had peer guardian running and didn't realize it. Thanks for the help though.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how to acces files is dvd ??
    By matt.leese in forum OS X - Operating System
    Replies: 12
    Last Post: 07-30-2012, 12:17 PM
  2. Can't acces e-mail or login to sites..
    By SubtleBreeze in forum OS X - Apps and Games
    Replies: 1
    Last Post: 03-23-2009, 03:43 PM
  3. Acces Files Through Internet
    By jesusfreak101 in forum OS X - Operating System
    Replies: 2
    Last Post: 11-20-2007, 04:59 PM
  4. Can't get to certain websites?
    By Gromit in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 04-30-2007, 11:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts