Results 1 to 5 of 5
  1. #1

    Member Since
    Dec 30, 2009
    MBP/AirPort compatibility with invisible SSID/network?
    Anyone else have this issue/experience - I have the network visibility of my wireless router SSID set to invisible. I have a couple of PCs, PS3 connecting to it without issue. However, when I tried to setup the connection on a newly acquired MBP, it doesn't connect.

    Here are the steps I used in an attempt to add the "invisible SSID/network":
    1) Join Other Networks from AirPort drop down menu
    2) enter my network info (network name, security (WPA), passwd. - Join
    3) Connecting network.... Connection Timeout.

    If I turn-on the visibility, the MBP will readily connect to the router. The MBP is running 10.6.2.


  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    You answered your own question. Turn on SSID. It doesn't matter whether you broadcast the SSID or not, as long as you're using strong encryption your network is safe. Use the strongest possible encryption you have available to your Mac and PCs. (Probably WPA2)

    Keeping the SSID invisible and/or using MAC filtering only leads to problems and it's not necessary in order to maintain a safe network.


  3. #3

    Member Since
    Jan 20, 2010
    Similar problem!
    I have D-Link Wireless 108G Gaming Router model D-Link DGL-4300

    create a wireless network with the parameters:

    Wireless Network Name: xxx_fffggkkklll

    Enable Auto Channel Scan: yes

    Super G™ Mode: disabled

    802.11 Mode: Mixed 802.11g and 802.11b

    Transmission Rate: Best(automatic)

    Visibility Status : Visible

    MBP, iMac 24 and iPhone - successfully connected to a WiFi network

    if I switching

    Visibility Status : Invisible reboot my D-Link DGL-4300

    MBP, iMac 24 - Connecting network.... Connection Timeout.
    Not connected!!!

    My old aluminum iPhone - successfully connected to a WiFi network

    My network use MAC filtering

    In both cases, when the network is invisible and visible.

    Why IPone works with a hidden network of my router and MBP and iMac does not?

    How to get to work with a hidden network of MBP and my iMac 24? What is the Secret of the behavior of more modern devices? I do not want to make your network visible only in order to connect the iMac and MacBook Pro. All other devices PC Computers work with the hidden network with no problems.


    WPA Mode :WPA or WPA2
    Group Key Update Interval : 3600 second

  4. #4

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Lake Mary, Florida
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Disabling SSID broadcast yields absolutely no benefit whatsoever. Anyone using a WiFi sniffer is still going to see it.

    What is DOES do, is make it a whole lot harder to establish and maintain a WiFi connection.

    Why do you have issues with your Mac and not your Windows machines? My guess is the way the drivers are written. I have tested exhaustively in different configurations and ultimately I've determined that it's just a deficiency in the drivers.

    But again, there's little point to disabling it in the first place. If you were using an easily crackable encryption mechanism like WEP, then it might be advisable to keep your network obscured from the relatively ignorant. But with modern WPA or WPA2/AES encryption, you've got nothing to worry about.
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

  5. #5

    Member Since
    Oct 22, 2010
    Exclamation Possible Solution.
    Okay, I know that this is an old post, but because I have encountered this problem in the past (and because there aren't too many posts about this), I'm going to post what I did to remedy this.

    1) From another Mac or PC, go into the router and set the network to be visible (Broadcast SSID).
    2) Set the WiFi Security to None or Disabled (AKA Open Network).
    3) Attempt to connect to the network from the AirPort pull-down menu.
    4) Once connected, return your router's WiFi settings to the desired specs
    5) Restart your Mac.
    6) The Airport should automatically discover your masked WiFi, but will now "know it" and prompt you for a password.
    7) Cross your fingers - everything should connect!

    Hope this helps; it did for me! :^)

    As for the controversy over hidden SSIDs. Although there are ways to trick a computer connected to a router into broadcasting the SSID, I still find it marginally more secure (though much more of a pain) to hide the SSID. It's just yet another step in a properly layered security scheme.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airport can't find wireless connection after I disable ssid broadcast
    By qwik3r in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 05-21-2008, 02:02 PM
  2. How do I set the SSID for internet connection sharing over airport?
    By sir_christopher in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 04-03-2008, 07:14 PM
  3. automatically connect to invisible SSID
    By roderick in forum Internet, Networking, and Wireless
    Replies: 8
    Last Post: 03-29-2008, 12:22 AM
  4. WPA2 - Mac Filtering - SSID - Airport - Help me please
    By TheChemist in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 10-01-2006, 11:30 PM
  5. Can I make my iBook G3 see a network without an SSID?
    By DigitalN. in forum OS X - Operating System
    Replies: 3
    Last Post: 11-15-2005, 03:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts