Results 1 to 4 of 4
  1. #1

    Member Since
    Dec 26, 2009
    Question Internet connection slow, and doesn't load pics
    My Macbook Pro is slow when connecting to the internet. It takes 15-30 seconds or more to load pages at times, depending on the graphics. It struggles loading pictures or finally doesn't load them at all.

    I have a Macbook Pro OSX 10.5.8, 2.4 GHz Intel Coure 2 Dou using a Belkin-N router, F5D8236-4 v3000. It has the problem whether it is wireless or hardwired to the router. When connected directly to my cable modem, the thing screams, no problem at all. Pictures load instantly.

    I have two PC's also connected to the router. One desktop hardwired, and one wireless. If either PC is turned on, the problem on my Mac is worse.

    I tried turning off the security, still an issue. I am using WPA/WPA2 Personal for security. Wireless mode is b/g/n, bandwidth is 20mhz/40 mhz auto.

    I updated the Macbook software and firmware and updated the firmaware on the router.

    Any other ideas?

  2. #2

    VegasGeorge's Avatar
    Member Since
    Sep 23, 2006
    Las Vegas, NV USA
    iMac, and Macbook Pro
    Do you need b/g/n? Can you change it to just n or just g? If so, see if that helps.

  3. #3

    Member Since
    Dec 26, 2009
    Thanks for the suggestion but no improvement what so ever. I went to friends house who has a Linksys router with a PC and Mac. My MacBook Pro worked fine. My Belkin just seems to hate my MacBook.

  4. #4

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Napier NZ
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Full internet connection, browsers wont load
    By dillonupgrade in forum Apple Notebooks
    Replies: 1
    Last Post: 04-29-2014, 08:24 PM
  2. Internet has full connection but pages do not load
    By lmg2727 in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 10-20-2011, 06:12 PM
  3. Internet Connection Slow
    By filsim in forum Apple Notebooks
    Replies: 1
    Last Post: 01-04-2011, 05:52 PM
  4. MacBook running slow and safari doesn't load
    By Macmaxxx in forum OS X - Operating System
    Replies: 3
    Last Post: 12-31-2010, 10:20 AM
  5. Internet load speeds in Safari very SLOW
    By jshicks in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 03-16-2008, 04:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts