First post and am desperate for some advice...

We have a Macbook (2008) running OSX Leopard and perform backups manually to a MyBook external HD.

I usually copy the files contained within our 'network' - i.e. Documents, Downloads, Pictures, etc. though this time, I accidentally tried to copy the entire 'Macintosh HD'.

While the computer was still running (and seemed fine), the external HD was hung up and though I disconnected it safely, the Macbook still showed the message window ('...preparing to backup...'). I tried to shut down and restart and reboot the external HD several times but it just blinked at me. And no, I was patient and let it run to see if it could perk up on its own. Nothing.

Later that night, we discovered our internet connection had gone wonky and so had our Airport Extreme. After fiddling with the configurations for two days and coming up empty, I bought a new external HD and backed the whole thing up last night.

We are still unable to get online, though after several Airport Extreme resets the AE seems to be functioning normally. The Macbook seems to be fine too. Our internet connection appears to be functioning as well. None of these things seem to be working together anymore, though. And when I tried to plug the ethernet cable (the AE end) directly into the MB, there was still no internet connection.

I am usually quite decent at analyzing such situations but in this case, so many things went wrong at once, I can hardly describe what our problem is! If any of you have an idea or advice, I would greatly appreciate it. I'm trying to do everything I can before giving up my system to the Mac pros...