So, I have a cable modem that runs to a linksys wireless router and everything worked fine. Then, I tried to add a Airport Express to get music through my home entertainment system. However, when I added it on, everything went kaboom.

For starters, the thing doesn't want to "restart" after running the typical software. I installed the airport utility, tried to add the express to "join existing network" but when it finished, it wouldn't restart at the end of installation. So then, I reset the airport express and everything went back to normal (IE i could use my wireless network).

So I then tried doing the same thing BUT, did so with a manual install which showed that their was an update for the express... Great I thought, that's the probelm. So I plugged the linksys into the express via an ethernet cable and it ran the update. Great, now we'll just rerun the install and tell it to join the existing network and it will work..

So then I ran the update and, once again, it said that it couldn't restart (got to the end of the instllation process and it didn't reset/restart the thing). This is where it gets odd.

So I figured, OK i didn't do it right again (even though i followed the process) so i will just unplug it again and continue using the original network but now, whenever i try and connect to my network, it gives me the airport logo with the ! The wierdest part is my gf's macbook connects just fine to it but mine won't. I just don't get it. Any help or advise?