New To Mac-Forums?

Welcome to our community! Join the discussion today by registering your FREE account. If you have any problems with the registration process, please contact us!

Get your questions answered by community gurus Advice and insight from world-class Apple enthusiasts Exclusive access to members-only contests, giveaways and deals

Join today!

 
Start a Discussion
 

Mac-Forums Brief

Subscribe to Mac-Forums Brief to receive special offers from Mac-Forums partners and sponsors

Join the conversation RSS
Internet, Networking, and Wireless Discussion of networking, internet, and wireless including Apple's Airport products.

cannot connect to Linksys router


Post Reply New Thread Subscribe

 
Thread Tools
variation

 
Member Since: Jul 02, 2008
Posts: 5
variation is on a distinguished road

variation is offline
I recently purchased a used Macbook 13" 2.2ghz. I previously had an ibook that connected easily to my home network which includes a linksys wireless n router one iMac 1.9ghz iSight and one eMac 1.25ghz. (all connected wirelessly)

With the iBook all I had to do was choose my network which was named "linksys" put in the key and was surfing. Now with this new macbook it detects my network "linksys" I put in the netowrk key but when I try to log on to the net it says page cannot be displayed (both safari and firefox). I also tried taking all security settings off but still wont connect. (I checked the iMac and eMac when the security settings were off and they connected fine)Now here is the part that I cannot understand. It "see's" my other computers on the network and I can access them, transfer files to my macbook and so forth. When I check the airport status its green but says something about an ip address and that it cannot connect to the internet. I manually put in my router address used the ip address from iMac, took my iMac off the network but the macbook still will not connect to the internet.

What am I missing or what am I doing wrong here?
QUOTE Thanks
deathcloud

 
deathcloud's Avatar
 
Member Since: Aug 25, 2009
Location: Jacksonville FL
Posts: 232
deathcloud is on a distinguished road
Mac Specs: 13'' Macbook Pro 2.26 Ghz Intel Core 2 Duo 2 GB 1067 Mhz DDR3 500 GB 7200rpm HD

deathcloud is offline
It seems like you are not getting the IP from your router. Like the DHCP isn't giving your new mbp the ip. Maybe try restarting the router. Then restart your macbook and see if it gets an ip address. I suggest leaving the other computers off first and focus on getting your MBP internet first. Then worry about the others. Maybe there is an IP conflict or something.

I know that I started to have problems as I went from leopard to snow leopard. Every time that I shut my lid and then opened it back up, then it wouldn't connect to my wireless network. Linksys N router. I then had to manually connect to it by manually adding the network by putting in the SSID and then put in the WEP password and then I haven't had problems since. It was really weird. Hope you figure it out.
QUOTE Thanks
twdcmd

 
Member Since: Mar 28, 2009
Posts: 45
twdcmd is on a distinguished road

twdcmd is offline
A client of mine had a linksys N router (small black one with no antenna, can't remember the model) and I had to update the firmware to get his Macs to connect...might want to check and see if there's an update for yours.
QUOTE Thanks
deathcloud

 
deathcloud's Avatar
 
Member Since: Aug 25, 2009
Location: Jacksonville FL
Posts: 232
deathcloud is on a distinguished road
Mac Specs: 13'' Macbook Pro 2.26 Ghz Intel Core 2 Duo 2 GB 1067 Mhz DDR3 500 GB 7200rpm HD

deathcloud is offline
Quote:
Originally Posted by twdcmd View Post
A client of mine had a linksys N router (small black one with no antenna, can't remember the model) and I had to update the firmware to get his Macs to connect...might want to check and see if there's an update for yours.
wow good idea.... I didnt think of that. I have the same one you are talking about.

might try that as well.
QUOTE Thanks
deathcloud

 
deathcloud's Avatar
 
Member Since: Aug 25, 2009
Location: Jacksonville FL
Posts: 232
deathcloud is on a distinguished road
Mac Specs: 13'' Macbook Pro 2.26 Ghz Intel Core 2 Duo 2 GB 1067 Mhz DDR3 500 GB 7200rpm HD

deathcloud is offline
Ok so now I am having trouble updating my firmware.

I have the wrt160n router. I have version 3.0.00. I then download firmware update 3.0.02 and then it goes to my download folder.

I then go to administration and then click the file wrt160n3.0.02.bin and upgrade.

It gets to about 98 percent and then says FAIL. So i dunno i am just going to keep it the same but however the new one has some good fixes.... HELP ME someone. am I doing something wrong?
QUOTE Thanks
twdcmd

 
Member Since: Mar 28, 2009
Posts: 45
twdcmd is on a distinguished road

twdcmd is offline
Are you doing it via wireless or plugging in with an ethernet cable?
QUOTE Thanks
deathcloud

 
deathcloud's Avatar
 
Member Since: Aug 25, 2009
Location: Jacksonville FL
Posts: 232
deathcloud is on a distinguished road
Mac Specs: 13'' Macbook Pro 2.26 Ghz Intel Core 2 Duo 2 GB 1067 Mhz DDR3 500 GB 7200rpm HD

deathcloud is offline
I am doing it via an ethernet cable. Am I doing the right steps? just wondering... I thought maybe I have to unzip the .bin file? But I think all you need is the .bin file right?
QUOTE Thanks
twdcmd

 
Member Since: Mar 28, 2009
Posts: 45
twdcmd is on a distinguished road

twdcmd is offline
I think I had to try it on a couple different machines before I got it to work...maybe try rebooting the router and see if that helps?
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,911
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.10.1, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
What web browser are you using to log into the Linksys? I had an issue on a network service call a month back with a 160n using Safari 4. I had to use Firefox to upgrade and save settings. Something about the firmware was not getting along with Safari 4.

Also if that is not the issue try holding down the reset button in the back for 10 seconds or so till it resets and try it again. You will loose all your settings but you can put those back.

Let us know what happens.
QUOTE Thanks
deathcloud

 
deathcloud's Avatar
 
Member Since: Aug 25, 2009
Location: Jacksonville FL
Posts: 232
deathcloud is on a distinguished road
Mac Specs: 13'' Macbook Pro 2.26 Ghz Intel Core 2 Duo 2 GB 1067 Mhz DDR3 500 GB 7200rpm HD

deathcloud is offline
So you are saying that I should download firefox (ewww) and then try it via that? I am willing to try anything.

So just to confirm should I hold the reset button down 1st or after I do the firmware upgrade? Lemme know

thanks
QUOTE Thanks
dtravis7

 
dtravis7's Avatar
 
Member Since: Jan 04, 2005
Location: Modesto, Ca.
Posts: 27,911
dtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond reputedtravis7 has a reputation beyond repute
Mac Specs: iMac 2.4 C2D 10.10.1, iMac 2.16 C2d 10.6.8, Macbook2007 10.8.4, Mac Mini 10.8.4, iPhone 3GS Note 8!!

dtravis7 is offline
Quote:
Originally Posted by deathcloud View Post
So you are saying that I should download firefox (ewww) and then try it via that? I am willing to try anything.

So just to confirm should I hold the reset button down 1st or after I do the firmware upgrade? Lemme know

thanks
The only reason I am first recommending trying Firefox is the issue I had with that clients Linksys like yours. I just could not get things to update till I tried Firefox.

The Reset idea is after you try Firefox and still it will not update the firmware, then try the reset. Can't hurt since it's not working now!
QUOTE Thanks
deathcloud

 
deathcloud's Avatar
 
Member Since: Aug 25, 2009
Location: Jacksonville FL
Posts: 232
deathcloud is on a distinguished road
Mac Specs: 13'' Macbook Pro 2.26 Ghz Intel Core 2 Duo 2 GB 1067 Mhz DDR3 500 GB 7200rpm HD

deathcloud is offline
Ok good deal. I am off to bed. I am too tired to deal with this anymore. Plus the game is on. I will let you know how it goes though tommoro. I hope it works.
QUOTE Thanks
twdcmd

 
Member Since: Mar 28, 2009
Posts: 45
twdcmd is on a distinguished road

twdcmd is offline
Thanks for mentioning that dtravis7, I think I had the same browser issue now that I think about it (been a few months back now).
QUOTE Thanks
deathcloud

 
deathcloud's Avatar
 
Member Since: Aug 25, 2009
Location: Jacksonville FL
Posts: 232
deathcloud is on a distinguished road
Mac Specs: 13'' Macbook Pro 2.26 Ghz Intel Core 2 Duo 2 GB 1067 Mhz DDR3 500 GB 7200rpm HD

deathcloud is offline
Well you were right. I switched to firefox on my imac and then it upgraded it. Flawless. And another thing, everytime I am on safari I can't click changes. It just drops the connection. Linksys should probably fix this or us mac users can't use it without going to firefox. Lame. So use firefox and it will work.
QUOTE Thanks

Post Reply New Thread Subscribe


« Internet Connection Acting Weird | cant access aol from router? »
Thread Tools

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off
Forum Jump

Similar Threads
Thread
Thread Starter
Forum
Replies
Last Post
Ethernet sees router but can not connect to Internet jooserparfs Internet, Networking, and Wireless 9 11-15-2010 10:58 PM
Question about Connecting Mac to Linksys Router Carmine782 Switcher Hangout 4 07-29-2009 09:00 AM
Connecting iMac G3 with linksys router wirelessly youngwun0 Internet, Networking, and Wireless 0 12-26-2006 10:44 PM
connecting through linksys router huffstar Internet, Networking, and Wireless 3 05-11-2006 02:06 AM
Buying Linksys WRT54G wireless router....opinions? Joeytpg Switcher Hangout 2 09-05-2004 07:47 PM

All times are GMT -4. The time now is 04:58 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
X

Welcome to Mac-Forums.com

Create your username to jump into the discussion!

New members like you have made this community the ultimate source for your Mac since 2003!


(4 digit year)

Already a member?