Results 1 to 3 of 3
  1. #1

    Member Since
    Aug 28, 2009
    10.5.8 en0 losing IP address and only a reboot fixes it
    I have a Macbook Pro with 2GB RAM and 10.5.8.

    At random intervals, the en0 interface will get a nonsense IP address and all network connectivity dies. Random = from 1 to 3 days. The nonsense IP address always seems to be netmask (0xffff0000).

    It always seems to happen after the screen saver comes on. I don't think the screen saver is killing my NIC card - I'm just saying. Basically, I am away from the Macbook for 1 to 2 hours - and when I come back - maybe the NIC is screwed up - most of the time, its okay.

    I have the power saver options off - because it is always plugged into the wall. The screen saver is set to come on after 10min, and the screen backlight will shut off after 30 min. I've never seen it go to sleep or go into standby - it always comes back instantly when I move the mouse around.

    I've tried to "ifconfig en0 down", count to 10, then "ifconfig en0 up" and the same nonsense IP address comes back. I also unplug/plug the network cable - same nonsense IP address comes back.

    If I use the Network System Preference tool, I set it to manual and plug in an IP address that is unused, and correct for my network - it still doesn't work. The ifconfig shows en0 has the networking information I programed into it, but if I ping a local machine, I get ONE "ping: sendto: No route to host" followed by a million "ping: sendto: Host is down" - which is wrong.

    I normally leave the AirPort off while I am in my office. But, if I turn on AirPort while en0 is FUBAR, it gets a good address and everything is fine on the AirPort network. The en0 is still FUBAR, but the pings and everything else works ok as long as AirPort is on. As soon as I turn it off, I am in the dark again.

    Two of the most important applications I use on the Macbook are VMWare Fusion (2.0.5 (173382)) and terminal. I haven't isolated it to either of these because if I can't use those, there is no point having this Mac fired up. But it wouldn't surprise me that Fusion is FUBAR. I can't get into the Fusion forum at VMWare - talk about a POS web site - so I can't really ask if anyone else is having problems.

    The only thing that "fixes" en0 is to reboot the Mac. MAJOR PAIN! I have 5 to 10 terminal sessions running, Transmission is DL'ing a .torrent, my VM is doing email & VPN - freaking disaster!

    I use the Macbook on my home network. I have a DHCP server (a real DHCP server, not my router/firewall) handing out IP address. The leases are set to 1hr (because I like it that way). The DHCP server is solid as a rock and this Macbook is the only system having a problem. All other systems (3 WinXP (1 wired, 2 wireless), 2 Linux, Sligbox, 2 DirecTV DVRs, IP connected printer and the home theater amp) have 100% connectivity internally and to the Internet while the Macbook is deaf & dumb.

    PLEASE do NOT say "Well, you should be using Parralles" or something like that. I use VMWare in my job, and I virtualized my work PC to run under Fusion. BTW: When the Mac loses its net connection, the VM loses its too. It is set to "bridged" and gets its IP from the DHCP server.

    I recently (last week?) updated the Mac OS to 10.5.8 and the Fusion to 2.0.5 - and this problem started around the same time - so it is either 10.5.8 or the new version of Fusion that is causing this problem. BTW - Snow Leopard is NOT an option - VMWare says (on their crappy web site) that Fusion is flat out not certified on Snow Leopard yet. It might work - but it might not.

    There is no conflict with the vmnet interfaces - vmnet1 & vmnet8 are both set to 192.168.something.1 and they are not matches to any internal net I have.

    If you need more info, let me know.
    If you have something constructive to say, please let me know.

  2. #2

    Member Since
    Aug 28, 2009

  3. #3

    Member Since
    Aug 28, 2009

    + Update.
    Everything has been great for the last 6 weeks or so. No problems.
    I've been using Fusion 2.0.5, and today, I upgraded to VMWare Fusion 2.0.6.

    Three hours later, the IP address on en0 went crazy. En0 went from the IP that was assign by my DHCP server to And, the system was NOT on screen saver or asleep - it happened right in the middle of a vi session I was having with one of my Linux systems.
    I lost all ssh and terminal sessions, Safari lost connection, and my VM lost its network VPN.

    But... Instead of rebooting, I turned on the Airport and it reestablished the network connection. On the VM, I did an ipconfig /release and /renew and got my VPN back up.

    Now, the $1,000,000 question: Why in the world do I keep losing en0 IP address and WHY can't I get it back without a reboot?!?

    Also: Why would en0 be screwed up but en1 is okay (for now)?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New mac user working with wired ethernet (en0)
    By gardrail in forum OS X - Operating System
    Replies: 3
    Last Post: 01-21-2011, 08:35 AM
  2. Losing internet connection on reboot/restart
    By unclephatu in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 12-05-2007, 08:38 PM
  3. Address book losing data upon unplug
    By huffstar in forum OS X - Operating System
    Replies: 0
    Last Post: 08-21-2005, 01:22 PM
  4. Address book losing data upon unplug
    By huffstar in forum OS X - Apps and Games
    Replies: 0
    Last Post: 08-21-2005, 01:22 PM
  5. constantly losing ip address
    By MrBill25 in forum OS X - Operating System
    Replies: 3
    Last Post: 04-03-2005, 04:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts