Results 1 to 6 of 6
  1. #1


    Member Since
    Jul 11, 2009
    Posts
    3
    Exclamation mac won't connect to the internet
    Seriously need help. my mac book is an old one, 2006 or 2007, and I have problems with the internet. I used to have a great connection, but then I went on vacation and came back 2 days later and was running at like 2 or 3 kilobytes per second as opposed to the 100 to 150 it usually runs. Then, two days later, the internet stopped working entirely. It was broken in both safari and firefox. at first i thought it was a virus, but it worked fine on all other programs. I then thought it was because it I had too much stuff in my hard drive, so I deleted all the junk and ended up with nothing but firefox, itunes and finder. The internet then worked for 1 night and then shut off again. It says that it has full signal strength on the airport menu, but every time I try to load a page, the bars and items are still there, but the page is blank and endlessly says it is loading, but never does. I can't take it in to the mac shop because the screen is broken and I have to have it hooked up to a tv via hdmi, so I can't take it anywhere. Also, system preferences does not work. any help, suggestions, anything? I am on my brothers computer and it works fine. So please help!

  2. #2

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,911
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Just a guess, but have you recently downloaded any pirated software? Installed any media player "plug-ins" when visiting, let's say, less than reputable web sites?
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  3. #3

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,298
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    Have you had in from new or are you 'another owner' - if it is used did u instal a new OS. Might be worth doing a back up and a clean instal then re evaluate.

  4. #4


    Member Since
    Jul 11, 2009
    Posts
    3
    I bought it new, and I don't have any viruses because all other programs work fine. the only things that I downloaded close enough before hand were planeshift ( free mmorpg for macs) and I tried to install a crossovergames trial. but bot of those files are deleted. Is there a setting I can change because I doubt the problem is with my OS. also, I think I lost the original software.

  5. #5

    cwa107's Avatar
    Member Since
    Dec 20, 2006
    Location
    Lake Mary, Florida
    Posts
    26,911
    Specs:
    15" MBP, Core i7/2GHz, 8GB RAM, 480GB Crucial M500 SSD
    Quote Originally Posted by adamator View Post
    I bought it new, and I don't have any viruses because all other programs work fine. the only things that I downloaded close enough before hand were planeshift ( free mmorpg for macs) and I tried to install a crossovergames trial. but bot of those files are deleted. Is there a setting I can change because I doubt the problem is with my OS. also, I think I lost the original software.
    Well, if you want to eliminate a settings issue, the easiest thing to do would be to create a test account (System Preferences => Accounts). Then, log in with that account and see if the problem persists. If it does, then you know it's either hardware or OS.
    Liquid and computers don't mix. It might seem simple, but we see an incredible amount of people post here about spills. Keep drinks and other liquids away from your expensive electronics!

    https://youtu.be/KHZ8ek-6ccc

  6. #6


    Member Since
    Jul 11, 2009
    Posts
    3
    now even system preferences won't work, it worked after I deleted most of my stuff, is it in a folder, because I can't find system preferences. also, can it even be deleted?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My HTC Wildfire will connect to internet sharing but won't connect to the internet.
    By Nicholas1501 in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 09-05-2012, 08:05 PM
  2. My Mac won't connect to the Internet, but my other devices can.
    By keanu in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 03-02-2012, 09:36 AM
  3. Replies: 2
    Last Post: 02-25-2010, 12:52 PM
  4. imac won't connect to internet
    By applenoob in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 12-30-2008, 01:48 PM
  5. mac os 9 won't connect to internet
    By lilmul123 in forum Running Windows (or anything else) on your Mac
    Replies: 0
    Last Post: 07-17-2008, 09:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •