Here is the full story as briefly as I can explain:

1. Upgraded home wifi at the weekend to a new Netgear (having had issues of connection timeout to an old Linksys for a while). The Netgear I bought was:

Wireless-N Router with Built-in DSL Modem

2. Had some issues (even with the Netgear with wireless security / stability) and eventually found:

WPN824 - Mac Book Pro connection problem - NETGEAR Forums

Based on this I set TCP/IP to 'DHCP static' / statically assigned an address out of the DHCP range of the Netgear and was able to get Airport up and stable with Netgear. Used it all day yesterday with no issue. It stayed up all night and I was able to VPN into corporate network this morning.

3. Left for a trip this morning around 10 local time. I disconnected VPN / slept Mac. While Mac was asleep I did a battery swap to charge my second battery as I am flying to California on Weds and on plane for 10 hours and wanted to ensure both batteries were good.

4. Resumed Mac on train where there is public wifi. I saw association with public wifi BUT I still had the home static address. I tried setting DHCP to dynamic but could not release the static address. Turned off the Airport and then found I could not turn it back on again.

5. Set startup disc to SuperDuper backup disc / restarted from that and was able to get airport working in that image (where I am now)

6. Did Full Permissions Repair on main HDD. Set startup to main HDD. Restarted from main HDD still no airport. Collected some log output when trying to get Airport working in main HDD:

22/06/2009 11:43:45 [0x0-0x1f01f][220] 2009-06-22 11:43:45.200 readconfig[348:10b] isInterfaceBuiltin IOServiceGetMatchingService
22/06/2009 11:43:45 [0x0-0x1f01f][220] 2009-06-22 11:43:45.205 readconfig[348:10b] isNetBootable IOServiceGetMatchingService
22/06/2009 11:43:45 [0x0-0x1f01f][220] 2009-06-22 11:43:45.209 readconfig[348:10b] isInterfaceBuiltin IOServiceGetMatchingService
22/06/2009 11:43:45 [0x0-0x1f01f][220] 2009-06-22 11:43:45.213 readconfig[348:10b] isNetBootable IOServiceGetMatchingService

22/06/2009 11:54:22[1] ([125]) Exited: Terminated
22/06/2009 11:54:23[167] launchctl: Please convert the following to launchd: /etc/mach_init_per_user.d/RemoteUI.plist
22/06/2009 11:54:23[165] ( Unknown key for boolean: EnableTransactions
22/06/2009 11:54:23[165] (org.x.startx) Unknown key for boolean: EnableTransactions

That is where I now stand......not good !

The other peculiarity (which may or may not be related) is that my VPN client wont authenticate me any longer on my corporate gateway.....I have an idea that is just a bizarre coincidence and unrelated - most likely I need to rekey (or I have been fired :-)) but worth mentioning as well

I am going to go into my local Apple store when I get home this afternoon and see if I can grab an adhoc Genius chat - there are no appointments before I leave for California on Weds. After that my next slot is Thursday afternoon in San Jose but I would seriously like to resolve this before I get on my plane on Weds if I can

Ideas ?