About 20 minutes ago was the worst instance of what usually happens, which is that I'll lose my bluetooth connection to usually my mouse, and at times both mouse and keyboard. The mouse is a Logitech (new) and the keyboard is the Apple bluetooth one. Usually, I'm able to go into preferences, then click reconnect and all is good, but not this time.

This time, the bluetooth icon in the menu bar only said "bluetooth not available", and neither mouse or keyboard were paired. And trying to reconnect by cycling the power on these items didn't do a thing either. I restarted the MBP, and then the situation became worse. Neither bluetooth device were recognized, and when I tried to use the connection wizzard, I got a message saying that there was no bluetooth device IN my MBP ?!

I tried several times to do different things w/preferences, but the MBP no longer recognized its own bluetooth hardware. Well, here I am after a hard boot, and it's working again, but this happened out of nowhere.

Keep in mind that all of my batteries are freshly charged, and that this is related to the bluetooth hardware inside the MBP, and not my peripherals.
My OS is up to date with the latest updates (10.5.7) and haven't had any other issues. I've also recently fixed all my permissions and such with Onyx.

The only thing that has changed recently is the RAM. I've installed 4 gigs of Corsair. Oh, and my MBP is the 2008 (summer) version.