Results 1 to 2 of 2
  1. #1

    Member Since
    Jun 10, 2009
    Problems with Airport Utility upgrade
    I have been using an Airport Express for some months to play iTunes on my stereo. The house has a Linksys router. Everything was working perfectly after an easy and trouble free setup until I downloaded the latest upgrade for Airport Utility 5.4.2. When I was installing a message popped up that said there was a problem with the Airport Express firmware and asked to repair it. I clicked ok and since that moment the Airport Express has ceased to function. It shows up in the iTunes but when you try to select it, it deselects and won't work. I have tried all resets recommended and that doesn't work. I tried to do the firmware update but the installer does not recognize the AX as an AX and won't install stating that there is a software problem. What is my next step? Thanks

  2. #2

    chscag's Avatar
    Member Since
    Jan 23, 2008
    Fort Worth, Texas
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, El Capitan
    Sounds like your AE firmware might have suffered brain damage. If that's the case, it may be dead. I'm not sure you can flash it with the old firmware or not. Anyway, the best I can suggest is to try the procedure given here in this Apple KB article: Link

    If that doesn't work for you, search using Google to see if anyone has come up with a solution to resetting the firmware or flashing back to the original.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. AirPort Utility not finding AirPort Extreme, etc
    By giblet_11 in forum Other Hardware and Peripherals
    Replies: 4
    Last Post: 11-30-2013, 02:19 PM
  2. installed Airport Utility 5.5.3, cannot access Airport
    By mhrovat in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 06-23-2011, 05:59 PM
  3. Airport Utility Can't Find Airport Express via Linksys Router
    By TWBuddha in forum Internet, Networking, and Wireless
    Replies: 12
    Last Post: 08-17-2009, 06:53 PM
  4. MacBook Pro can't find my airport after airport utility update
    By mllrtms in forum Internet, Networking, and Wireless
    Replies: 2
    Last Post: 07-04-2009, 05:46 AM
  5. Airport Utility needed new version after Leopard upgrade
    By markvanh in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 02-11-2009, 02:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts