Results 1 to 6 of 6
  1. #1

    Member Since
    Dec 28, 2008
    Airport won't reconnect automatically to wireless networks it has passwords saved for
    I have a MacBook Air and have had, it seems, most of the wireless network connectivity issues I've seen reported here and in other forums.
    My issue was that while my two Windows laptops happily remained connected to my wireless network, my Air would connect and then drop the connection - to such an extent that I could not complete an Apple software update because it wouldn't stay connected long enough to complete the download.
    I think I have solved this problem using AirGrab WiFi Radar utility to show me my neighbour's various WiFi networks and in particular the channels they are on, and by explicitly setting my router to use a distinct channel.
    But having done this and added and deleted WiFi connection settings repeatedly (including as advised in various posts from the Keychain and the preferred networks list - and even changing the name of my network to something I haven't used before) the Airport will no longer reconnect to my wireless network.
    If I reboot the Air it connects happily (I have "remember any network this computer has joined" ticked in advanced network settings). But if I take the Air out of range and then bring it back, or if I turn the router off and on again, or I simulate this by turning the airport off then on, it does not reconnect. If I click on the drop down symbol it shows the network name as detected but stubbornly does not reconnect automatically. If I click manually on the network name it immediately connects (with no prompting for passwords).

    I'm using a Netgear Wireless N WNR-2000 router (but in my desparation have tried 4 other routers as well including an Apple Time Capsule and ones made by Linksys and D-Link - and I have the same problem with them all).
    I'm using WPA/WPA2 security.

    Any suggestions? (I've read so many post in the past few days and tried a whole variety of settings, I can believe there's a setting somewhere else that I've forgotten about!)

  2. #2

    Member Since
    Jun 04, 2009
    Have you checked the order of connections? Network preferences...under the list of connection types there's a can change which network connects first. Maybe one is dominating the other and kicking you off?

  3. #3

    Member Since
    Dec 28, 2008
    No that's not it - the network I am using is top of the list in network preferences

  4. #4

    Member Since
    Jun 04, 2009
    Do you have the 'allow network to be extended' box checked under wireless in the airport utility?

  5. #5

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Napier NZ
    27 iMac+Thunderbolt, iMac 20, 2TB dual TC, AppleTV, iPh4S
    My understanding is that extending a network is for hanging one airport off of another, so not sure that will help. Have you tried setting up a Location on the MBA specifically for your wireless network instead of using Location - Automatic. Make sure that you have all settings in Network such as "Using DHCP" and your ISPs DNS numbers listed under the IP for the Router like this;

    Click for full size - Uploaded with plasq's Skitch

  6. #6

    Member Since
    Dec 28, 2008
    Thank you all for the posts. I have tried many of the suggestions - including the location one above - I hadn't seen that feature before.
    Nothing made any difference really. I have now physically moved my Router (extra network cabling kind of wasting the Wifi concept) so that now my router is only 4m from my Apple and it works fine - no network drops and no network reconnect problems.
    Seems a shame to me that Apple - who produce such great looking and functional products - seem to have problems with WiFi - my HP laptop - which is bulky and not as pretty (and doesn't run all the cool Mac apps) is sitting there right next to my Mac Air and hasn't dropped WiFi at all throughout the problems the air has had with Wifi connections.
    I am hopeful that Apple will be able to release some software solutions because of the great little utility I've been using called Airgrab Wifi Radar. This app shows the various Wifi networks in range and their channels and signal strengths. I've noticed that when the airport utility in the tray drops the line completely (and sometimes doesn't even show it as an available network to manually reconnect to) the Airgrab utility shows the network is still there and with decent signal strength. Could it just be bad programming on the use of the wireless card in the Air? I hope so - in which case - COME ON APPLE - sort it out!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Airport does not automatically reconnect to Wi-Fi when waking from sleep
    By techbulletin1 in forum macOS - Operating System
    Replies: 4
    Last Post: 07-16-2010, 08:46 AM
  2. Won't connect to wireless networks.
    By ImageX in forum Running Windows (or anything else) on your Mac
    Replies: 3
    Last Post: 08-31-2009, 10:13 PM
  3. My MacBook (aluminum 2.4) Won't automatically connect to preferred networks
    By HenryTypeS in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 04-05-2009, 03:34 AM
  4. Automatically Reconnect To Server
    By Connaught in forum Switcher Hangout
    Replies: 1
    Last Post: 01-07-2009, 09:53 PM
  5. Replies: 2
    Last Post: 09-13-2006, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts