Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Internet, Networking, and Wireless (http://www.mac-forums.com/forums/internet-networking-wireless/)
-   -   Mac doesn't recognize airport password (http://www.mac-forums.com/forums/internet-networking-wireless/152653-mac-doesnt-recognize-airport-password.html)

Jasmine Rice 05-22-2009 01:26 AM

Mac doesn't recognize airport password
 
I just moved and had new internet set up. As usual, I entered a password for my internet and joined my network, but the password I entered was wrong and the Mac has already remembered that wrong password. So I turned airport off and turned it on again to enter the right password, but mac doesn't recognize the right password even though I checked "remember this network" everytime, it keeps using the wrong one.

So I went into KeyChain under Application, delete the airport network password of my network, turned airport off and on again to enter the right password. Now, KeyChain doesn't log in the network password at all. So every time I turn on the computer it asks me to join the network and type in the password. It even prompts me to enter join the network every time it awakes from sleep.

I check "remember this network" everytime. I tried every possible method...like deleting the .com.airport.preference.plist, deleting all the log in password in KeyChain, but after I enter the password it still does the same thing. I basically have to enter the internet password and join my network every time the computer starts and awakes from sleep.

I think it is caused by me deleting the airport password in KeyChain at the first place. So now what should I do to solve this annoying problem? Thanks.

Collin Bl 05-22-2009 04:13 AM

Try creating a new user and setting it up to connect to your network. If you are successful with that then it could show up where your current set up is failing.

bobtomay 05-22-2009 11:15 AM

Open System Preferences - Network

highlight Airport on the left if not already

click the Advanced button

make sure you are on the Airport tab

In the Preferred Networks box - delete any old networks that are not being used any longer (highlight and hit the - button)and move the one you want to join automatically (drag it) to the top of the list

I've also had success with this problem by deleting all the networks in that Preferred Networks box and then adding it back in.

Jasmine Rice 05-22-2009 02:49 PM

I tried your method. I deleted all the preferred networks under Airport in system preference, and add it back up again. And now I find my network password showing up in keychain again!

But it still prompts me to select a network every time I turn on the mac, but now at least it remembers the password, I don't have to type it in anymore, I just have to select my network and hit "join". The "remember this network" is checked. How can I have my mac just connect to my network automatically without me having to join the network every time? Thanks

Brighteyes9 05-23-2009 12:00 AM

If you go back into network, Airport, Advanced make sure your network is the first on the preferred networks list and just below the box "Remember any network this computer has joined" is checked. That's all I can think of.

GL.

Jasmine Rice 05-23-2009 05:48 PM

Quote:

Originally Posted by Brighteyes9 (Post 849175)
If you go back into network, Airport, Advanced make sure your network is the first on the preferred networks list and just below the box "Remember any network this computer has joined" is checked. That's all I can think of.

GL.


I already did that. It still ask me to join the network when I start the computer.


All times are GMT -4. The time now is 04:32 AM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.