Results 1 to 2 of 2
  1. #1

    Member Since
    Feb 07, 2009
    wireless and self-assigned IP
    MacBook 2.0 GHz Aluminum, 4 Gigs memory, OS X 10.5.6 with all updates, etc--Great machine (new as of Feb).

    About 2 or 3 weeks ago I began to have trouble with wireless connection. Originally, I had set up wireless to connect to an unprotected network at the office (a university campus) and at home with a WPA encryption passphrase (WPA personal; I had also tried WEP). Airport is set to use DHCP (it needs to in my office). Firewall is on and set to Set Access to Specific Programs and in stealth mode. Both networks were in the profile Automatic and I had checked "Remember this network".

    This worked flawlessly until 2 or so weeks ago. That is when upon boot or upon turning on Airport, signal would show strong in the menu bar applet but I was not connected to the internet. Looking in System Preferences/Network would be the message "...self-assigned IP..blah blah" with an IP of 169.other stuff. Not cool.

    At this point the only thing I could do is go kill the firewall, wait about 3 seconds, and then turn it back on. Needless to say not an ideal solution.

    I have searched these and other forums and tried various suggested solutions including (at home) repowering everything (Cable modem, wireless router (NETGEAR) and computer), deleting certain file in
    /Library/Preferences/System Configuration, etc. NONE of these worked.

    One solution I have found is to delete my two wireless networks from System Preferences/Network/Advanced, uncheck the box for the computer to remember all networks it connects to. Now upon boot or upon starting Airport, it will connect but a pop up window appears with the question: Do you want to allow "configd" to accept incoming network connections? (I hit enable button).

    The other solution is to simply leave the firewall turned off, one I do not like.

    The first solution is acceptable to me as I tend to turn off Airport so I do not get annoyed with email, chat stuff, etc when I am working. It just means that everytime I boot or awake from sleep and want the internet, I have to choose the network to connect to from the menu bar applet--no big deal.

    Anyone else experienced this?? Is there a better solution??

    Evidently something changed with the update to Mac OS X 10.5.6 a few weeks ago and configd is not seeing through the firewall as it should, hence dhcp cannot see out.

  2. #2

    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Napier NZ
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    You could find life much better by setting up locations for each of the places that you use your laptop. Sys Prefs/Network/Location/Edit Locations.
    If you enter a name for each of the locations as well as other settings and then add the DNS IP address to the box then it will connect better at each place with the required location selected in Apple drop down menu.
    See here;
    Sys Prefs/Network/Location/Airport/Advanced/DNS where the Location is school for example. Don't overwrite the modem IP address if that appears but do it like this, just add numbers in groups of 4 eg; = router = DNS Primary = DNS Secondary

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Self-Assigned IP
    By guzzyo in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 10-02-2014, 09:07 PM
  2. Self-assigned IP problem
    By makowa_panienka in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 05-03-2011, 01:31 PM
  3. Self-assigned IP
    By nena1110 in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 01-10-2011, 05:23 PM
  4. Can't connect to wireless/self assigned IP
    By TwizzStackie in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 09-03-2010, 04:16 PM
  5. Self-Assigned IP
    By Zadarkh in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 05-18-2009, 12:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts