Mac Forums

Mac Forums (http://www.mac-forums.com/forums/)
-   Internet, Networking, and Wireless (http://www.mac-forums.com/forums/internet-networking-wireless/)
-   -   Wireless fine on MacBook but not on iMac (http://www.mac-forums.com/forums/internet-networking-wireless/150159-wireless-fine-macbook-but-not-imac.html)

joosid 04-27-2009 06:21 AM

Wireless fine on MacBook but not on iMac
 
I have a MacBook & a new iMac. The MacBook's wireless works perfectly at my house - always a high signal, lightning fast, no problems whatsoever.

But, my iMac won't stay connected! I had this same problem at my office with another router, so I know it's not a router problem. Laptop was fine, iMac not so much.

The network is showing up in the network preferences, and it does connect, but the signal is really weak (one or two bars compared with full signal on my MacBook).

Not sure if this is where the problem lies, but when I click on the wireless icon on my MacBook, it says "Airport: On". On my iMac, I click the icon and it says "Airport: Scanning...". I have no clue why it's doing this and it's starting to get REALLY frustrating! Can anyone help???

dtravis7 04-27-2009 06:22 AM

An iMac G5 is an older computer. It's not new. Are you talking about a new Intel iMac or an older G5 iMac? Very different machines. A G5 is a Power PC CPU and will not run any X86 OS.

joosid 04-27-2009 06:38 AM

Sorry - it's a new iMac - 2.66GHz Intel Core 2 Duo.

Collin Bl 04-27-2009 03:33 PM

Think i would be taking it back while it is under warranty, my 2.2 MBP has same indications as 2.4 iMac when on LAN


All times are GMT -4. The time now is 08:07 PM.

Powered by vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.