I have a Macbook that I purchased 2 years ago, and realise that the OS System is a bit older then the new interfaces (I have run all the software updates throughout the years that I am prompted for)...

When I purchased my macbook I also bought an airport extreme to use as my wireless router at home. However, about 2 weeks ago, i got problems with it saying "PPPoE not found".... so basically I reset, tried to fix it all again and it failed... eventually in frustration I purchased an Airport Express to use at home.

I went home quite optimistic that it would solve my problems and end the frustration. However, when I plugged it into my modem, the light just keeps flashing Amber.... then I went into Airport Utilities and it found the airport express BUT when I went in to change the settings (i.e. give it a name, enter security, enter internet connection username and passwords etc) I realised that the version on my computer of Airport Utilities was out dated for this new airport express. So I went to the Apple Support website and downloaded the new software.

After this, I opened the new software and I selected "Create new wireless network".. it all worked fine, i could enter a network name, password, but then it asked me for a prompt "Continuing will make the amber light on the express flash, to avoid press ignore" (something like this)... the problem is, there was no continue key to select from, all I had was SKIP, IGNORE and CANCEL?? No matter what I clicked I couldnt continue??

Can anybody please offer some advice for me please, as you can imagine its pretty frustrating and its the first difficulty I have had with an apple product.... (as you can tell I am not very computer savvy)...